• linkedu视频
  • 平面设计
  • 电脑入门
  • 操作系统
  • 办公应用
  • 电脑硬件
  • 动画设计
  • 3D设计
  • 网页设计
  • CAD设计
  • 影音处理
  • 数据库
  • 程序设计
  • 认证考试
  • 信息管理
  • 信息安全
菜单
linkedu.com
导航菜单
  • 网页制作
  • 数据库
  • 程序设计
  • 操作系统
  • CMS教程
  • 游戏攻略
  • 脚本语言
  • 平面设计
  • 软件教程
  • 网络安全
  • 电脑知识
  • 服务器
  • 视频教程
  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx
您的位置:首页 > 服务器 >虚拟化 > docker daemon远程连接设置详解

docker daemon远程连接设置详解

作者:推背图 字体:[增加 减小] 来源:互联网

本文主要包含docker,daemon,docker,daemon远程连接等服务器相关知识,推背图 希望可以进行参考

Docker为C/S架构,服务端为docker daemon,客户端为docker.service.支持本地unix socket域套接字通信与远程socket通信。默认为本地unix socket通信,要支持远程客户端访问需要做如下设置(仅用于测试,生产环境开启会极大增加不安全性:由于开了监听端口,任何人可以通过远程连接到docker daemon服务器进行操作):

1、设置daemon监听连接:

添加本地默认监听端口,模式为IP:port

Ubuntu:

修改daemon配置:/etc/docker/daemon.json,添加如下行:

重启docker:

systemctl restart docker.service(Ubuntu16.04) 

查看有了“-H”表示成功

root@ubuntu:~# ps aux|grep dockerd 
root   113731 0.5 0.1 636160 47536 ?    Ssl 10:54  0:00 /usr/bin/dockerd -H unix:///var/ -H tcp://0.0.0.0 
root@ubuntu:~# netstat -lant|grep 2375 
tcp6    0   0 :::2375         :::*          LISTEN  

Centos7:

/etc/docker/daemon.json会被docker.service的配置文件覆盖,直接添加daemon.json不起作用。可以有如下几种设置:

1、直接编辑配置文件:Centos中docker daemon配置文件在/lib/systemd/system/docker.service,找到以下字段,在后面添加如下,注意,此处不能用"fd://",否则报错

... 
[Service] 
... 
ExecStart=/usr/bin/dockerd -H unix:///var/run/docker.sock -H tcp://0.0.0.0:2375 

执行

systemctl daemon-reload 
systemctl restart docker.service 

2、systemctl edit docker.service,或者编辑vim /etc/systemd/system/docker.service.d/override.conf(必须这样,少一行都不行,unix://也不能按官方写fd://)

[Service] 
ExecStart= 
ExecStart=/usr/bin/dockerd -H unix:///var/run/docker.sock -H tcp://0.0.0.0:2375 

同样执行

systemctl daemon-reload 
systemctl restart docker.service 

最后查看是否成功,添加了-H参数,启动了端口(端口默认为2375,但是可以改):

[root@myrepo docker.service.d]# ps aux|grep dockerd 
root   5567 8.0 2.0 632976 37696 ?    Ssl 15:08  0:00 /usr/bin/dockerd -H tcp://0.0.0.0:2376 -H unix:///var/run/docker.sock 
root   6143 0.0 0.0 112660  976 pts/0  S+  15:08  0:00 grep --color=auto dockerd 
[root@myrepo docker.service.d]# netstat -lant|grep 2376 
tcp6    0   0 :::2376         :::*          LISTEN 

以上就是本文的全部内容,希望对大家的学习有所帮助,也希望大家多多支持。

您可能感兴趣的文章:

  • ubuntu vps安装docker报错:Cannot connect to the Docker daemon at unix:///var/run/docker.sock.问题解决
  • Docker出现Cannot connect to the Docker daemon. Is the docker daemon running on this host错误解决办法
  • 解决执行docker daemon命令时出错的问题
  • Docker daemon 无法启动: does not match with stored UUID错误解决办法
分享到:QQ空间新浪微博腾讯微博微信百度贴吧QQ好友复制网址打印

您可能想查找下面的文章:

  • Docker实践8:Compose,docker实践compose
  • Docker buildx构建多平台镜像并推送到私有仓库的方法
  • Docker三个基本概念镜像(Image)容器(Container)仓库(Repository)
  • 什么是Docker?为什么要使用Docker
  • docker 开源的应用容器引擎
  • 如何给docker设置http代理
  • docker官方mysql镜像自定义配置详解
  • 详解Docker数据管理(数据卷&数据卷容器)
  • 如何利用Docker容器实现代理转发与数据备份详解
  • 详解Docker Swarm 在持续集成测试中的应用

相关文章

  • CloudStack SSVM启动条件源码阅读与问题解决方法
  • Centos 7中Docker私有仓库的搭建方法
  • VirtualBox配置虚拟网卡(桥接)——实现主机-虚拟机网络互通
  • kvm虚拟化学习笔记(一)之kvm虚拟化环境安装的步骤
  • 详解使用Hyper-V安装Ubuntu Server 16.10
  • Docker容器通过独立IP暴露给局域网的方法
  • docker中修改镜像容器的存放目录的方法
  • 虚拟化和云计算的区别分析
  • 详解docker强制批量删除none的image镜像
  • VMware 10 中为CentOS 7添加多网卡并重命名

文章分类

  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx

最近更新的内容

    • 使用Docker Swarm搭建分布式爬虫集群的方法示例
    • docker一键安装wordpress的方法步骤
    • Docker daemon 无法启动: does not match with stored UUID错误解决办法
    • 解决docker pull被复位出现的问题
    • openstack 重启的服务命令整理总结
    • VMware设置桥接上网(图文详解)
    • VMWare 虚拟机Centos7安装Oracle数据库的教程图解
    • CentOS7 阿里云的yum源使用详解
    • Spark三种属性配置方式详解
    • 关于Docker容器内部无法解析域名问题的解决

关于我们 - 联系我们 - 免责声明 - 网站地图

©2020-2025 All Rights Reserved. linkedu.com 版权所有