• linkedu视频
  • 平面设计
  • 电脑入门
  • 操作系统
  • 办公应用
  • 电脑硬件
  • 动画设计
  • 3D设计
  • 网页设计
  • CAD设计
  • 影音处理
  • 数据库
  • 程序设计
  • 认证考试
  • 信息管理
  • 信息安全
菜单
linkedu.com
导航菜单
  • 网页制作
  • 数据库
  • 程序设计
  • 操作系统
  • CMS教程
  • 游戏攻略
  • 脚本语言
  • 平面设计
  • 软件教程
  • 网络安全
  • 电脑知识
  • 服务器
  • 视频教程
  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx
您的位置:首页 > 服务器 >虚拟化 > CentOS7 docker服务无法启动解决方案及实现步骤

CentOS7 docker服务无法启动解决方案及实现步骤

作者:康赛拉 字体:[增加 减小] 来源:互联网

本文主要包含CentOS7,docker服务无法启动,CentOS7,docker服务无法启动解决办法,CentOS7,docker服务出错等服务器相关知识,康赛拉 希望可以进行参考

CentOS7  docker服务无法启动解决方案

检查步骤

启动docker服务:

systemctl restart docker

这个时候会报错,请进行以下步骤:

1. 找到报错的类型,或者报错的说明。
2. 检查docker的配置文件
3. 检查磁盘空间
4. 检查端口占用情况

步骤详解

检查报错类型,查看日志:

journalctl -xe

检查配置文件,不同操作系统位置基本相同:

/etc/sysconfig/docker/

或者直接找到docker运行程序,一般会有相关配置文件的默认路径

检查磁盘空间:

df -h

检查端口占用:

netstat -anp

实例

报错信息如下:

-- Unit docker.service has begun starting up.
Dec 04 21:17:46 localhost.localdomain docker[7175]: time="2016-12-04T21:17:46.093155159+08:00" level=warning msg="/!\\ DON'T BIND ON ANY IP ADDRESS WITHOUT setting -tlsverify IF YOU DON'T KNOW WHAT YOU'RE DOING /!\\"
Dec 04 21:17:46 localhost.localdomain docker[7175]: time="2016-12-04T21:17:46.093322868+08:00" level=fatal msg="listen tcp 172.17.0.1:2376: bind: cannot assign requested address"
Dec 04 21:17:46 localhost.localdomain systemd[1]: docker.service: main process exited, code=exited, status=1/FAILURE
Dec 04 21:17:46 localhost.localdomain systemd[1]: Failed to start Docker Application Container Engine.
-- Subject: Unit docker.service has failed
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- Unit docker.service has failed.

解决方案:

上一篇文章已经说过了简单暴力的解决方案,就是清理/var/lib/docker这个目录,重置设置。

然而,并不清楚具体原因。今天服务器有断电了,服务还是报错。说明了一点,简单暴力的手段并不是好的解决方案,治标不治本。这里重新分析了先问题:

可以看到fatal msg”listen tcp 172.17.0.1:2376: bind: cannot assign requested address“,说的是绑定了一个端口,但是这个地址和端口又不能分配。

上一行大意“你要是不懂,就别瞎绑定端口”,囧。。

找了很久没有在/var/lib/docker的目录下找到关于2376端口bind的配置,思量半天,突然感觉是程序启动的配置文件,最后在/etc/sysconfig/docker目录下找到了。额,这个是之前为了实现一个跟jenkins相关的功能绑定的,并不是瞎邦的。暂时注释掉bind设置的这行,重启服务。ok~

感谢阅读,希望能帮助到大家,谢谢大家对本站的支持!

您可能感兴趣的文章:

  • CentOS7 安装docker 解决启动不了的问题
  • centos7 安装docker步骤详细介绍
  • docker centos7 安装ssh具体步骤
  • centos7系统下搭建docker本地镜像仓库的方法
  • Docker在CentOS7下不能下载镜像timeout的解决办法(图解)
  • 在Centos7 中更改Docker默认镜像和容器的位置
  • Centos7下安装Docker Engine
  • Docker CentOS7的系统上安装部署以及基础教程
  • 详解centos7 docker1.12安装私有仓库
  • CentOS7.2下安装docker容器教程
分享到:QQ空间新浪微博腾讯微博微信百度贴吧QQ好友复制网址打印

您可能想查找下面的文章:

  • VMware14 上安装CentOS 7 图文教程
  • CentOS 7中搭建KVM虚拟化平台的方法步骤
  • CentOS7虚拟机安装并配置docker套件
  • centos7更改docker仓库的方法
  • Centos7下安装与卸载docker应用容器引擎的方法
  • CentOS7.2服务器上搭建Docker私有镜像仓库操作示例
  • VMWare 虚拟机Centos7安装Oracle数据库的教程图解
  • centos7搭建docker私人仓库的方法(kubernetes)
  • CentOS7.2下安装docker容器教程
  • VirtualBox下CentOS7网络配置教程(可连外网)

相关文章

  • 详解基于本地存储的kvm虚拟机在线迁移
  • 详解使用docker搭建kafka环境
  • Docker之开启远程访问的实现
  • 详解Docker私有仓库最简便的搭建方法
  • docker中使用mysql数据库详解(在局域网访问)
  • docker快速入门教程
  • OpenStack Keystone的基本概念详细介绍
  • Docker下Tomcat容器中使用Mysql的方法
  • 基于Docker的PHP调用基于Docker的Mysql数据库
  • 基于Docker 搭建WordPress的方法

文章分类

  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx

最近更新的内容

    • ubuntu 下VirtualBox 如何实现共享设置
    • 8个你可能不知道的Docker知识
    • 详解Ubuntu Docker Registry 搭建私有仓库
    • 如何Docker化Python Django应用程序
    • Docker如何固定IP设置的方法
    • Docker 镜像、容器、仓库的概念及应用详解
    • 服务器虚拟资源分配原则如何制定?
    • vmware Esxi 5.0 忘记密码重置的方法
    • Docker搭建私有镜像仓库的方法
    • docker cgroup 资源监控的详解

关于我们 - 联系我们 - 免责声明 - 网站地图

©2020-2025 All Rights Reserved. linkedu.com 版权所有