• linkedu视频
  • 平面设计
  • 电脑入门
  • 操作系统
  • 办公应用
  • 电脑硬件
  • 动画设计
  • 3D设计
  • 网页设计
  • CAD设计
  • 影音处理
  • 数据库
  • 程序设计
  • 认证考试
  • 信息管理
  • 信息安全
菜单
linkedu.com
导航菜单
  • 网页制作
  • 数据库
  • 程序设计
  • 操作系统
  • CMS教程
  • 游戏攻略
  • 脚本语言
  • 平面设计
  • 软件教程
  • 网络安全
  • 电脑知识
  • 服务器
  • 视频教程
  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx
您的位置:首页 > 服务器 >虚拟化 > Xen虚拟机在CentOS系统中的安装和使用方法

Xen虚拟机在CentOS系统中的安装和使用方法

作者: 字体:[增加 减小] 来源:互联网

本文主要包含centos,xen,centos7安装xen,xen虚拟机等服务器相关知识,希望可以进行参考

一、原理讲解

    虚拟化的概念:将服务器物理资源抽象成逻辑资源,让一台服务器变成几台甚至上百台相互隔离的虚拟服务器,我们不再受限于物理上的界限,而是让CPU、内存、磁盘、I/O等硬件变成可以动态管理的“资源池”,从而提高资源的利用率,简化系统管理,实现服务器整合,让IT对业务的变化更具适应力--------这就是服务器的虚拟化。

    XEN是目前Linux上的最佳的虚拟化解决方案,特别适合于服务器应用,如用于将多个服务器合并到一台物理服务器上,以节省运营成本(机房空间、电力消耗);或者是出于安全角度的考虑,需要将不同的应用进行分区,以便降低安全风险等。

1、名词:

  完全虚拟化(Full Virtualization):full virtualized

  半虚拟化(Para Virtualization):paravirtualized

2、XEN的运行环境:Domain-0与Domain-U

  Domain-0即虚拟母机或称为宿主机,与Linux主机为同一系统,以XEN的Linux内核启动的主机,负责管理和控制客户机。

  Domain-U即虚拟客户机或称VPS,在Domain-0上可以建立多个虚拟客户机。

  Domain-0与Domain-U的区别就是Domain-0是虚拟机,Domain-U是虚拟机上的操作系统。用过Windows上VMWare的可以把Domain-0理解为VMWare软件,Domain-U则是运行在VMWare上的操作系统。

3、XEN的运行方式:

  XEN分成多个层级 (layer) 执行。它将Linux的核心修改后,再使用修改过的核心开机,而开机后先载入XEN的监控器 (Hypervisor) , 并且启动第一个操作系统,称为domain-0。在Xen上面所谓的一个domain就是指一个虚拟机。

  Domain-0之所以要先被载入是因为Domain-0含有其他虚拟机启动所必须的控制指令,并且domain-0也是控制虚拟装置的重要主控系 统。在domain-0上最重要的就是一个xend的常住进程,其他的domain都是由这个xend来管理的。至于命名方面,除了domain-0之外 的其他虚拟机就依序被称为domain-1, domain-2等等, 我们统称为domain-U。

  Domain-0是很重要的,因为它直接控制Xen的监控器(Hypervisor),而且掌握了真实的Linux驱动程序 (drivers)。而其他的虚拟机(domain-U)则是透过Xen监控器来与真实的硬件以及domain-0进行交互。为了让domain-0能够 与Xen结合,我们必须要修改domain-0的核心才能顺利运行。并且需要使用domain-0的核心来开机才可以。domain-0是所有虚拟机的基 础,所以它可以尽量简洁,其他的个别服务则可以放置到不POP时尚资讯网同的domain中。xend可以管理domain-0与其他domain之间的启动与交互,提供一个终端控制 (console) 界面来让 domain-0 登入其他的 domain。

二、必要条件

1、硬件说明:

请在服务器BIOS设置中打开关于CPU的虚拟技术;由于品牌、型号不一样请仔细查找。

2、系统查看CPU不否支持虚拟化

查看CPU对虚拟化的支持程度:

  Intel和AMD的半虚拟化支持标识 - PAE

  # cat /proc/cpuinfo | grep flags
  flags : fpu tsc msr pae mce cx8 apic mtrr mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss nx constant_tsc pni ssse3

INTEL全虚拟化支持标识 - VMX

  # cat /proc/cpuinfo | grep flags
  flags : fpu tsc msr pae mce cx8 apic mtrr mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx lm constant_tsc up pni monitor ds_cpl vmx est tm2 cx16 xtpr lahf_lm

AMD全虚拟化支持标识 - SVM

  # cat /proc/cpuinfo | grep flags
  flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt rdtscp lm 3dnowext 3dnow pni cx16 lahf_lm cmp_legacy svm extapic cr8legacy 3dnowprefetch ts fid vid ttp tm stc 100mhzsteps

 三、初始Xen

    1、配置本地光盘yum

     CentOS系统只把光盘挂载便可以使用本地源。

    2、安装Xen

  #yum install xen kernel-xen xen-lib virt-manager python-virtinst –y

    3、作用理解

        kernel-xen:可以跑 Xen 的 Linux 核心

        xen:主要的 xen 套件,包括配置文件、启动脚本和一些函数库

        xen-libs:Xen 所需要的函数库

        python-virtinst:提供终端安装的软件

        virt-manager:用于图形界面管理xen

        查看/etc/grub.conf

        选择带有xen的内核,并改为使用的内核 

        #init 6

        重启之后,查看内核

        #uname –r

        2.6.18-274.12.1.e15xen

        #xm list

        Domain-0 

四、安装Xen(图形化)

1、打开“应用程序” CentOS <wbr>Xen <wbr>安装及使用

2、打开“系统工具”,选择“虚拟系统

3、选择“localhost”,鼠标右击“新建”  

4、点击“前进” 

5、虚拟机命名 

6、选择系统架构,多数由CPU决定

7、选择引导模式(ISO、PXE)

8、指定位置

9、指定硬盘大小(allocate entire virtual disk now 使用整个硬盘)

10、指定网络

11、指定内存大小

12、虚拟机全部信息

13、开始“创建”

14、安装后台

五、常见错误描述及解决办法

   1、通过http或NFS安装客户机操作系统出现 Unable to retrieve 错误:....

  多数原因是防火墙造成的,如果使用http安装方式时可以先停止防火墙,也可以采用以下方式解决:
通过iptables  -L命令查询是否有打开80端口或者netstat tunlp | grep httpd
开放端口

  iptables –I INP
  


 
分享到:QQ空间新浪微博腾讯微博微信百度贴吧QQ好友复制网址打印

您可能想查找下面的文章:

  • centos 下docker 安装方法
  • VMware14 上安装CentOS 7 图文教程
  • CentOS 7中搭建KVM虚拟化平台的方法步骤
  • CentOS7虚拟机安装并配置docker套件
  • centos7更改docker仓库的方法
  • Centos7上安装docker的方法
  • Centos7下安装与卸载docker应用容器引擎的方法
  • CentOS7.2服务器上搭建Docker私有镜像仓库操作示例
  • VMWare 虚拟机Centos7安装Oracle数据库的教程图解
  • centos7搭建docker私人仓库的方法(kubernetes)

相关文章

  • 详解基于Docker的服务部署流程
  • 如何为Go程序创建一个最小的Docker Image详解
  • centos7更改docker仓库的方法
  • 详解将本地docker容器迁移到服务端
  • 利用Docker制作Nginx+PHP镜像的步骤详解
  • Docker daemon 无法启动: does not match with stored UUID错误解决办法
  • Windows使用docker打开新窗口error解决办法
  • Ubuntu 16.04中Docker的安装和代理配置教程
  • Docker 实现浏览器里开发Android应用的功能
  • 深究开源虚拟化KVM热潮

文章分类

  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx

最近更新的内容

    • Docker学习笔记之容器查看启动终止删除的方法
    • 详解在Docker容器中运行Spring Boot应用
    • 将博客迁移至docker纪实
    • CentOS系统中一键安装Openstack图文教程
    • Docker容器中文乱码(修改docker容器编码格式)的解决方案
    • 使用Docker安装phabricator的配置和使用方法
    • KVM虚拟化:选REHL还是RHEV?
    • Docker命令行与守护进程的交互方法
    • docker在ubuntu14.04下的安装步骤
    • openstack 重启的服务命令整理总结

关于我们 - 联系我们 - 免责声明 - 网站地图

©2020-2025 All Rights Reserved. linkedu.com 版权所有