• linkedu视频
  • 平面设计
  • 电脑入门
  • 操作系统
  • 办公应用
  • 电脑硬件
  • 动画设计
  • 3D设计
  • 网页设计
  • CAD设计
  • 影音处理
  • 数据库
  • 程序设计
  • 认证考试
  • 信息管理
  • 信息安全
菜单
linkedu.com
导航菜单
  • 网页制作
  • 数据库
  • 程序设计
  • 操作系统
  • CMS教程
  • 游戏攻略
  • 脚本语言
  • 平面设计
  • 软件教程
  • 网络安全
  • 电脑知识
  • 服务器
  • 视频教程
  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx
您的位置:首页 > 服务器 >windows > nginx main和events模块学习

nginx main和events模块学习

作者:网友 字体:[增加 减小] 来源:互联网

本文主要包含nginx main和events模块学习等服务器相关知识,网友希望可以进行参考

nginx配置文件主要分为六个区域:main section、events section、http section、sever section、

location section、upstream section。依据这个分类学习nginx的模块。


main module:主要控制子进程的所属用户/用户组、派生子进程数、错误日志位置/级别、pid位置、子进程优先级、进程对应cpu、进程能够打开的文件描述符数目等。

user kingnet kingnet;
worker_processes 4;
error_log logs/error.log notice;
pid logs/nginx.pid;
# worker_priority -5;
# worker_cpu_affinity 0001 0010 0100 1000;
worker_rlimit_nofile 1024;

注:worker_cpu_affinity:指定进程对应cpu,上面配置是第一个进程对应cpu0,第二个进程对应cpu1,第三个进程对应cpu2,第四个进程对应cpu3,也可以指定一个进程对应多个cpu。比如0101表示进程对应cpu0/cpu2。

worker_rlimit_nofile:指定每个woker可以打开的文件描述符数目,一般和worker_connections的值是相同的。


event module:控制nginx处理连接的方式。

events {
    use epoll;
    worker_connections 10240;
}

注:use:使用网络IO模型,epoll模型比select模型效率高很多。

worker_connections:每个worker能够处理的最大连接数,取决于ulimit -n的值。

nginx并发连接数:<worker_processes*worker_connections。

关于网络IO模型以后需详细学习。


参考文档

http://www.howtocn.org/nginx:nginx%E6%A8%A1%E5%9D%97%E5%8F%82%E8%80%83%E6%89%8B%E5%86%8C%E4%B8%AD%E6%96%87%E7%89%88

http://wiki.nginx.org/NginxChs



本文出自 “fly天地” 博客,请务必保留此出处http://liuping0906.blog.51cto.com/2516248/1298253

分享到:QQ空间新浪微博腾讯微博微信百度贴吧QQ好友复制网址打印

您可能想查找下面的文章:

相关文章

  • 远程桌面连接服务器和修改远程端口图解
  • centos 6.4下的samba服务器的构建
  • Windows8系统自带Hyper-V虚拟机
  • windows服务器修改密码图文教程
  • 来到这里的第一天
  • 用来安装 Microsoft Windows 的产品密钥可能无效
  • Linux学者必备文件通配符掌握8
  • IIS8中添加WCF支持几种方法总结
  • 垃圾、无用文件无法删除问题的解决办法
  • WEB服务器的跨域攻击方法介绍

文章分类

  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx

最近更新的内容

    • windows 安装 mongodb 服务图文教程
    • Zabbix之配置文件详解
    • memached启动报错
    • 禁止Windows Server 2008 R2密码过期提示
    • linux高级安全PAM使用
    • 在CentOS 5上配置NFS服务器
    • windows 2003 如何用cmd命令,批量修改设置目录的安全权限
    • srosa.sys插件导致计算机蓝屏故障
    • Corosync/Openais+Pacemaker+ISCSI+OCFS:构建高可用Web群集
    • 无法打开用户默认数据库的解决方法

关于我们 - 联系我们 - 免责声明 - 网站地图

©2020-2025 All Rights Reserved. linkedu.com 版权所有