• linkedu视频
  • 平面设计
  • 电脑入门
  • 操作系统
  • 办公应用
  • 电脑硬件
  • 动画设计
  • 3D设计
  • 网页设计
  • CAD设计
  • 影音处理
  • 数据库
  • 程序设计
  • 认证考试
  • 信息管理
  • 信息安全
菜单
linkedu.com
导航菜单
  • 网页制作
  • 数据库
  • 程序设计
  • 操作系统
  • CMS教程
  • 游戏攻略
  • 脚本语言
  • 平面设计
  • 软件教程
  • 网络安全
  • 电脑知识
  • 服务器
  • 视频教程
  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx
您的位置:首页 > 服务器 >Linux > Centos 6.5下安装MySQL 5.6

Centos 6.5下安装MySQL 5.6

作者:网友 字体:[增加 减小] 来源:互联网

本文主要包含centos6.5安装mysql,centos6.5下安装mysql,centos安装mysql,centos下安装mysql,centos安装mysql5.7等服务器相关知识,网友希望可以进行参考

Centos 6.5下安装MySQL 5.6


1.下载Linux对应的RPM包

http://dev.mysql.com/downloads/mysql/5.6.html

wget http://cdn.mysql.com//Downloads/MySQL-5.6/MySQL-5.6.33-1.el6.x86_64.rpm-bundle.tar
  • 1
  • 1

2.解压tar包

tar -xvf MySQL-5.6.33-1.el6.x86_64.rpm-bundle.tar
  • 1
  • 1

3.安装MySQL

rpm -ivh MySQL-server-5.6.33-1.el6.x86_64.rpm rpm -ivh MySQL-client-5.6.33-1.el6.x86_64.rpm rpm -ivh MySQL-devel-5.6.33-1.el6.x86_64.rpm
  • 1
  • 2
  • 3
  • 1
  • 2
  • 3

如果出现:

error: Failed dependencies:        libaio.so.1()(64bit) is needed by MySQL-server-5.6.33-1.el6.x86_64        libaio.so.1(LIBAIO_0.1)(64bit) is needed by MySQL-server-5.6.33-1.el6.x86_64        libaio.so.1(LIBAIO_0.4)(64bit) is needed by MySQL-server-5.6.33-1.el6.x86_64
  • 1
  • 2
  • 3
  • 4
  • 1
  • 2
  • 3
  • 4

下载libaio

yum install libaio
  • 1
  • 1

如果出现:

error: Failed dependencies:        libnuma.so.1()(64bit) is needed by MySQL-server-5.6.33-1.el6.x86_64        libnuma.so.1(libnuma_1.1)(64bit) is needed by MySQL-server-5.6.33-1.el6.x86_64        libnuma.so.1(libnuma_1.2)(64bit) is needed by MySQL-server-5.6.33-1.el6.x86_64
  • 1
  • 2
  • 3
  • 4
  • 1
  • 2
  • 3
  • 4

下载numactl

yum install numactl
  • 1
  • 1

4.初始化MySQL及设置密码

/usr/bin/mysql_install_dbservice mysql start
  • 1
  • 2
  • 1
  • 2

如果启动失败可能是数据块所在目录没有权限

cat /root/.mysql_secret  #查看root账号密码mysql> SET PASSWORD = PASSWORD('123456');mysql> exit
  • 1
  • 2
  • 3
  • 1
  • 2
  • 3

如果.mysql_secret文件不存在,先停止MySQL进入安全模式设置密码

service mysql stopmysqld_safe --skip-grant-tables&mysql -u root mysqlmysql> UPDATE user SET password=PASSWORD("new password") WHERE user='root';mysql> FLUSH PRIVILEGES;
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5

5.允许远程登陆

mysql> use mysql;mysql> select host,user,password from user;mysql> update user set host='%' where user='root' and host='localhost';mysql> flush privileges;mysql> exit
  • 1
  • 2
  • 3
  • 4
  • 5
  • 1
  • 2
  • 3
  • 4
  • 5

6.设置开机自启动

chkconfig mysql onchkconfig --list | grep mysqlmysql           0:off   1:off   2:on    3:on    4:on    5:on    6:off
  • 1
  • 2
  • 3
  • 1
  • 2
  • 3

7.MySQL的默认安装位置

/var/lib/mysql/               #数据库目录/usr/share/mysql              #配置文件目录/usr/bin                     #相关命令目录/etc/init.d/mysql              #启动脚本
  • 1
  • 2
  • 3
  • 4
  • 1
  • 2
  • 3
  • 4

8.常用命令

1.使用客户端工具连接到数据库

mysql -u root -p
  • 1
  • 1

2.查看MySQL服务器中包含那些数据库

mysql>SHOW DATABASES;
  • 1
  • 1

3.查看数据库中的数据表信息

mysql>SHOW TABLES;
  • 1
  • 1

4.切换数据库

mysql>USE mysql;
  • 1
  • 1

5.创建新的数据库

mysql>CREATE DATABASE 数据库名字;
  • 1
  • 1

6.创建新的数据表

mysql>CREATE TABLE 表名 (字段定义)
  • 1
  • 1

7.删除一个数据表

mysql>DROP TABLE 数据库名.表名;
  • 1
  • 1

8.删除一个数据库

mysql>DROP DATABASE 数据库名
  • 1
  • 1

9.备份整个数据库

mysqldump -u root -p auth > mysql-auth.sql
  • 1
  • 1

10.备份数据库MYSQL中的user表

mysqldump -u root -p mysql user > mysql.host-user.sql
  • 1
  • 1

11.备份MYSQL服务器中所有数据库

mysqldump -u root -p -all-databases > mysql-all.sql
  • 1
  • 1

12.恢复数据库

mysql -u root -p [数据库名]< mysql-all.sql
分享到:QQ空间新浪微博腾讯微博微信百度贴吧QQ好友复制网址打印

您可能想查找下面的文章:

  • Centos 6.5下安装MySQL 5.6
  • CentOS6.5安装Nginx1.10.2
  • Centos中完全删除mysql的方法
  • Centos6.5 安装 MySQL5.6
  • Centos上安装MySQL社区版

相关文章

  • CentOS7安装配置mysql
  • centos下Nginx配置指南
  • centos7搭建DHCP简要服务器
  • CentOS7.2下Hadoop2.7.2的集群搭建
  • centos 7搭建原版 Minecraft 服务器
  • Nginx基础应用详解
  • 使用 Linux seq 命令生成数字序列(推荐)
  • Ubuntu 16.04源码编译安装Nginx 1.10.0
  • Centos 6.8上安装Mysql 5.6.35
  • Asp.Net Core 发布和部署(Linux + Jexus )

文章分类

  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx

最近更新的内容

    • centos7部署LAMP+xcache
    • centos5下安装mysql5.7.17
    • rsync+inotify实现实时数据同步案例
    • Centos 6.8上安装Mysql 5.6.35
    • Centos 6.5编译安装git 2.9.3
    • Ubuntu 16.04 源码编译安装PHP7
    • CentOS安装配置mariadb
    • 详解CentOS 8 VMware虚拟机设置静态ip网卡上网
    • linux下修改mysql密码
    • Linux下如何永久修改主机名的方法步骤

关于我们 - 联系我们 - 免责声明 - 网站地图

©2020-2025 All Rights Reserved. linkedu.com 版权所有