• linkedu视频
  • 平面设计
  • 电脑入门
  • 操作系统
  • 办公应用
  • 电脑硬件
  • 动画设计
  • 3D设计
  • 网页设计
  • CAD设计
  • 影音处理
  • 数据库
  • 程序设计
  • 认证考试
  • 信息管理
  • 信息安全
菜单
linkedu.com
导航菜单
  • 网页制作
  • 数据库
  • 程序设计
  • 操作系统
  • CMS教程
  • 游戏攻略
  • 脚本语言
  • 平面设计
  • 软件教程
  • 网络安全
  • 电脑知识
  • 服务器
  • 视频教程
  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx
您的位置:首页 > 服务器 >Nginx > Nginx 504 Gateway Time-out错误的解决方案

Nginx 504 Gateway Time-out错误的解决方案

作者:网友 字体:[增加 减小] 来源:互联网

本文主要包含502 bad gatewaynginx,nginx api gateway,gateway nginx,bad gateway nginx,02 bad gatewaynginx等服务器相关知识,网友希望可以进行参考

最近在centos下搭建了一个nginx的WEB服务器,但是有朋友说经常出现以下错误:

504 Gateway Time-out
The server didn't respond in time.

帮客之家编辑查了一下资料,终于解决了,现在分享如下:

在CentOS下配置lnmp组合基本上用的都是同样的配置文件,一直都没出现过问题,可最近在一个vps上安装同样的环境之后,网站在线10多人就出 现了打开速度非常缓慢的情况,有好几次都是直接达到了nginx中设置的脚本最大超时时间300秒,结果导致nginx往客户端浏览器发送了一个504 Gateway Time-out的错误代码,分析了之后改动了几处配置文件,终于避免了该情况的出现。

从错误代码基本可以确定跟nginx本身无关,主要是提交给php-fpm的请求未能正确反馈而导致,一般情况下,提交动态请求的时候,nginx会直接把 请求转交给php-fpm,而php-fpm再分配php-cgi进程来处理相关的请求,之后再依次返回,最后由nginx把结果反馈给客户端浏览器,但 我这个vps目前跑的是个纯php应用内容,实际上用户所有的请求都是php请求,有的耗费时间比较久,php-cgi进程就一直都被用满,而php- fpm本身的配置文件只打开了10组php-cgi进程,这样的话在线用户稍微多的话就会导致请求无法被正常处理而出错。

大概分析出了原因,下面做就比较容易了,首先是更改php-fpm的几处配置:

把max_children由之前的10改为现在的30,这样就可以保证 有充足的php-cgi进程可以被使用;
把request_terminate_timeout由之前的0s改为60s,这样php-cgi进程 处理脚本的超时时间就是60秒,可以防止进程都被挂起,提高利用效率。

接着再更改nginx的几个配置项,减少FastCGI的请求次 数,尽量维持buffers不变:

fastcgi_buffers由 4 64k 改为 2 256k;
fastcgi_buffer_size 由 64k 改为 128K;
fastcgi_busy_buffers_size 由 128K 改为 256K;
fastcgi_temp_file_write_size 由 128K 改为 256K。

好了,重新加载php-fpm和nginx的配置,再次测试,至今两周时间内没有再出现504 Gateway Time-out的情况,算是达到效果了。

另外,php-fpm的默认静态处理方式会使得php-cgi的进程长期占用内存而无法释放,这也是导致nginx出错的原因之一,因此可以将php-fpm的处理方式改成apache模式。
<value name=”style”>apache-like</value>

从更改完毕到现在的测试表明上述方式的效果还是很明显的,并没有发现一次Nginx502 bad gateway或504 Gateway Time-out错误。当然,如果你的VPS或者服务器的性能足够好可以根据具体情况不必做无谓的改动。

分享到:QQ空间新浪微博腾讯微博微信百度贴吧QQ好友复制网址打印

您可能想查找下面的文章:

  • Nginx 502 Bad Gateway错误的原因分析与解决方法
  • Nginx 504 Gateway Time-out错误的解决方案

相关文章

  • 更换apache到nginx的操作过程全记录
  • Nginx下统一顶级域名和www子域名实现自动转向
  • Nginx用户认证配置方法(域名/目录)详解
  • nginx 设置网站目录访问验证方法
  • nginx下文件类型错误解析漏洞及处理方法
  • nginx支持.htaccess文件实现rewrite伪静态
  • Debian 7 安装LNMP服务器命令详解
  • Nginx 502 Bad Gateway错误的原因分析与解决方法
  • nginx中隐藏响应头/返回头信息/php版本号/服务器信息
  • 使用Nginx给Google App Engine做负载均衡

文章分类

  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx

最近更新的内容

    • nginx静态压缩(ngx_http_gzip_static_module)
    • nginx下文件类型错误解析漏洞及处理方法
    • 使用Nginx给Google App Engine做负载均衡
    • nginx中隐藏响应头/返回头信息/php版本号/服务器信息
    • nginx1.1.0无缝升级升级到1.1.1教程
    • 使用 Nginx 提升网站访问速度
    • Curl监控Nginx网站状态,如回应502信息即重启php-fpm
    • nginx 设置网站目录访问验证方法
    • Nginx下设置虚拟主机的技巧一则
    • Nginx 504 Gateway Time-out错误的解决方案

关于我们 - 联系我们 - 免责声明 - 网站地图

©2020-2025 All Rights Reserved. linkedu.com 版权所有