• linkedu视频
  • 平面设计
  • 电脑入门
  • 操作系统
  • 办公应用
  • 电脑硬件
  • 动画设计
  • 3D设计
  • 网页设计
  • CAD设计
  • 影音处理
  • 数据库
  • 程序设计
  • 认证考试
  • 信息管理
  • 信息安全
菜单
linkedu.com
导航菜单
  • 网页制作
  • 数据库
  • 程序设计
  • 操作系统
  • CMS教程
  • 游戏攻略
  • 脚本语言
  • 平面设计
  • 软件教程
  • 网络安全
  • 电脑知识
  • 服务器
  • 视频教程
  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx
您的位置:首页 > 服务器 >windows > 七、编写每天定时切割Nginx日志的脚本【LNMP安装 】

七、编写每天定时切割Nginx日志的脚本【LNMP安装 】

作者:网友 字体:[增加 减小] 来源:互联网

本文主要包含nginx centos6.5 lnmp,lnmp nginx,lnmp 重启nginx,lnmp nginx配置,lnmp 日志等服务器相关知识,网友希望可以进行参考

1、创建脚本/usr/local/webserver/nginx/sbin/cut_nginx_log.sh

vi /usr/local/webserver/nginx/sbin/cut_nginx_log.sh
  输入以下内容:引用#!/bin/bash
# This script run at 00:00

# The Nginx logs path
logs_path="/usr/local/webserver/nginx/logs/"

mkdir -p ${logs_path}$(date -d "yesterday" +"%Y")/$(date -d "yesterday" +"%m")/
mv ${logs_path}access.log ${logs_path}$(date -d "yesterday" +"%Y")/$(date -d "yesterday" +"%m")/access_$(date -d "yesterday" +"%Y%m%d").log
kill -USR1 `cat /usr/local/webserver/nginx/nginx.pid`

  2、设置crontab,每天凌晨00:00切割nginx访问日志crontab -e
  输入以下内容:引用00 00 * * * /bin/bash  /usr/local/webserver/nginx/sbin/cut_nginx_log.sh


本文出自 “FlyHome” 博客,请务必保留此出处http://superfly81.blog.51cto.com/6302302/1294673

分享到:QQ空间新浪微博腾讯微博微信百度贴吧QQ好友复制网址打印

您可能想查找下面的文章:

  • 三、安装Nginx 0.8.46【LNMP安装 】
  • 四、配置开机自动启动Nginx + PHP【LNMP安装 】
  • 六、在不停止Nginx服务的情况下平滑变更Nginx配置【LNMP安装 】
  • 七、编写每天定时切割Nginx日志的脚本【LNMP安装 】
  • LNMP基于fastcgi实现nginx,php,mysql的分离

相关文章

  • IIS短文件和文件夹泄漏漏洞的分析
  • Windows Server 2008 设置简单密码的方法
  • ubuntu dnsmasq配置
  • windows搭建memcached环境配置方法
  • win2003 服务错误 在系统启动时至少有一个服务或驱动程序产生错误
  • window+Apache+Php环境配置方法
  • sendmail 服务慢的解决方法
  • shell写的检测linux系统硬件信息的脚本
  • 部署awstats分析系统
  • Raid阵列与lvm逻辑卷组(下)

文章分类

  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx

最近更新的内容

    • windows2003中cscript.exe自动启动解决办法
    • memached启动报错
    • Windows Server 2008备份Exchange Information Store
    • windows2000上怎么装PHP+MYSQL(IIS版)
    • FC-SAN和IP-SAN
    • nagios+cacti+nconf部署文档
    • UAC窗体应用程序默认配置信息读写的问题
    • mdadm软RAID的删除方法和注意事项
    • 网站提示:Bad Request(Invalid Hostname)错误分析
    • 域普通用户临时提升权限

关于我们 - 联系我们 - 免责声明 - 网站地图

©2020-2025 All Rights Reserved. linkedu.com 版权所有