• linkedu视频
  • 平面设计
  • 电脑入门
  • 操作系统
  • 办公应用
  • 电脑硬件
  • 动画设计
  • 3D设计
  • 网页设计
  • CAD设计
  • 影音处理
  • 数据库
  • 程序设计
  • 认证考试
  • 信息管理
  • 信息安全
菜单
linkedu.com
导航菜单
  • 网页制作
  • 数据库
  • 程序设计
  • 操作系统
  • CMS教程
  • 游戏攻略
  • 脚本语言
  • 平面设计
  • 软件教程
  • 网络安全
  • 电脑知识
  • 服务器
  • 视频教程
  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx
您的位置:首页 > 服务器 >windows > VM配置文件所在分区内存太小导致错误的解决方法

VM配置文件所在分区内存太小导致错误的解决方法

作者:网友 字体:[增加 减小] 来源:互联网

本文主要包含vm配置,vm 配置hadoop,tomcat vm配置,华硕k45vm配置,华硕vm590z配置等服务器相关知识,网友希望可以进行参考

前几天在自己工作机(Win2008 R2)上安装的VS等一些工具,机器的系统盘空间大幅减少到3G以下. 在此机器上用Hyper-v启动MyVirtualMachine(配给内存为5120M)时,Hyper-v报错误信息: Could not initialize memory: There is not enough space on the disk. 具体如下:

[Window Title]
Virtual Machine Connection

[Main Instruction]
The application encountered an error while attempting to change the state of 'MyVirtualMachine'.

[Content]
'MyVirtualMachine' failed to start.

Could not initialize memory: There is not enough space on the disk. (0x80070070).

Failed to create memory contents file 'C:\ProgramData\Microsoft\Windows\Hyper-V\Virtual Machines\A00AE5F2-48F9-4114-A804-A85289C8541D\A00AE5F2-48F9-4114-A804-A85289C8541D.bin' of size 5120 MB.

[Expanded Information]
'MyVirtualMachine' failed to start. (Virtual machine ID A00AE5F2-48F9-4114-A804-A85289C8541D)

'MyVirtualMachine' could not initialize memory: There is not enough space on the disk. (0x80070070). (Virtual machine ID A00AE5F2-48F9-4114-A804-A85289C8541D)

'MyVirtualMachine' failed to create memory contents file 'C:\ProgramData\Microsoft\Windows\Hyper-V\Virtual Machines\A00AE5F2-48F9-4114-A804-A85289C8541D\A00AE5F2-48F9-4114-A804-A85289C8541D.bin' of size 5120 MB. (Virtual machine ID A00AE5F2-48F9-4114-A804-A85289C8541D)

[^] Hide details [Close]

经分析发现:

MyVirtualMachine配置的文件所在磁盘为系统盘, 其空间小于3G,
此工作机Hyper-V的Virtual Machines的配置文件所在的文件夹为:%SystemDrive%\ProgramData\Microsoft\Windows\Hyper-V\Virtual Machines. (可由下方式查看:打开Hyper-v Manager,在控制台树面板中,选中当前机器->[Action]->[Hyper-v Setting]->[Server]组->[Virtual Machines])
在提示信息中Hyper-V将为MyVirtualMachine在其配置文件所在的文件夹下分配5120 MB(配给的内存大小),此时报错没有足够空间

解决办法:

转移MyVirtualMachine的配置文件到其他的磁盘(本人没有在Hyper-v Manager中发现此功能,是否存在?) 
修改此工作机上Hyper-V的Virtual Machines的配置文件所在的文件夹,按以前的配置再创建新的VM(操作成功)
修改此工作机上Hyper-V的Virtual Machines的配置文件所在的文件夹,拷贝VM的配置文件到新的目录下,然后重新启动Hyper-v服务.(尝试没有成功,Hyper-v Manager没显示拷贝过去的配置文件)
通过简单修改VM的配置文件,指定将要生成bin文件的路径到其他磁盘.(发现没有简单的配置达到此目的,没有花时间仔细研究)
结论:

VM配置文件所在磁盘空间小于其配给内存大小时,当Hyper-v启动VM时会报如下错误信息:Could not initialize memory: There is not enough space on the disk. 可通过修改此工作机上Hyper-V的Virtual Machines的配置文件所在的文件夹,按以前的配置再创建新的VM来解决.

分享到:QQ空间新浪微博腾讯微博微信百度贴吧QQ好友复制网址打印

您可能想查找下面的文章:

  • VM配置文件所在分区内存太小导致错误的解决方法

相关文章

  • 负载均衡集群解决方案 (一)LVS-DR
  • rsync 如何排除文件同步指定的文件夹
  • Windows 2003中IIS不支持FLV视频文件
  • Redis 默认配置精简及注释说明
  • Nginx下构建nagios监控平台Nagios+nrpe+nagios-plugins+pnp安装文档
  • 搭建基于Corosync+Pacemaker+NFS的高可用Web集群
  • windows中apache php环境配置方法(php.ini 配置)
  • 笔记本电脑不使用软件共享无线网络的方法
  • Hyper-V之VDI基础架构
  • nginx图片防盗链

文章分类

  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx

最近更新的内容

    • Boot Manager菜单的显示语言设置
    • 微软提供正确卸载IE7的方法并恢复IE6
    • Windows查看端口被占用的程序命令(80端口为例)
    • 怎么制作破解windows2003系统密码的PE系统教程
    • 64 位硬件和软件的优势(Office SharePoint Server 2007)
    • Windows Server 2003 的启动问题
    • Windows下安装配置apache+mysql+php运行环境详细
    • apache python 模块mod_wsgi的编译安装
    • 服务器远程桌面超出最大连接数的解决方法
    • windows shutdown实现定时关机和重启

关于我们 - 联系我们 - 免责声明 - 网站地图

©2020-2025 All Rights Reserved. linkedu.com 版权所有