• linkedu视频
  • 平面设计
  • 电脑入门
  • 操作系统
  • 办公应用
  • 电脑硬件
  • 动画设计
  • 3D设计
  • 网页设计
  • CAD设计
  • 影音处理
  • 数据库
  • 程序设计
  • 认证考试
  • 信息管理
  • 信息安全
菜单
linkedu.com
导航菜单
  • 网页制作
  • 数据库
  • 程序设计
  • 操作系统
  • CMS教程
  • 游戏攻略
  • 脚本语言
  • 平面设计
  • 软件教程
  • 网络安全
  • 电脑知识
  • 服务器
  • 视频教程
  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx
您的位置:首页 > 服务器 >windows > 无法打开用户默认数据库的解决方法

无法打开用户默认数据库的解决方法

作者:网友 字体:[增加 减小] 来源:互联网

本文主要包含oracle数据库创建用户,数据库创建用户,数据库用户名,数据库用户名和密码,修改数据库用户密码等服务器相关知识,网友希望可以进行参考

无法打开用户默认数据库,登录失败,这也是SQL Server使用者熟悉的问题之一。在使用企业管理器、查询分析器、各类工具和应用软件的时候,只要关系到连接SQL Server数据库的时候,都有可能会碰到此问题,引起此错误发生的原因比较多,下面我们就来详细分析引起此问题的原因以及解决办法。

  一、原因

  登录帐户的默认数据库被删除。

  二、解决方法:

  (一)、使用管理员帐户修改此帐户的默认数据库

  1、打开企业管理器,展开服务器组,然后展开服务器

  2. 展开"安全性",展开登录,右击相应的登录帐户,从弹出的菜单中选择,属性

  3、重新选择此登录帐户的默认数据库

  (二)、若没有其他管理员登录帐户,无法在企业管理器里修改,使用isql命令行工具

  isql /U"sa" /P"sa的密码" /d"master" /Q"exec sp_defaultdb N'sa', N'master'"

  如果使用Windows验证方式,使用如下命令行,将默认数据库改成非丢失的数据库:

  isql /E /d"master" /Q"exec sp_defaultdb N'BUILTINAdministrators', N'master'"

  (2)由于改变了系统密码导致SQLSErver无法启动

  解决办法是:

  点击运行,键入services.msc,打开服务程序,找到SQLSERVER项目,选择属性项之二-‘登录’,把登录密码改为操作系统Administrator帐户登录密码,重新启动SQLSErver,即可正常启动。

  SQL Server 2005

  在 SQL Server 2005 中,可以使用 sqlcmd 实用程序更改默认数据库。为此,请按照下列步骤操作:◆1. 单击“开始”,单击“运行”,键入 cmd,然后按 Enter。

  ◆2. 根据 SQL Server 登录使用的身份验证种类,请使用以下方法之一:• 如果 SQL Server 登录使用 Microsoft Windows 身份验证连接到该实例,请在命令提示符处键入以下内容,然后按 Enter:

  sqlcmd –E -S InstanceName –d master

  • 如果 SQL Server 登录使用 SQL Server 身份验证连接到该实例,请在命令提示符处键入以下内容,然后按 Enter:

  sqlcmd -S InstanceName -d master -U SQLLogin -P Password

  注意:InstanceName 是要连接到的 SQL Server 2005 实例的名称的占位符。SQLLogin 是已删除其默认数据库的 SQL Server 登录的占位符。Password 是 SQL Server 登录密码的占位符。

  ◆3. 在 sqlcmd 提示符处,键入以下内容,然后按 Enter:

  Alter LOGIN SQLLogin WITH DEFAULT_DATABASE = AvailDBName

  注意:AvailDBName 是可由实例中 SQL Server 登录访问的现有数据库的名称的占位符。

  ◆4. 在 sqlcmd 提示符处,键入 GO,然后按 Enter。

分享到:QQ空间新浪微博腾讯微博微信百度贴吧QQ好友复制网址打印

您可能想查找下面的文章:

  • 无法打开用户默认数据库的解决方法

相关文章

  • memached启动报错
  • windows 2003服务器配置ftp服务器图解
  • windows200/2003/2008中安装sqlserver 2000图文教程
  • apache服务无法启动多种方法总结?
  • Windows 2008 R2 Server Core .NET环境配置
  • Window2003 iis+mysql+php+zend环境配置图解
  • Windows下安装配置apache+mysql+php运行环境详细
  • 域普通用户临时提升权限
  • LFTP 软件详解
  • firefox下弹出调试器或主机应用程序正在何处运行

文章分类

  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx

最近更新的内容

    • 关闭apache error.log日志生成及按日期生成日志
    • tomcat 学习总结
    • linux高级安全ssh限制利用PAM
    • 服务器性能优化策略之gzip压缩开启方法
    • IIS中安装PHP5.2与php5.4配置方法
    • 基本信息查看总结
    • Windows Server 2008服务器系统数据安全
    • Windows操作系统的经典蓝屏场景回顾[多图]
    • 【有奖征文】让运维更有“韵味”
    • window/linux下php配置mysql方法详解

关于我们 - 联系我们 - 免责声明 - 网站地图

©2020-2025 All Rights Reserved. linkedu.com 版权所有