• linkedu视频
  • 平面设计
  • 电脑入门
  • 操作系统
  • 办公应用
  • 电脑硬件
  • 动画设计
  • 3D设计
  • 网页设计
  • CAD设计
  • 影音处理
  • 数据库
  • 程序设计
  • 认证考试
  • 信息管理
  • 信息安全
菜单
linkedu.com
导航菜单
  • 网页制作
  • 数据库
  • 程序设计
  • 操作系统
  • CMS教程
  • 游戏攻略
  • 脚本语言
  • 平面设计
  • 软件教程
  • 网络安全
  • 电脑知识
  • 服务器
  • 视频教程
  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx
您的位置:首页 > 服务器 >云计算 > openstack-glance-api.service start request repeated too quickly, refusing to start,openstackglance

openstack-glance-api.service start request repeated too quickly, refusing to start,openstackglance

作者:网友 字体:[增加 减小] 来源:互联网

本文主要包含openstack-glance-api.service start request repeated too quickly, refusing to start,openstackglance等服务器相关知识,网友希望可以进行参考

openstack-glance-api.service start request repeated too quickly, refusing to start,openstackglance


问题描述

openstack J版 centos7部署
重启服务时起不来,日志也不报错,以glance服务为例,如下:

#  systemctl start openstack-glance-api.service openstack-glance-registry.service 
Job for openstack-glance-api.service failed. See 'systemctl status openstack-glance-api.service' and 'journalctl -xn' for details.



# systemctl status openstack-glance-api.service 
openstack-glance-api.service - OpenStack Image Service (code-named Glance) API server
   Loaded: loaded (/usr/lib/systemd/system/openstack-glance-api.service; enabled)
   Active: failed (Result: start-limit) since Sat 2015-07-11 22:25:43 EDT; 19s ago
  Process: 11841 ExecStart=/usr/bin/glance-api (code=exited, status=1/FAILURE)
 Main PID: 11841 (code=exited, status=1/FAILURE)

Jul 11 22:25:43 node-82 systemd[1]: Failed to start OpenStack Image Service (code-named Glance) API server.
Jul 11 22:25:43 node-82 systemd[1]: Unit openstack-glance-api.service entered failed state.
Jul 11 22:25:43 node-82 systemd[1]: openstack-glance-api.service holdoff time over, scheduling restart.
Jul 11 22:25:43 node-82 systemd[1]: Stopping OpenStack Image Service (code-named Glance) API server...
Jul 11 22:25:43 node-82 systemd[1]: Starting OpenStack Image Service (code-named Glance) API server...
Jul 11 22:25:43 node-82 systemd[1]: openstack-glance-api.service start request repeated too quickly, refusing to start.
Jul 11 22:25:43 node-82 systemd[1]: Failed to start OpenStack Image Service (code-named Glance) API server.
Jul 11 22:25:43 node-82 systemd[1]: Unit openstack-glance-api.service entered failed state.

错误分析

之前mariadb起不来也是类似错误,但是输入journalctl -xn 后,会显示配置错误,订正my.cnf 就可以但glance报这个错误怎么解决?我还没做什么呢,他说连接过快,无奈之下想起了“重启试试,不行就分”。重启吧,重启也没用,那就卸掉glance组件,删掉数据库,删掉keystone链接重来吧,结果还是没卵用。

类似这种服务起不来的情况,依个人经历作如下总结

1.配置文档有错,订正配置文档,再次启动

2.相关文件夹/文件的权限有问题,查看权限,修改权限

错误解决

因为我都是root权限操作的,所以同步数据库经常用用的是glance-manage db_sync 这次也没什么问题,同步是成功的,问题找不到原因就只能乱撞了,google也没找到。当我输入了su -s /bin/sh -c "glance-manage db_sync" glance 狐狸尾巴终于露出来了,同步出错,错误信息:

Traceback (most recent call last):
  File "/usr/bin/glance-manage", line 10, in <module>
    sys.exit(main())
  File "/usr/lib/python2.7/site-packages/glance/cmd/manage.py", line 273, in main
    log.setup('glance')
  File "/usr/lib/python2.7/site-packages/glance/openstack/common/log.py", line 460, in setup
    _setup_logging_from_conf(product_name, version)
  File "/usr/lib/python2.7/site-packages/glance/openstack/common/log.py", line 529, in _setup_logging_from_conf
    filelog = logging.handlers.WatchedFileHandler(logpath)
  File "/usr/lib64/python2.7/logging/handlers.py", line 392, in __init__
    logging.FileHandler.__init__(self, filename, mode, encoding, delay)
  File "/usr/lib64/python2.7/logging/__init__.py", line 902, in __init__
    StreamHandler.__init__(self, self._open())
  File "/usr/lib64/python2.7/logging/__init__.py", line 925, in _open
    stream = open(self.baseFilename, self.mode)
IOError: [Errno 13] Permission denied: '/var/log/glance/api.log'

api.log 权限有问题,查看之

# ll /var/log/glance/api.log                                                          
-rw-r--r--. 1 root root 14783 Jul 11 22:25 /var/log/glance/api.log

果然,将它改成glance组glance的,再次同步,再次重启,ok

# chown -R glance:glance /var/log/glance/api.log
# su -s /bin/sh -c "glance-manage db_sync" glance
#  systemctl start openstack-glance-api.service 

版权声明:本文为博主原创文章,未经博主允许不得转载。

分享到:QQ空间新浪微博腾讯微博微信百度贴吧QQ好友复制网址打印

您可能想查找下面的文章:

  • openstack-glance-api.service start request repeated too quickly, refusing to start,openstackglance

相关文章

  • 玩转OpenStack网络Neutron(2)--使用Open vSwitch实现VLAN类型租户网络,openstackvswitch
  • hive优化-----控制hive任务的reduce数,hivereduce
  • Storm On Yarn部署,stormonyarn部署
  • 大数据处理算法一:Bitmap算法,数据处理bitmap算法
  • Binary Tree Preorder Traversal (leetcode 144),preorderleetcode
  • Spark MLlib Deep Learning Convolution Neural Network (深度学习-卷积神经网络)3.3,mllibconvolution
  • 安装openstack 时 遇见的一些问题及解决方法!,openstack一些问题
  • hadoop 2.4.1 64位编译记录,hadoop2.4.1
  • 在Ubuntu下安装Mongdb,以及Mongdb基本操作命令,ubuntumongdb
  • Hadoop之—— Linux搭建hadoop环境(简化篇),linuxhadoop

文章分类

  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx

最近更新的内容

    • S3C2416 按键驱动,s3c2416按键驱动
    • MapReduce排序及实例,MapReduce排序实例
    • 在linux下制作libxxx.so 动态库,linuxlibxxx.so
    • HDFS概述---namenode的设计详解,hdfs概述---namenode
    • 在 Mac OS X 系统里使用 Docker,osdocker
    • 在Ubuntu下安装Mongdb,以及Mongdb基本操作命令,ubuntumongdb
    • word2vec.c源码分析,word2vec.c源码
    • hadoop-common源码分析之-WritableUtils,hadoopcommon源码
    • 超人学院Hadoop大数据资源分享,超人学院hadoop分享
    • 胡振亮:原来这就是很多网站百度权重做不上去的原因,胡振亮重做

关于我们 - 联系我们 - 免责声明 - 网站地图

©2020-2025 All Rights Reserved. linkedu.com 版权所有