• linkedu视频
  • 平面设计
  • 电脑入门
  • 操作系统
  • 办公应用
  • 电脑硬件
  • 动画设计
  • 3D设计
  • 网页设计
  • CAD设计
  • 影音处理
  • 数据库
  • 程序设计
  • 认证考试
  • 信息管理
  • 信息安全
菜单
linkedu.com
导航菜单
  • 网页制作
  • 数据库
  • 程序设计
  • 操作系统
  • CMS教程
  • 游戏攻略
  • 脚本语言
  • 平面设计
  • 软件教程
  • 网络安全
  • 电脑知识
  • 服务器
  • 视频教程
  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx
您的位置:首页 > 服务器 >云计算 > 运行spark-shell时遇到的主机地址的错误,spark-shell主机

运行spark-shell时遇到的主机地址的错误,spark-shell主机

作者:网友 字体:[增加 减小] 来源:互联网

本文主要包含银行主机系统错误,主机硬件id错误,主机时间错误,主机解析错误,主机错误等服务器相关知识,网友希望可以进行参考

运行spark-shell时遇到的主机地址的错误,spark-shell主机


下载了spark 1.4,运行spark-shell时遇到以下错误:

java.net.UnknownHostException: UKON-M-Q0EP: UKON-M-Q0EP: nodename nor servname provided, or not known
at java.net.InetAddress.getLocalHost(InetAddress.java:1473)

这并不是spark特有的错误,而是Mac上使用java常见的一个问题,是application在查询主机对应的ip地址时无法查询到ip地址。

其中UKON-M-Q0EP是我Mac的主机名,可以通过Mac terminal的hostname命令查询到:

UKON-M-Q0EP:~ ukon$ hostname
UKON-M-Q0EP

但是系统却不能找到此主机名的ip地址,(其实我是不太能理解为什么不能找到,系统就不能智能一点吗?但的确是不能),这可以通过下面的命令来验证:

UKON-M-Q0EP:~ ukon$ ping UKON-M-Q0EP
^C

但是如果我在/etc/hosts文件中加入此主机名与127.0.0.1就能够ping到了:

UKON-M-Q0EP:~ ukon$ ping UKON-M-Q0EP
PING ukon-m-q0ep (127.0.0.1): 56 data bytes
64 bytes from 127.0.0.1: icmp_seq=0 ttl=64 time=0.056 ms
64 bytes from 127.0.0.1: icmp_seq=1 ttl=64 time=0.133 ms
64 bytes from 127.0.0.1: icmp_seq=2 ttl=64 time=0.121 ms
64 bytes from 127.0.0.1: icmp_seq=3 ttl=64 time=0.134 ms
^C

可见,系统的确需要我们手动的在/etc/hosts中配置才能够找到主机的ip地址。

再次运行./bin/spark-shell,就能够成功了

UKON-M-Q0EP:spark-1.4.0-bin-hadoop2.6 ukon$ ./bin/spark-shell
2015-07-04 00:12:04.604 java[31755:1803488] Unable to load realm info from SCDynamicStore
Welcome to
__
/ / _ _/ /__
\ \/ \/ _ `/ _/ ‘/
// ./_,// //_\ version 1.4.0
/_/

Using Scala version 2.10.4 (Java HotSpot(TM) 64-Bit Server VM, Java 1.7.0_45)
Type in expressions to have them evaluated.
Type :help for more information.
Spark context available as sc.
SQL context available as sqlContext.

scala>

DONE!

然后,成功的运行了一段spark代码,统计一个本地文件的行数和查询第一行的文本内容:

scala> val textFile = sc.textFile(“README.md”)
textFile: org.apache.spark.rdd.RDD[String] = MapPartitionsRDD[1] at textFile at :21

scala> textFile.count()
res0: Long = 98

scala> textFile.first()
res1: String = # Apache Spark

很酷!

版权声明:本文为博主原创文章,未经博主允许不得转载。

分享到:QQ空间新浪微博腾讯微博微信百度贴吧QQ好友复制网址打印

您可能想查找下面的文章:

  • 运行spark-shell时遇到的主机地址的错误,spark-shell主机

相关文章

  • Linux、hive、sqoop常用脚本,hivesqoop
  • Andrew Ng机器学习课程10,andrewng机器课程
  • <转>云主机配置OpenStack使用spice的方法,openstackspice
  • 大数据学习笔记1--hadoop简介和入门,学习笔记1--hadoop
  • AWS和OpenStack服务对照表,OpenStack服务英文单词的中文翻译,awsopenstack
  • Redis源码学习-Lua脚本,redis源码-lua
  • HDFS API基本操作,hdfsapi基本操作
  • Hadoop文件解压缩,
  • 从Hadoop URL中读取数据,hadoopurl读取数据
  • sqoop流程详解,sqoop详解

文章分类

  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx

最近更新的内容

    • Hive之简单查询不启用MapReduce,hive启用mapreduce
    • 在spark上运行独立程序(Self-Contained Applications),selfcontained
    • Flume 开发者指南V1.5.2,flume开发者v1.5.2
    • Hadoop,HBase集群环境搭建的问题集锦(一),hadoophbase
    • Hadoop之——数据类型,hadoop数据类型
    • Hadoop源码分析----RPC反射机制,hadoop----rpc
    • 每日定时导入hive数据仓库的自动化脚本,hive数据仓库脚本
    • centos7 安装配置openstack-dashboard (官网openstack-juno版),centos7openstack
    • Hadoop之—— Linux搭建hadoop环境(简化篇),linuxhadoop
    • Understanding Cubert Concepts(二)Co-Partitioned Blocks,partitioned

关于我们 - 联系我们 - 免责声明 - 网站地图

©2020-2025 All Rights Reserved. linkedu.com 版权所有