• linkedu视频
  • 平面设计
  • 电脑入门
  • 操作系统
  • 办公应用
  • 电脑硬件
  • 动画设计
  • 3D设计
  • 网页设计
  • CAD设计
  • 影音处理
  • 数据库
  • 程序设计
  • 认证考试
  • 信息管理
  • 信息安全
菜单
linkedu.com
导航菜单
  • 网页制作
  • 数据库
  • 程序设计
  • 操作系统
  • CMS教程
  • 游戏攻略
  • 脚本语言
  • 平面设计
  • 软件教程
  • 网络安全
  • 电脑知识
  • 服务器
  • 视频教程
  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx
您的位置:首页 > 服务器 >虚拟化 > 【甘道夫】Apache Hadoop 2.5.0-cdh5.2.0 HDFS Quotas 配额控制,hadoophdfs

【甘道夫】Apache Hadoop 2.5.0-cdh5.2.0 HDFS Quotas 配额控制,hadoophdfs

作者:网友 字体:[增加 减小] 来源:互联网

本文主要包含【甘道夫】Apache Hadoop 2.5.0-cdh5.2.0 HDFS Quotas 配额控制,hadoophdfs等服务器相关知识,网友希望可以进行参考

【甘道夫】Apache Hadoop 2.5.0-cdh5.2.0 HDFS Quotas 配额控制,hadoophdfs


前言 HDFS为管理员提供了针对目录的配额控制特性,可以控制名称配额(指定目录下的文件&文件夹总数),或者空间配额(占用磁盘空间的上限)。 本文探究了HDFS的配额控制特性,记录了各类配额控制场景的实验详细过程。 实验环境基于Apache Hadoop 2.5.0-cdh5.2.0。
欢迎转载,请注明出处:http://blog.csdn.net/u010967382/article/details/44452485
名称配额功能试用

设置名称配额,即当前目录下文件和目录的最大数量: casliyang@singlehadoop:~$ hdfs dfsadmin -setQuota 3 /Workspace/quotas/ 15/03/18 14:53:52 WARN util.NativeCodeLoader: Unable to load native-hadoop library for your platform... using builtin-java classes where applicable
上传文件: casliyang@singlehadoop:~$ hdfs dfs -put slf4j-log4j12-1.6.4.jar /Workspace/quotas/ 15/03/18 14:54:16 WARN util.NativeCodeLoader: Unable to load native-hadoop library for your platform... using builtin-java classes where applicable
上传文件: casliyang@singlehadoop:~$ hdfs dfs -put dict.txt /Workspace/quotas/ 15/03/18 14:55:08 WARN util.NativeCodeLoader: Unable to load native-hadoop library for your platform... using builtin-java classes where applicable
继续上传文件报错: casliyang@singlehadoop:~$ hdfs dfs -put examples.desktop /Workspace/quotas/ 15/03/18 14:55:28 WARN util.NativeCodeLoader: Unable to load native-hadoop library for your platform... using builtin-java classes where applicable put: The NameSpace quota (directories and files) of directory /Workspace/quotas is exceeded: quota=3 file count=4
查看该目录情况: casliyang@singlehadoop:~$ hdfs dfs -ls /Workspace/quotas 15/03/18 17:11:31 WARN util.NativeCodeLoader: Unable to load native-hadoop library for your platform... using builtin-java classes where applicable Found 2 items -rw-r--r--   3 casliyang supergroup         14 2015-03-18 14:55 /Workspace/quotas/dict.txt -rw-r--r--   3 casliyang supergroup       9748 2015-03-18 14:38 /Workspace/quotas/slf4j-log4j12-1.6.4.jar 目录下只有两个文件。

查看配额情况: casliyang@singlehadoop:~$ hdfs dfs -count -q /Workspace/quotas 15/03/18 16:00:53 WARN util.NativeCodeLoader: Unable to load native-hadoop library for your platform... using builtin-java classes where applicable            3               0            none             inf            1            2               9762 /Workspace/quotas
注意几个数字的含义依次是:
名称配额剩余量的计算公式: 名称配额剩余量 = 名称配额总量 - ( 目录数 + 文件数 )
基于上面配额查看结果得知: 名称配额总量=3 目录数=1 文件数=2
所以,名称配额剩余量=3-(1+2)=0 所以此时继续上传文件会超出名称配额的限制。
BTW,居然把根目录也计数了!
我们再来建一个没有设定quotas的目录,测试下是否也将根目录纳入count统计: casliyang@singlehadoop:~$ hdfs dfs -mkdir /Workspace/quotas1 15/03/18 17:19:21 WARN util.NativeCodeLoader: Unable to load native-hadoop library for your platform... using builtin-java classes where applicable casliyang@singlehadoop:~$ hdfs dfs -count -q /Workspace/quotas1 15/03/18 17:20:24 WARN util.NativeCodeLoader: Unable to load native-hadoop library for your platform... using builtin-java classes where applicable         none             inf            none             inf            1            0                  0 /Workspace/quotas1
上面的实验看出,名称配额和空间配额都没设置,所以都显示none/inf,果然当前根目录还是计入统计了,目录数为1。
下面通过命令取消/Workspace/quotas目录的名称配额: casliyang@singlehadoop:~$ hdfs dfs -count -q /Workspace/quotas 15/03/18 17:28:25 WARN util.NativeCodeLoader: Unable to load native-hadoop library for your platform... using builtin-java classes where applicable            3               0            none             inf            1            2               9762 /Workspace/quotas casliyang@singlehadoop:~$ hdfs dfsadmin -clrQuota /Workspace/quotas 15/03/18 17:28:40 WARN util.NativeCodeLoader: Unable to load native-hadoop library for your platform... using builtin-java classes where applicable casliyang@singlehadoop:~$ hdfs dfs -count -q /Workspace/quotas 15/03/18 17:28:50 WARN util.NativeCodeLoader: Unable to load native-hadoop library for your platform... using builtin-java classes where applicable         none             inf            none             inf            1            2               9762 /Workspace/quotas

空间配额功能试用

清空目录/Workspace/quotas: casliyang@singlehadoop:~$ hdfs dfs -rm -r /Workspace/quotas/* 15/03/18 17:33:08 WARN util.NativeCodeLoader: Unable to load native-hadoop library for your platform... using builtin-java classes where applicable 15/03/18 17:33:11 INFO fs.TrashPolicyDefault: Namenode trash configuration: Deletion interval = 0 minutes, Emptier interval = 0 minutes. Deleted /Workspace/quotas/dict.txt 15/03/18 17:33:11 INFO fs.TrashPolicyDefault: Namenode trash configuration: Deletion interval = 0 minutes, Emptier interval = 0 minutes. Deleted /Workspace/quotas/slf4j-log4j12-1.6.4.jar casliyang@singlehadoop:~$ hdfs dfs -ls /Workspace/quotas/ 15/03/18 17:33:36 WARN util.NativeCodeLoader: Unable to load native-hadoop library for your platform... using builtin-java classes where applicable casliyang@singlehadoop:~$ hdfs dfs -count -q /Workspace/quotas 15/03/18 17:33:49 WARN util.NativeCodeLoader: Unable to load native-hadoop library for your platform... using builtin-java classes where applicable         none             inf            none             inf            1            0                  0 /Workspace/quotas
为目录设定空间限额: casliyang@singlehadoop:~$ hdfs dfsadmin -setSpaceQuota 8000 /Workspace/quotas 15/03/18 17:36:17 WARN util.NativeCodeLoader: Unable to load native
分享到:QQ空间新浪微博腾讯微博微信百度贴吧QQ好友复制网址打印

您可能想查找下面的文章:

  • 【甘道夫】Apache Hadoop 2.5.0-cdh5.2.0 HDFS Quotas 配额控制,hadoophdfs

相关文章

  • docker中mysql初始化及启动失败问题解决方案
  • 详解基于Docker的服务部署流程
  • docker一键安装wordpress的方法步骤
  • 详解Docker挂载本地目录及实现文件共享的方法
  • Docker 教程之获取镜像基础知识详解
  • 详解在Ubuntu 14.04安装和使用Docker
  • docker快速入门教程
  • CentOS7 阿里云的yum源使用详解
  • 局域网内部署 Docker Registry(推荐)
  • Docker自动部署Apache Tomcat的方法

文章分类

  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx

最近更新的内容

    • openstack pike单机一键安装shell的方法
    • 为VMware的多台虚拟机绑定IP地址的方法
    • 通过UI管理docker的方法
    • 什么是Docker? Docker入门教程
    • VMware Workstation如何创建加密虚拟机
    • 详解基于docker搭建lanproxy内网穿透服务
    • Gartner:服务器虚拟化形成中国IT拐点
    • 详解nodejs之创建最小docker镜像
    • docker配置独立桥接IP的方法
    • Docker如何使用Dockerfile构建镜像

关于我们 - 联系我们 - 免责声明 - 网站地图

©2020-2025 All Rights Reserved. linkedu.com 版权所有