• linkedu视频
  • 平面设计
  • 电脑入门
  • 操作系统
  • 办公应用
  • 电脑硬件
  • 动画设计
  • 3D设计
  • 网页设计
  • CAD设计
  • 影音处理
  • 数据库
  • 程序设计
  • 认证考试
  • 信息管理
  • 信息安全
菜单
linkedu.com
导航菜单
  • 网页制作
  • 数据库
  • 程序设计
  • 操作系统
  • CMS教程
  • 游戏攻略
  • 脚本语言
  • 平面设计
  • 软件教程
  • 网络安全
  • 电脑知识
  • 服务器
  • 视频教程
  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx
您的位置:首页 > 服务器 >虚拟化 > Docker容器自启动的实现方法

Docker容器自启动的实现方法

作者:温暖的电波 字体:[增加 减小] 来源:互联网

本文主要包含Docker容器自启动,docker,自启动等服务器相关知识,温暖的电波 希望可以进行参考

容器自启动

Docker提供了restart policy机制,可以在容器退出或者Docker重启时控制容器能够自启动。这种Restart policy可以保证相关容器按照正确顺序启动。虽然也可以通过进程监控的方式(如systemd)来完成这种动作,但Docker还是建议尽量避免使用进程监控的方式来 "自启动" 容器。

Docker的 Restart policy与dockerd命令的--live-restore启动标志还有区别:--live-restore标志可以在Docker升级的时候保证容器继续运行,但是网络以及用户终端输入会被中断。

那到底什么是restart policy呢?我们来看看实际的情况吧。

使用restart policy

restart policy在使用docker run启动容器时通过--restart标志指定,这个标志有多个value可选,不同的value有不同的行为,如下表所列:

Flag Description
no 不自动重启容器. (默认value)
on-failure  容器发生error而退出(容器退出状态不为0)重启容器
unless-stopped  在容器已经stop掉或Docker stoped/restarted的时候才重启容器
always  在容器已经stop掉或Docker stoped/restarted的时候才重启容器

举个例子:下面的命令启动一个Redis容器,当Redis容器停止后或者Docker被重启时,Redis容器都会重启。

$ docker run -dit --restart unless-stopped redis

Restart policy细节

使用restart policies时需要注意如下细节:

(1) 容器只有在成功启动后restart policy才能生效。这里的"成功启动"是指容器处于up至少10秒且已经处于docker监管。这是避免没有成功启动的容器陷入restart的死循环。

(2)如果手动(manually)的stop(与前面的explicitly stopped有何区别)一个容器,容器设置的restart policy将会被忽略,除非Docker daemon重启或者容器手动重启。这是避免了另外一种死循环。

(3)restart policies只能用于容器,对于swarm services其restart policies有不通过的配置。

 进程监控

如果上面讲的restart policies无法满足需求,也可以采用进程监控的管理方案,如upstart,systemd或者supervisor等等。

这种方案中,进程监控服务运行在容器中。它可以监控一个进程是否运行,并可以在此进程没有运行的时候去启动该进程。而这发生的一切Docker都毫无知觉。

Docker不推荐此种方法来进行进程监控,理由很简单,这种方法和系统平台甚至linux发行版相关。

原文:https://docs.docker.com/engine/admin/start-containers-automatically/#use-a-process-manager

Docker容器开机自动启动

在使用docker run启动容器时,使用--restart参数来设置:

# docker run -m 512m --memory-swap 1G -it -p 58080:8080 --restart=alway

 --name bvrfis --volumes-from logdata mytomcat:4.0 /root/run.sh   

--restart具体参数值详细信息:

  • no -  容器退出时,不重启容器;
  • on-failure - 只有在非0状态退出时才从新启动容器;
  • always - 无论退出状态是如何,都重启容器;

还可以在使用on - failure策略时,指定Docker将尝试重新启动容器的最大次数。默认情况下,Docker将尝试永远重新启动容器。

# sudo docker run --restart=on-failure:10 redis

以上就是本文的全部内容,希望对大家的学习有所帮助,也希望大家多多支持。

您可能感兴趣的文章:

  • Docker容器内不能联网的6种解决方案
  • Docker创建运行多个mysql容器的方法示例
  • 如何隔离docker容器中的用户的方法
  • Docker容器中Mysql数据的导入/导出详解
  • Docker容器使用jenkins部署web项目(总结)
  • Docker容器之内网独立IP访问的方法
  • 详解将本地docker容器迁移到服务端
  • Docker下Tomcat容器中使用Mysql的方法
  • Centos7下安装与卸载docker应用容器引擎的方法
  • docker容器启动后添加端口映射
  • 详解Docker 端口映射与容器互联
  • Docker教程:使用容器(简单示例)
分享到:QQ空间新浪微博腾讯微博微信百度贴吧QQ好友复制网址打印

您可能想查找下面的文章:

  • Docker容器自启动的实现方法

相关文章

  • Ubuntu 18.04 LTS安装KVM虚拟机的方法步骤
  • 详解Docker容器可视化监控中心搭建
  • windows中VirtualBox如何调整扩大VMDK格式的磁盘空间
  • 详解OpenStack之服务端口号
  • VMware搭建虚拟机服务器
  • VMWare Workation双网卡配置IP地址的图文教程
  • Centos7下安装与卸载docker应用容器引擎的方法
  • 在虚拟机virtualbox中安装ubuntu的图文教程
  • Docker 学习文档(知识结构整理)
  • docker利用WebHook实现持续集成

文章分类

  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx

最近更新的内容

    • 详解vmware14Pro中ubuntu系统界面太小的问题解决
    • VirtualBox 共享文件夹设置及开机自动挂载详细教程
    • mac 中docker安装mysql的图文教程
    • Docker 基础网络配置详解
    • Docker镜像制作详解介绍
    • docker 的java编译环境构建详细介绍
    • 使用Docker搭建Django,Nginx,R,Python部署环境的方法
    • Docker学习之基于Dockerfile搭建JAVA Tomcat运行环境的方法
    • Xen虚拟化基础篇第1/2页
    • Vrtualbox虚拟机中共享文件夹配置教程

关于我们 - 联系我们 - 免责声明 - 网站地图

©2020-2025 All Rights Reserved. linkedu.com 版权所有