• linkedu视频
  • 平面设计
  • 电脑入门
  • 操作系统
  • 办公应用
  • 电脑硬件
  • 动画设计
  • 3D设计
  • 网页设计
  • CAD设计
  • 影音处理
  • 数据库
  • 程序设计
  • 认证考试
  • 信息管理
  • 信息安全
菜单
linkedu.com
导航菜单
  • 网页制作
  • 数据库
  • 程序设计
  • 操作系统
  • CMS教程
  • 游戏攻略
  • 脚本语言
  • 平面设计
  • 软件教程
  • 网络安全
  • 电脑知识
  • 服务器
  • 视频教程
  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx
您的位置:首页 > 服务器 >虚拟化 > Docker搭建本地私有仓库的详细步骤

Docker搭建本地私有仓库的详细步骤

作者:banbanaoxiang 字体:[增加 减小] 来源:互联网

本文主要包含docker本地仓库搭建,docker,私有仓库,docker,私有仓库搭建等服务器相关知识,banbanaoxiang 希望可以进行参考

和Mavan的管理一样,Dockers不仅提供了一个中央仓库,同时也允许我们使用registry搭建本地私有仓库。使用私有仓库有许多优点:

一、节省网络带宽,针对于每个镜像不用每个人都去中央仓库上面去下载,只需要从私有仓库中下载即可;

二、提供镜像资源利用,针对于公司内部使用的镜像,推送到本地的私有仓库中,以供公司内部相关人员使用。

接下来我们就大致说一下如何在本地搭建私有仓库。

环境准备

环境:两个装有Docker的Ubuntu虚拟机

虚拟机一:192.168.112.132 用户开发机

虚拟机二:192.168.112.136 用作私有仓库

此处我们准备了两个虚拟机,分别都安装了Docker,其中132机器用作开发机,136机器用作registry私有仓库机器。环境准备好之后接下来我们就开始搭建私有镜像仓库。

搭建私有仓库

首先在136机器上下载registry镜像

$ sudo docker pull registry 

下载完之后我们通过该镜像启动一个容器

$ sudo docker run -d -p 5000:5000 registry 

 默认情况下,会将仓库存放于容器的/tmp/registry目录下,这样如果容器被删除,则存放于容器中的镜像也会丢失,所以我们一般情况下会指定本地一个目录挂载到容器的/tmp/registry下,如下:

$ sudo docker run -d -p 5000:5000 -v /opt/data/registry:/tmp/registry registry 

可以看到我们启动了一个容器,地址为:192.168.112.136:5000

接下来我们就要操作把一个本地镜像push到私有仓库中

在132机器下pull一个比较小的镜像来测试(此处使用的是busybox)

$ sudo docker pull busybox 

接下来修改一下该镜像的tag

$ sudo docker tag busybox 192.168.112.136:5000/busybox 

接下来把打了tag的镜像上传到私服

$ sudo docker push 192.168.112.136:5000/busybox 

可以看到push失败,具体结果如下:

2015/01/05 11:01:17 Error: Invalid registry endpoint https://192.168.112.136:5000/v1/: Get https://192.168.112.136:5000/v1/_ping: dial tcp 192.168.112.136:5000: connection refused. If this private registry supports only HTTP or HTTPS with an unknown CA certificate, please add `--insecure-registry 192.168.112.136:5000` to the daemon's arguments. In the case of HTTPS, if you have access to the registry's CA certificate, no need for the flag; simply place the CA certificate at /etc/docker/certs.d/192.168.112.136:5000/ca.crt

因为Docker从1.3.X之后默认docker registry使用的是https,所以当用docker pull命令下载远程镜像时,如果远程docker registry是非https的时候就会报上面的错误。

为了解决这个问题需要在启动docker server时增加启动参数

修改docker启动配置文件(此处是修改132机器的配置)Ubuntu下配置文件地址为:/etc/init/docker.conf

在其中增加--insecure-registry 192.168.112.136:5000如下所示:

$ sudo vi /etc/init/docker.conf 

修改完之后,重启Docker服务

$ sudo restart docker 

重启完之后我们再次运行推送命令,把本地镜像推送到私有服务器上

$ sudo docker push 192.168.112.136:5000/busybox 

可以看到镜像已经push到私有仓库中去了,接下来我们删除本地镜像,然后从私有仓库中pull下来该镜像

删除了本地镜像,然后我们从私有镜像仓库中下载该镜像

$ sudo docker pull 192.168.112.136:5000/busybox 

好了,到此本地搭建registry私有仓库就完结了,如有任何问题欢迎指正。

以上就是本文的全部内容,希望对大家的学习有所帮助,也希望大家多多支持。

您可能感兴趣的文章:

  • 详解Docker私有仓库最简便的搭建方法
  • 详解CentOS 7 : Docker私有仓库搭建和使用
  • docker 如何搭建私有仓库(ubuntu 14.04,Docker版本1.6.4)详细介绍
  • 详解centos7 docker1.12安装私有仓库
  • Docker 教程之私有仓库详解
  • Docker 私有仓库恢复实例详解
  • Docker Registry 私有仓库搭建详细步骤
  • Centos 7中Docker私有仓库的搭建方法
分享到:QQ空间新浪微博腾讯微博微信百度贴吧QQ好友复制网址打印

您可能想查找下面的文章:

  • Docker搭建本地私有仓库的详细步骤

相关文章

  • 详解docker容器间通信的一种方法
  • OpenStack Heat AutoScaling详解及实例代码
  • VMware中虚拟机的NAT设置方法
  • VMware虚拟机CentOS系统网络设置
  • docker swarm 集群故障与异常详解
  • 讲解使用Docker搭建Java Web运行环境
  • Dockerfile基础分享
  • Openstack 使用migrate进行数据库升级实现方案详细介绍
  • CentOS 5.X xen虚拟机的安装配置及基本使用
  • Docker如何固定IP设置的方法

文章分类

  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx

最近更新的内容

    • docker images 如何建立自己的原生镜像
    • docker添加多网卡的方法
    • 详解利用ELK搭建Docker容器化应用日志中心
    • Docker镜像上传到阿里云的步骤详解
    • Docker daemon 无法启动: does not match with stored UUID错误解决办法
    • VMware虚拟机安装CentOS 6.9图文教程
    • Docker系列之使用Docker Compose编排容器
    • docker常用命令总结之安装、镜像、容器基本操作
    • XenServer安装后修改IP与域名并解析测试的方法
    • CentOS 7安装Docker服务详细过程

关于我们 - 联系我们 - 免责声明 - 网站地图

©2020-2025 All Rights Reserved. linkedu.com 版权所有