• linkedu视频
  • 平面设计
  • 电脑入门
  • 操作系统
  • 办公应用
  • 电脑硬件
  • 动画设计
  • 3D设计
  • 网页设计
  • CAD设计
  • 影音处理
  • 数据库
  • 程序设计
  • 认证考试
  • 信息管理
  • 信息安全
菜单
linkedu.com
导航菜单
  • 网页制作
  • 数据库
  • 程序设计
  • 操作系统
  • CMS教程
  • 游戏攻略
  • 脚本语言
  • 平面设计
  • 软件教程
  • 网络安全
  • 电脑知识
  • 服务器
  • 视频教程
  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx
您的位置:首页 > 服务器 >虚拟化 > 使用Docker容器搭建MySql主从复制

使用Docker容器搭建MySql主从复制

作者:zhangchao19890805 字体:[增加 减小] 来源:互联网

本文主要包含docker,mysql,主从复制等服务器相关知识,zhangchao19890805 希望可以进行参考

1. 编写主MySQL的Docker文件

新建文件夹,命名为MySQL-master-v1。在文件夹mysql-master-v1中新建文件Dockerfile和master.cnf。笔者推荐使用的编辑器是Visual Studio Code。利用编辑器将这两个文件的编码设置成UTF-8。因为本文介绍安装到Linux系统下,所以笔者建议读者把换行符设置成LF,以兼顾Linux操作系统。按照如下内容编写这两个文件。

Dockerfile

FROM mysql:5.7
# set timezone as china/shanghai
RUN cp /usr/share/zoneinfo/PRC /etc/localtime
# copy mysql config file
COPY master.cnf /etc/mysql/conf.d/
ENTRYPOINT ["docker-entrypoint.sh"]
EXPOSE 3306
CMD ["mysqld"]

master.cnf

user=root
password='123456'
[mysqld]
max_allowed_packet=8M
lower_case_table_names=1
character_set_server=utf8
max_connections=900
max_connect_errors=600
server-id=1
log-bin=mysql-bin
replicate-wild-do-table=db1.%
replicate-wild-do-table=db2.%
slow_query_log=1
long_query_time=1
log_error

2. 主MySQL的配置文件参数说明

解释一下master.cnf。

lower_case_table_names:忽略表名、列名等数据结构的大小写(注意:不是每行记录内容的大小写!)。

server-id=1: 表示此MySQL服务器是主服务器 。

log-bin:开启二进制记录。这是为了主从复制而做的设置。本文使用RBR(Row-Based Replication)模式。

replicate-wild-do-table:规定有哪些表可以从主服务器复制到从服务器。db1.%是指只要是数据库db1的表,就都可以复制到从服务器上。可以多条设置,来允许多个数据库。

没有使用replicate-do-db是因为replicate-do-db禁止跨数据库的访问。比如用户已经使用use db2;选择了数据库db2,用户还要执行update db1.t_student set c_name='stu_c' where c_id='1234c',那么就不能使用replicate-do-db。在编程的时候虽然程序员不会用到use,但是程序员有可能把连接mysql的url写成指定某个数据库或没有指定具体的数据库。即便没有指定数据库,使用replicate-do-db也是不允许的。

slow_query_log=1:开启慢查询日志。如果某一条SQL执行的时间超过long_query_time设置的秒数,那么就记录下来。记录文件路径可以使用show variables;命令,在变量名是slow_query_log_file下查找到具体的日志文件路径。

long_query_time=1:单位是秒。指如果某一条SQL语句执行时间超过1秒,就记录下来。必须开启慢查询日志了以后,此变量才能使用。

log_error:开启错误日志。show variables like 'log_error'; 就可以查询到日志文件的路径。mysql的Docker官方镜像如果设置别的取值会导致容器无法正常启动。

3. 生成并使用主MySQL的镜像

上传文件夹mysql-master-v1到Linux服务器上。为了便于说明,用服务器A来指代这台服务器。笔者的Linux版本是Ubuntu14.04。通过cd命令进入目录mysql-master-v1。然后输入以下命令来编译镜像:

docker build -t zhangchao/mysql-master5.7:v1 .

注意不要落下行末尾最后一个点。

根据编译好的镜像,生成新的容器:

docker run --name mysql-master \
-p 3306:3306 \
-v /zc/mysql-master/datadir:/var/lib/mysql \
-e MYSQL_ROOT_PASSWORD='123456' -d zhangchao/mysql-master5.7:v1

使用MySQL的客户端连接MySQL主服务器,笔者使用的是MySQL Workbench。执行如下命令:

show master status;

记录下file和position。这里假设file是mysql-bin.000001,post是154。

4. 编写从MySQL的Docker文件

新建文件夹 mysql-slave-v1。仿照步骤1在文件夹 mysql-slave-v1下新建 Dockerfile 和 slave.cnf 两个文件。下面是这两个文件的内容。

Dockerfile

FROM mysql:5.7
# set timezone as china/shanghai
RUN cp /usr/share/zoneinfo/PRC /etc/localtime
# copy mysql config file
COPY slave.cnf /etc/mysql/conf.d/
ENTRYPOINT ["docker-entrypoint.sh"]
EXPOSE 3306
CMD ["mysqld"]

slave.cnf

[mysqldump]
user=root
password='123456'
[mysqld]
max_allowed_packet=8M
lower_case_table_names=1
character_set_server=utf8
max_connections=900
max_connect_errors=600
slow_query_log=1
long_query_time=1
log_error
# Regard this db as a slave
server-id=2

slave.cnf 文件中的 server-id=2 会把MySQL服务器设置成从服务器。

5. 生成并使用从MySQL的镜像

上传 mysql-slave-v1 到第二台服务器。用服务器B来指代这台服务器。

编译镜像:

docker build -t zhangchao/mysql-slave5.7:v1 .

利用新的镜像建立容器:

docker run --name mysql-slave \
-p 3306:3306 \
-v /zc/mysql-slave/datadir:/var/lib/mysql \
-e MYSQL_ROOT_PASSWORD='123456' -d zhangchao/mysql-slave5.7:v1

这时MySQL的主从服务器都在运行中,需要读者自行保证两边的数据相同。只有当两台服务器的数据都一样的时候,才能建立主从复制连接。

6. 把从MySQL连接到主MySQL上

使用客户端连接到MySQL从服务器,假定服务器A的IP是192.168.10.1。

执行如下命令:

change master to 
master_host='192.168.10.1',
master_user='root',
master_password='123456',
master_log_file='mysql-bin.000001',
master_log_pos=154;

待命令正常执行后,接着执行如下命令:

start slave;

这样就可以主从复制了。只要在主服务器的db1和db2数据库插入或修改数据,就可以自动复制到从服务器上了。

以上所述是小编给大家介绍的使用Docker容器搭建MySql主从复制,希望对大家有所帮助,如果大家有任何疑问请给我留言,小编会及时回复大家的。在此也非常感谢大家对网站的支持!

您可能感兴趣的文章:

  • 详解如何利用docker快速构建MySQL主从复制环境
  • mysql 5.7 docker 主从复制架构搭建教程
  • 详解Docker方式实现MySql 主从复制(实践篇)
分享到:QQ空间新浪微博腾讯微博微信百度贴吧QQ好友复制网址打印

您可能想查找下面的文章:

  • Docker实践8:Compose,docker实践compose
  • Docker buildx构建多平台镜像并推送到私有仓库的方法
  • Docker三个基本概念镜像(Image)容器(Container)仓库(Repository)
  • 什么是Docker?为什么要使用Docker
  • docker 开源的应用容器引擎
  • 如何给docker设置http代理
  • docker官方mysql镜像自定义配置详解
  • 详解Docker数据管理(数据卷&数据卷容器)
  • 如何利用Docker容器实现代理转发与数据备份详解
  • 详解Docker Swarm 在持续集成测试中的应用

相关文章

  • 理解Docker(2):Docker 镜像详细介绍
  • 局域网内部署 Docker Registry(推荐)
  • windows docker环境设置注意事项
  • 详解Openstack使用ubuntu镜像启动虚拟机实例
  • VMware虚拟机下linux上网的几种方式示例
  • CentOS7 docker服务无法启动解决方案及实现步骤
  • 详解VMware 虚拟机中添加新硬盘的方法
  • XenServer 6.5 安装配置图文教程
  • 详解Docker中安装配置Oracle数据库
  • MacBookPro下docker的安装与使用教程

文章分类

  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx

最近更新的内容

    • [Azure]如何定位虚拟机内部附加的数据磁盘
    • CentOS 5.4+OpenVZ+Vtonf实现VPS服务器的方法
    • Docker容器访问宿主机网络的方法
    • 在Ubuntu上面安装VMware Workstation教程
    • VMware虚拟机安装CentOS 6.9图文教程
    • CloudStack SSVM启动条件源码阅读与问题解决方法
    • 解决Docker容器时区及时间不同步问题的方法
    • IBM KVM三特点:Linux、虚拟化与开源
    • 虚拟化之VMware Workstation 10.0.x安装教程(图文)
    • Docker 限制容器可用的CPU的方式

关于我们 - 联系我们 - 免责声明 - 网站地图

©2020-2025 All Rights Reserved. linkedu.com 版权所有