• linkedu视频
  • 平面设计
  • 电脑入门
  • 操作系统
  • 办公应用
  • 电脑硬件
  • 动画设计
  • 3D设计
  • 网页设计
  • CAD设计
  • 影音处理
  • 数据库
  • 程序设计
  • 认证考试
  • 信息管理
  • 信息安全
菜单
linkedu.com
导航菜单
  • 网页制作
  • 数据库
  • 程序设计
  • 操作系统
  • CMS教程
  • 游戏攻略
  • 脚本语言
  • 平面设计
  • 软件教程
  • 网络安全
  • 电脑知识
  • 服务器
  • 视频教程
  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx
您的位置:首页 > 服务器 >windows > mogilefs的存储节点由dead转为alive

mogilefs的存储节点由dead转为alive

作者:网友 字体:[增加 减小] 来源:互联网

本文主要包含mogilefs,mogilefs官网,centos下安装mogilefs,dead or alive,more dead than alive等服务器相关知识,网友希望可以进行参考

有个需求,mogilefs的死节点需要重用,于是线下测试,如果直接用命令行:

mogadm --trackers=localhost:6001 device mark mogilestorage2 2 alive

将dead节点标记为alive会报错:

Error updating device: state_too_high Status cannot go from dead to alive; must use down

于是想个了馊主意,在数据库中直接修改device表,将其修改为alive状态;

修改完成后用命令:

mogadm --trackers=localhost:6001 check 测试各种状态也显示正常,

于是存几张图片,再次将其该节点标记为dead,问题出来了,发现它里面存储的东西不会自动

清理掉。

回头再看看:http://code.google.com/p/mogilefs/wiki/Maintenance 的介绍

感觉自己确实想多了。

分享到:QQ空间新浪微博腾讯微博微信百度贴吧QQ好友复制网址打印

您可能想查找下面的文章:

  • mogilefs的存储节点由dead转为alive

相关文章

  • liunx基本命令(用户的管理)
  • Windows2003中让php加载curl.dll和mcrypt 模块
  • Windows操作系统的经典蓝屏场景回顾[多图]
  • windows通过rsync定期备份下svn目录到linux
  • liunx基本命令(适合初学者看)
  • windows2003中带$符号的用户无法删除
  • 不需手动锁表同步mysql数据库
  • Mac OS X/windows下启用Mod Rewrite和.htaccess
  • 多路径链路状态异常解决
  • 谈谈重复数据删除

文章分类

  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx

最近更新的内容

    • 解码云时代企业云存储服务
    • windows中关闭137,138,139危险端口方法
    • Windows Server 2003的Web接口
    • iis网站提示 Internal Server Error
    • Windows 中 Apache配置 与 虚拟主机 设置
    • 垃圾、无用文件无法删除问题的解决办法
    • DELL R420 & MD3220 IO性能测试报告
    • liunx基本命令(用户的管理,难点重复介绍)
    • windows通过rsync定期备份下svn目录到linux
    • 企业shell脚本分析及切割apache日志实战

关于我们 - 联系我们 - 免责声明 - 网站地图

©2020-2025 All Rights Reserved. linkedu.com 版权所有