• linkedu视频
  • 平面设计
  • 电脑入门
  • 操作系统
  • 办公应用
  • 电脑硬件
  • 动画设计
  • 3D设计
  • 网页设计
  • CAD设计
  • 影音处理
  • 数据库
  • 程序设计
  • 认证考试
  • 信息管理
  • 信息安全
菜单
linkedu.com
导航菜单
  • 网页制作
  • 数据库
  • 程序设计
  • 操作系统
  • CMS教程
  • 游戏攻略
  • 脚本语言
  • 平面设计
  • 软件教程
  • 网络安全
  • 电脑知识
  • 服务器
  • 视频教程
  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx
您的位置:首页 > 服务器 >windows > oracle数据库使用nfs存储,启动报错提示无法锁定文件

oracle数据库使用nfs存储,启动报错提示无法锁定文件

作者:网友 字体:[增加 减小] 来源:互联网

本文主要包含oracle数据库报错,oracle数据库安装报错,oracle数据库导入报错,oracle数据库存储过程,oracle数据库存储结构等服务器相关知识,网友希望可以进行参考

oracle报错信息:

SQL> startup> ORA-10997: another startup/shutdown operation of this instance inprogress> ORA-09968: unable to lock file> Linux-x86_64 Error: 37: No locks available> Additional information: 64


message文件报错信息:192.168.0.200为netapp存储地址)

> Jun 6 18:21:19 eccdemo sm-notify[3707]: Unable to notify bogon, giving up> Jun 6 18:39:18 eccdemo rpc.statd[3705]: No canonical hostname found for 192.168.0.200> Jun 6 18:39:18 eccdemo rpc.statd[3705]: STAT_FAIL to eccdemo for SM_MON of 192.168.0.200> Jun 6 18:39:18 eccdemo kernel: lockd: cannot monitor 192.168.0.200> Jun 6 18:39:33 eccdemo rpc.statd[3705]: No canonical hostname found for 192.168.0.200> Jun 6 18:39:33 eccdemo rpc.statd[3705]: STAT_FAIL to eccdemo for SM_MON of 192.168.0.200> Jun 6 18:39:33 eccdemo kernel: lo> ckd: cannot monitor 192.168.0.200


解决办法:

按照oracle官方文档,需要增加挂载参数

mount -t nfs -o rw,bg,hard,rsize=32768,wsize=32768,vers=3,nointr,timeo=600,tcp,actimeo=0 192.168.0.200:/vol/oraclenfs /oracle

具体挂载参数需要参考官方文档,每个版本是不一样的。

RAC  


In the table below
  • Binaries is the shared mount points where the Oracle Home and CRS_HOME is installed.

  • Datafiles includes Online Logs, Controlfile and Datafiles

  • nfsvers and vers are identical on those OS platforms that has nfsvers.  The ver option is an alternative to the nfsvers option. It is included for compatibility with other operating systems

  • Please note that the mount options on each of the following cells are applicable only to those type of files listed in the column heading.

  • For RMAN backup sets, image copies, and Data Pump dump files, the "NOAC" mount option should not be specified - that is because RMAN and Data Pump do not check this option and specifying this can adversely affect performance.


Operating System

Mount options for    Binaries ##

Mount options for Oracle DatafilesMount options for CRS Voting Disk and OCR
Sun Solaris *

rw,bg,hard,nointr,rsize=32768,
wsize=32768,proto=tcp,noac,

vers=3,suid

rw,bg,hard,nointr,rsize=32768,
wsize=32768,proto=tcp,noac,
forcedirectio, vers=3,suid
rw,bg,hard,nointr,rsize=32768,
wsize=32768,proto=tcp,vers=3,
noac,forcedirectio
AIX (5L) **

rw,bg,hard,nointr,rsize=32768,
wsize=32768,proto=tcp,

vers=3,timeo=600

cio,rw,bg,hard,nointr,rsize=32768,
wsize=32768,proto=tcp,noac,
vers=3,timeo=600

cio,rw,bg,hard,intr,rsize=32768,
wsize=32768,tcp,noac,
vers=3,timeo=600

HPUX 11.23 ***  --rw,bg,vers=3,proto=tcp,noac,
hard,nointr,timeo=600,
rsize=32768,wsize=32768,suid
rw,bg,vers=3,proto=tcp,noac,
forcedirectio,hard,nointr,timeo=600,
rsize=32768,wsize=32768,suid
rw,bg,vers=3,proto=tcp,noac,
forcedirectio,hard,nointr,timeo=600
,rsize=32768,wsize=32768,suid
WindowsNot SupportedNot SupportedNot Supported
Linux x86
#
****

rw,bg,hard,nointr,rsize=32768,
wsize=32768,tcp, vers=3,
timeo=600, actimeo=0

rw,bg,hard,nointr,rsize=32768,
wsize=32768,tcp,actimeo=0,
vers=3,timeo=600

rw,bg,hard,nointr,rsize=32768,
wsize=32768,tcp,noac,actimeo=0,
vers=3,timeo=600

Linux x86-64 #
****
rw,bg,hard,nointr,rsize=32768,
wsize=32768,tcp,vers=3,
timeo=600, actimeo=0
rw,bg,hard,nointr,rsize=32768,
wsize=32768,tcp,actimeo=0,
vers=3,timeo=600
rw,bg,hard,nointr,rsize=32768,
wsize=32768,tcp,noac,vers=3,
timeo=600,actimeo=0
Linux - Itaniumrw,bg,hard,nointr,rsize=32768,
wsize=32768,tcp,vers=3,
timeo=600, actimeo=0
rw,bg,hard,nointr,rsize=32768,
wsize=32768,tcp,actimeo=0,
vers=3,timeo=600
rw,bg,hard,nointr,rsize=32768,
wsize=32768,tcp,noac,vers=3,
timeo=600,actimeo=0

* NFS mount option “forcedirectio” is required on Solaris platforms when mounting the OCR/CRS files when using Oracle 10.1.0.4 or 10.2.0.2 or later (Oracle unpublished bug 4466428)
** AIX is only supported with NAS on AIX 5.3 TL04 and higher with Oracle 10.2.0.1 and later (NetApp)
*** NAS devices are only supported with HPUX 11.23 or higher ONLY
**** As per BUG 11812928, the 'intr' & 'nointr' are deprecated in OEL 5.6 kernels and up including Oracle Linux 6. It is harmless to still include it, but the "NFS: ignoring mount option: nointr" will appears. This message can be ingnored.


# These mount options are for Linux kernels 2.6 and above for older kernels please check Note 279393.1

Due to Unpublished bug 5856342, it is necessary to use the following init.ora parameter when using NAS with all versions of RAC on Linux (x86 & X86-64 platforms) until 10.2.0.4. This bug is fixed and included in 10.2.0.4 patchset.
filesystemio_options = DIRECTIO

Single Instance


Operating System

Mount options for BinariesMount options for Oracle Datafiles
Sun Solaris *
(8, 9, 10)

rw,bg,hard,rsize=32768,wsize=32768,vers=3,nointr,proto=tcp,suid

rw,bg,hard,rsize=32768,wsize=32768,vers=3,[forcedirectio or llock],nointr,proto=tcp,suid
AIX (5L) **

rw,bg,hard,rsize=32768,wsize=32768,vers=3,intr,timeo=600,proto=tcp

rw,bg,hard,rsize=32768,wsize=32768,vers=3,cio,intr,timeo=600,proto=tcp

HPUX 11.23 ****rw,bg,hard,rsize=32768,wsize=32768,vers=3,nointr,timeo=600,proto=tcp,suidrw,bg,hard,rsize=32768,wsize=32768,vers=3,nointr,timeo=600,proto=tcp, suid, forcedirectio
WindowsNot SupportedNot Supported
Linux x86
#
rw,bg,hard,rsize=32768,wsize=32768,vers=3,nointr,timeo=600,tcprw,bg,hard,rsize=32768,wsize=32768,vers=3,nointr,timeo=600,tcp,actimeo=0*
Linux x86-64 #rw,bg,hard,rsize=32768,wsize=32768,vers=3,nointr,timeo=600,tcprw,bg,hard,rsize=32768,wsize=32768,vers=3,nointr,timeo=600,tcp,actimeo=0*
Linux - Itaniumrw,bg,hard,rsize=32768,wsize=32768,vers=3,nointr,timeo=600,tcprw,bg,hard,rsize=32768,wsize=32768,vers=3,nointr,timeo=600,tcp


* actime=0 or noac can be used


本文出自 “忧忧郁郁” 博客,请务必保留此出处http://wangy

分享到:QQ空间新浪微博腾讯微博微信百度贴吧QQ好友复制网址打印

您可能想查找下面的文章:

  • oracle数据库使用nfs存储,启动报错提示无法锁定文件

相关文章

  • IIS8中添加WCF支持几种方法总结
  • 电脑桌面向右移动了,如何恢复?
  • Windows与Linux中生成以当前时间命名的文件
  • 八个简单设置让你的IE 8浏览器提速
  • 企业里实现代码自动部署、回滚的解决方案——Caphub
  • 禁止Windows Server 2008 R2密码过期提示
  • Windows 操作系统的路径变量简介
  • 安装软件时程序中断,系统未被修改
  • 谈谈重复数据删除
  • liunx服务使用(xinetd服务代理服务的服务、 telnet服务、)

文章分类

  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx

最近更新的内容

    • windows 2003服务器远程桌面超出最大连接数解决办法
    • 免疫Windows系统 不受恶意代码骚扰
    • Serv-U服务器安装配置图解教程(1/2)
    • LNMP基于fastcgi实现nginx,php,mysql的分离
    • Windows2003 如何查看端口是否已打开及端口占用情况
    • Windows沙拉:文件关联的实现原理
    • liunx基本命令(用户的管理,难点重复介绍)
    • discuz 常见报错
    • 运维虚拟化之VMware虚拟化项目实施步骤
    • mdadm软RAID的删除方法和注意事项

关于我们 - 联系我们 - 免责声明 - 网站地图

©2020-2025 All Rights Reserved. linkedu.com 版权所有