• linkedu视频
  • 平面设计
  • 电脑入门
  • 操作系统
  • 办公应用
  • 电脑硬件
  • 动画设计
  • 3D设计
  • 网页设计
  • CAD设计
  • 影音处理
  • 数据库
  • 程序设计
  • 认证考试
  • 信息管理
  • 信息安全
菜单
linkedu.com
导航菜单
  • 网页制作
  • 数据库
  • 程序设计
  • 操作系统
  • CMS教程
  • 游戏攻略
  • 脚本语言
  • 平面设计
  • 软件教程
  • 网络安全
  • 电脑知识
  • 服务器
  • 视频教程
  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx
您的位置:首页 > 服务器 >windows > IIS 7.5中一些诡异问题的解决方案

IIS 7.5中一些诡异问题的解决方案

作者:网友 字体:[增加 减小] 来源:互联网

本文主要包含iis配置问题,iis问题,win10 iis权限问题,iis,宾得k5iis等服务器相关知识,网友希望可以进行参考

本文章介绍了关于IIS 7.5中一些诡异问题的解决方案,有需要了解的朋友可参考一下下哦。

问题描述:

如果第一次在IIS 7.5部署WCF 服务文件---.svc的时候,你很有可能会遇到下面的问题:

404 – Not Found - The page you are requesting cannot be served because of the extension of the configuration. If the page is a script, add a handler. If the file should be downloaded, add a MIME map.
解决方案:

404,很熟悉吧。就是没找到文件。

其实,这问题很简单,发生错误的主要原因是HTTP Handler默认配置中的虚拟目录并没有映射(mapping)到以.svc为后缀的文件名。svc我们都知道在WCF机制中的重要性。既然目录都找不到,当然就会报错的哦!~。

步骤:

第一步:打开命令提示框。也就是cmd。

第二步:在黑屏窗口中,通过cd 导航到一下目录:

C:WindowsMicrosoft.NetFrameworkv3.0Windows Communication Foundation
第三步:然后输入:

ServiceModelReg –i如图

二。在IIS中 不能看到Window Authentication(window 授权)
我们都知道,在IIS 7.0中,默认情况下有以下3中授权方式:

Anonymous(匿名,默认情况下打开)

Impersonation( 模拟身份,默认情况关闭)

Forms(默契情况下关闭)

如图:

如图:

 可能有些童鞋会觉得,不对啊,好像上面还缺少一种。对,缺少的就是“Windows Authentication”这个验证方式。那么,有些人就会问,是没有了呢?还是被路人甲给隐藏了呢?

呵呵,其实是隐藏的!~~微软这孩子已经把它不作为默认出现了。如果你真的需要这种验证方式,那么可以如下这么做:

打开控制面板(Control Panel),然后找到“Programs and Features”,在点击“Turn Windows Features on/off “,如下:

然后。。。

勾选上就可以了~~~~

三。Login failed for user 'IIS APPPOOLClassic .NET
这种情况主要发生在运用Windows Credentials 访问数据库时。宿主服务器(Host Server) 有sql 2008数据库以及有HTTP 请求经过路由(routed)。

基于这种情况的主要是因为改变这个Classic .NET Application的进程属性标识,所以如果碰到这个情况,那么你需要把你的虚拟目录映射(mapped)Classic .NET Application中就可以了。

过程如下:

 第一步:打开你的IIS 管理器(我很喜欢直接在“开始”→“运行”里敲入  inetmgr,然后打开,觉得很酷!~嘻嘻。)

 第二步:在IIS 管理器里,选择“Application Pools(应用程序池)”,在右边的列表里,选择“Class .NET AppPools”

IIS 7.5版本中一些诡异问题的解决方案

2012-06-12 09:36 by 随风浪迹天涯, 200 visits, 收藏, 编辑

前言

我想任何一个基于.NET的宫城师都会同意微软的产品,特别是这个IIS,常常在你很恨意外的时候抛出异常来,比如在你的主要产品要升级的时候。然后你会花好多时间去找啊找,找到天荒地老。悲催!~。

此篇文章的目标主要是为了IIS 7.5 在一些情况下的解决方案。希望这些对你们有帮助。

一。 IIS 有关WCF 宿主(hosting)问题

问题描述:

如果第一次在IIS 7.5部署WCF 服务文件---.svc的时候,你很有可能会遇到下面的问题:

 代码如下 复制代码

404 – Not Found - The page you are requesting cannot be served because of the extension of the configuration. If the page is a script, add a handler. If the file should be downloaded, add a MIME map.

解决方案:

404,很熟悉吧。就是没找到文件。

其实,这问题很简单,发生错误的主要原因是HTTP Handler默认配置中的虚拟目录并没有映射(mapping)到以.svc为后缀的文件名。svc我们都知道在WCF机制中的重要性。既然目录都找不到,当然就会报错的哦!~。

步骤:

第一步:打开命令提示框。也就是cmd。

第二步:在黑屏窗口中,通过cd 导航到一下目录:

 代码如下 复制代码

C:WindowsMicrosoft.NetFrameworkv3.0Windows Communication Foundation

第三步:然后输入:

 代码如下 复制代码
ServiceModelReg –i

如图

这样就OK了。

二。在IIS中 不能看到Window Authentication(window 授权)

我们都知道,在IIS 7.0中,默认情况下有以下3中授权方式:

Anonymous(匿名,默认情况下打开)

Impersonation( 模拟身份,默认情况关闭)

Forms(默契情况下关闭)

如图:

 可能有些童鞋会觉得,不对啊,好像上面还缺少一种。对,缺少的就是“Windows Authentication”这个验证方式。那么,有些人就会问,是没有了呢?还是被路人甲给隐藏了呢?

呵呵,其实是隐藏的!~~微软这孩子已经把它不作为默认出现了。如果你真的需要这种验证方式,那么可以如下这么做:

打开控制面板(Control Panel),然后找到“Programs and Features”,在点击“Turn Windows Features on/off “,如下:

然后。。。

勾选上就可以了~~~~

三。Login failed for user 'IIS APPPOOLClassic .NET

这种情况主要发生在运用Windows Credentials 访问数据库时。宿主服务器(Host Server) 有sql 2008数据库以及有HTTP 请求经过路由(routed)。

基于这种情况的主要是因为改变这个Classic .NET Application的进程属性标识,所以如果碰到这个情况,那么你需要把你的虚拟目录映射(mapped)Classic .NET Application中就可以了。

过程如下:

 第一步:打开你的IIS 管理器(我很喜欢直接在“开始”→“运行”里敲入  inetmgr,然后打开,觉得很酷!~嘻嘻。)

 第二步:在IIS 管理器里,选择“Application Pools(应用程序池)”,在右边的列表里,选择“Class .NET AppPools”

第三步:打开它的“Advanced Setting(高级设置)”。把Process Model下面的Identity属性改为LocalSystem,如下图:

四。HTTP Error 500.23 - Internal Server Error
为什么会发生这样的错误呢?这个很大程度上是因为和托管的管道模式(Managed Pipeline Mode)设置有关系.

这个主要有2个解决方案:

第一个:改变你虚拟目录映射的Application Pool(应用程序池)的Managed Pipeline 模式。默认情况下,你虚拟目录将映射到DefaultAppPool下的Integrated Managed Pipeline模式。OK,我们需要把它从Integrated 到Classic模式就行了

 方法2:为你的虚拟目录创建一个新的Application

在你的网页目录下,右键,添加一个“Application”,如下:

分享到:QQ空间新浪微博腾讯微博微信百度贴吧QQ好友复制网址打印

您可能想查找下面的文章:

  • IIS 7.5中一些诡异问题的解决方案

相关文章

  • nginx+php编译安装
  • ganglia监控部署学习笔记分享
  • apache如何绑定多个域名
  • Win7的telnet服务怎么打开,Windows7如何用Telnet
  • 如何在本地系统中挂载VHD硬盘(附右键快捷命令)
  • svn修改新url地址方法(linux,windows,centos)
  • Windows 操作系统的路径变量简介
  • Hyper-V Server2008 R2的热插拔技术
  • 如何禁止登陆QQ聊天系统
  • Python+django 快速建立简易blog

文章分类

  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx

最近更新的内容

    • Windows操作系统的经典蓝屏场景回顾[多图]
    • rsync 排除文件和文件夹参数详解
    • Windows 系统运行命令操作十个技巧
    • Windows XP安装Apache环境图文详解
    • windows服务器asp木马删除不了解决办法
    • 提高数据中心能效必须与业务目标挂钩
    • Linux学者必备文件通配符掌握8
    • iis与apache取消目录脚本执行权限方法
    • Windows 2003 中密钥无效解决方法
    • PHP中apache和iis下Rewrite静态化服务器配置方法

关于我们 - 联系我们 - 免责声明 - 网站地图

©2020-2025 All Rights Reserved. linkedu.com 版权所有