• linkedu视频
  • 平面设计
  • 电脑入门
  • 操作系统
  • 办公应用
  • 电脑硬件
  • 动画设计
  • 3D设计
  • 网页设计
  • CAD设计
  • 影音处理
  • 数据库
  • 程序设计
  • 认证考试
  • 信息管理
  • 信息安全
菜单
linkedu.com
导航菜单
  • 网页制作
  • 数据库
  • 程序设计
  • 操作系统
  • CMS教程
  • 游戏攻略
  • 脚本语言
  • 平面设计
  • 软件教程
  • 网络安全
  • 电脑知识
  • 服务器
  • 视频教程
  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx
您的位置:首页 > 服务器 >windows > iis服务器提示 http错误 500 Internal Server Error解决办法

iis服务器提示 http错误 500 Internal Server Error解决办法

作者:网友 字体:[增加 减小] 来源:互联网

本文主要包含iis http跳转https,iis http error 503,iis http 500,iis http重定向,iis http转https等服务器相关知识,网友希望可以进行参考

本文章来给各位朋友介绍iis服务器提示 http错误 500 Internal Server Error解决办法,有需要此类问题的朋友可参考参考。

排查问题

最初得到的错误提示是:HTTP 500 - Internal server error ,但我去掉了“显示友好的HTTP错误消息”后,得到了更详细的错误代码。我在这次网上搜索的过程中也遇到很多人都有HTTP 500 - Internal server error 的错误信息,但可能每个人更具体的错误都不一样,不能盲目的轻信别人的建议了


内部服务器500错误的几种可能

们以下三种判断依据和相应的解决方案:

1.服务器资源超载

如果你没对网站文件做过什么更改的话,最有可能的是同服务器的资源超载:即同一时间内处理器有太多的进程需要处理的时候,会出现500错误。借助SSH,可以在命令行中输入以下命令查看:

ps faux

ps faux |grep username

如果你查到某个进程消耗过多资源,可以用kill命令强制关闭这个进程,只需输入该进程的进程号(Pid):

kill -9 pid

2.文件权限设置错误

500错误还有可能是对文件设置了不正确的权限:

后台目录和文件的权限默认应该是755,而图片,文字等html文件应该是644,所以如果在刚刚上传文件后出现500错误,应该主要检查文件权限设置。

可以使用FTP软件选中所有文件,然后批量修改文件权限。

3 .htaccess文件写入错误的代码

在使用某些wordpress SEO插件的时候,插件会改写.htacess文件,如果语法错误的话就有可能造成500错误!

在.htaccess文件中,可能因为添入了一些与源文件冲突的代码。所以为了检测到错误语句,最好的方法是为语句添加注释来逐条验证。因为注释之后,语句就不再起作用。

逐条添加“#”在语句前面,如

 代码如下 复制代码

DirectoryIndex default.html
AddType application/x-httpd-php5 php

你可以添加#到该命令前,从而实现注释效果:

 代码如下 复制代码

DirectoryIndex default.html
#AddType application/x-httpd-php5 php

.net出现如下错误

HTTP Error 500.21 - Internal Server Error

Handler "WebServiceHandlerFactory-Integrated" has a bad module "ManagedPipelineHandler" in its module list

原因:在安装Framework v4.0之后,再启用IIS,导致Framework没有完全安装

解决:

 代码如下 复制代码

开始->所有程序->附件->鼠标右键点击“命令提示符”->以管理员身份运行->%windir%Microsoft.NETFrameworkv4.0.30319aspnet_regiis.exe -i

分享到:QQ空间新浪微博腾讯微博微信百度贴吧QQ好友复制网址打印

您可能想查找下面的文章:

  • iis服务器提示 http错误 500 Internal Server Error解决办法

相关文章

  • ↑mysql主从复制实现SSL加密和半同步复制↑
  • Windows7下系统环境变量的配置图解
  • Windows中IIS7+FastCGI配置PHP环境
  • iis“Microsoft JET Database Engine(0x80004005)未指定错误”
  • wamp 虚拟目录You don’t have permission to acce
  • LAMP&LNMP自动化安装脚本
  • nginx日志
  • phpMyAdmin在服务器创建一个mysql数据库
  • 八个简单设置让你的IE 8浏览器提速
  • 国内云存储领域后起之秀

文章分类

  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx

最近更新的内容

    • 后棱镜门时代企业核心数据如何存储
    • .htaccess重定向和url重写
    • 八个简单设置让你的IE 8浏览器提速
    • windows下定时cmd命令行运行php文件实例
    • liunx基本命令(权限的使用)
    • Nginx+uWSGI+DJango+Python+ Mysql 搭建可靠的python web服务器
    • 通过shell脚本防止端口扫描
    • Windows Server 2008 设置简单密码的方法
    • Centos自建集群搭配细化
    • FTP连接错误:PASV模式失败&数据socket 错误

关于我们 - 联系我们 - 免责声明 - 网站地图

©2020-2025 All Rights Reserved. linkedu.com 版权所有