• linkedu视频
  • 平面设计
  • 电脑入门
  • 操作系统
  • 办公应用
  • 电脑硬件
  • 动画设计
  • 3D设计
  • 网页设计
  • CAD设计
  • 影音处理
  • 数据库
  • 程序设计
  • 认证考试
  • 信息管理
  • 信息安全
菜单
linkedu.com
导航菜单
  • 网页制作
  • 数据库
  • 程序设计
  • 操作系统
  • CMS教程
  • 游戏攻略
  • 脚本语言
  • 平面设计
  • 软件教程
  • 网络安全
  • 电脑知识
  • 服务器
  • 视频教程
  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx
您的位置:首页 > 服务器 >windows > Windows不能在本地计算机启动iis admin service

Windows不能在本地计算机启动iis admin service

作者:网友 字体:[增加 减小] 来源:互联网

本文主要包含windows admin,windows7admin,iis admin service,iisadmin.dll,iisadmin.dll下载等服务器相关知识,网友希望可以进行参考

今天我在把两个硬盘复制之后直接也把iis复制过来了,但是我的World Wide Web Publishing Service与IIS Admin Service无法启动了,后来找了一些解决办法。

问题说明

硬盘对考后:World Wide Web Publishing Service和IIS Admin Service无法启动

IIS Admin Service提示错误:Windows不能在本地计算机启动iis  admin  service.错误代码是2145318902.查看事件管理器,提示的错误是:未能模拟ASP应用程序LM/W3SVC/ROOT/report的匿名用户.将不执行GLOBAL.ASA  ONEND例程.

  发现windows/system32/inetsrv/metabase.xml大小变成了0,

解析办法metabase.xml所在的目录下还有个history目录,里面存放的是metabase.xml文件在各个时间的备份。至此,解决办法也有了,就是从history目录下拷贝一份到inetsrv目录即可。

  虽然方法很简单,但肯定会有很多朋友没有想到,所以今天写在这里,希望对大家有所帮助

其它关于iis不能启动原因总结

IIS Admin Service 服务因 2149647636 (0x80210514) 服务性错误而停止
服务器 {A9E69610-B80D-11D0-B9B9-00A0C922E750} 没有在限定的时间内用 DCOM 注册。
IIS Admin Service 服务因 2149647636 (0x80210514) 服务性错误而停止。
与 HTTP SSL 服务相依的 IIS Admin Service 服务因下列错误而无法启动:
服务已返回特定的服务错误代码。
与 World Wide Web Publishing Service 服务相依的 IIS Admin Service 服务因下列错误而无法启动:
服务已返回特定的服务错误代码。
IIS Admin Service 服务因 2149647636 (0x80210514) 服务性错误而停止。

解决办法

开始,运行输入 regsvr32 Msxml3.dll 回车

一般就可以解决了,如果上面运行之还是没有办法我们可删除下面是MetaBase.xml文件里,完整的一个网站配置的信息,供参考,在删除时就是从<IIsWebServer 到</IIsWebVirtualDir>全部删除。

 代码如下 复制代码

<IIsWebServer        Location ="/LM/W3SVC/196384284"
                AuthFlags="0"
                LogPluginClsid="{FF160663-DE82-11CF-BC0A-00AA006111E0}"
                MaxBandwidth="307200"
                MaxConnections="30"
                ServerAutoStart="TRUE"
                ServerBindings=":80:www.hzhuti.com
                        :80:xxxxxx.com"
                ServerComment="xxxxxx"
        >
</IIsWebServer>
<IIsFilters        Location ="/LM/W3SVC/196384284/filters"
                AdminACL="49634462f0000000a400000040000000a033df9ebf05aec22b99d08927eb6f88c1835151bf15810cffc558860e147e44af56f7389b3b6c05764b6b8d44dccce1d236ad84647cac4f451862de8a8ce15e4d8144ecb47cc781dbe2493568e79f93acc4e7ece68247e1abcdaad4987d5bdeb6c824086427f5e51d560f693a774e7507bb5c2b5d48f31ee4ba0a0f0af468a17467c7f0e9e8dd6b37453b5b888d87b2af4c397ec83d960d1a9f28d1a2caa915274007da36a434ff91122ee589a4f25bfc5f3e4edaff4edce4be45d2a9e5d3f87568a27eb77a16261d4bc5e374f20d86c3daf716252b6689065069ba378a6afd8b9d21dac97be71c"
        >
</IIsFilters>
<IIsWebVirtualDir        Location ="/LM/W3SVC/196384284/root"
                AccessFlags="AccessSource | AccessRead | AccessWrite | AccessScript"
                AnonymousUserName="NETLINE-7TTINPF/xxxxxx"
                AnonymousUserPass="49634462600000001600000040000000a033df9ef605c052d899b78987eb5b88f9836451ab15810c90ff4b6076ced1cea3542be8dcc834c518ca159a85e1a47c7565a6a28151c6e37bc49551b22339462634f2a0e64a22b8850e94b1aaf04e53085200d47df6a245"
                AppFriendlyName="默认应用程序"
                AppIsolated="2"
                AppRoot="/LM/W3SVC/196384284/Root"
                AspEnableParentPaths="TRUE"
                AuthFlags="AuthAnonymous | AuthNTLM"
                DefaultDoc="index.htm,index.asp,Default.htm,Default.asp,Default.aspx"
                DirBrowseFlags="DirBrowseShowDate | DirBrowseShowTime | DirBrowseShowSize | DirBrowseShowExtension | DirBrowseShowLongDate | EnableDefaultDoc"
                Path="E:/xxxxxx/www"
                ScriptMaps=".asa,C:/WINDOWS/system32/inetsrv/asp.dll,5,GET,HEAD,POST,TRACE
                        .asax,C:/WINDOWS/Microsoft.NET/Framework/v1.1.4322/aspnet_isapi.dll,5,GET,HEAD,POST,DEBUG
                        .ascx,C:/WINDOWS/Microsoft.NET/Framework/v1.1.4322/aspnet_isapi.dll,5,GET,HEAD,POST,DEBUG
                        .ashx,C:/WINDOWS/Microsoft.NET/Framework/v1.1.4322/aspnet_isapi.dll,1,GET,HEAD,POST,DEBUG
                        .asmx,C:/WINDOWS/Microsoft.NET/Framework/v1.1.4322/aspnet_isapi.dll,1,GET,HEAD,POST,DEBUG
                        .asp,C:/WINDOWS/system32/inetsrv/asp.dll,5,GET,HEAD,POST,TRACE
                        .aspx,C:/WINDOWS/Microsoft.NET/Framework/v1.1.4322/aspnet_isapi.dll,1,GET,HEAD,POST,DEBUG
                        .axd,C:/WINDOWS/Microsoft.NET/Framework/v1.1.4322/aspnet_

分享到:QQ空间新浪微博腾讯微博微信百度贴吧QQ好友复制网址打印

您可能想查找下面的文章:

  • Windows不能在本地计算机启动iis admin service

相关文章

  • aspx禁止跨站、禁止读取iis信息、禁止cmd命令执行
  • Mailbox:日支撑过亿信息数据库的性能调优及集群迁移
  • 电脑开机为什么要按F1才能进入系统,如何解决?
  • NBU MediaServer 备份失败状态码2
  • Windows 2003服务器初始化第二磁盘
  • Apache中怎么修改默认站点目录
  • Understanding Lync load balance
  • iis环境下配置网站与网站权限配置图文教程
  • oracle数据库表空间文件迁移
  • 用户 NT AUTHORITY\NETWORK SERVICE登录失败解决方法

文章分类

  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx

最近更新的内容

    • 80端口被inetinfo.exe占用解决方法
    • 融合式架构--数据中心兴起的新星
    • VMware Workstation 虚拟机上重装系统
    • 源代码编译安装apache启动报错
    • Windows 2003中IIS不支持FLV视频文件
    • Win2003+IIS6+PHP5.33(FastCGI)+MySQl5.1.50安装配置
    • phpMyAdmin在服务器创建一个mysql数据库
    • windows服务器修改密码的图文教程
    • Windows操作系统下 如何安装Memcache软件
    • Win2003哪里下载

关于我们 - 联系我们 - 免责声明 - 网站地图

©2020-2025 All Rights Reserved. linkedu.com 版权所有