今天我在把两个硬盘复制之后直接也把iis复制过来了,但是我的World Wide Web Publishing Service与IIS Admin Service无法启动了,后来找了一些解决办法。
问题说明
硬盘对考后:World Wide Web Publishing Service和IIS Admin Service无法启动
IIS Admin Service提示错误:Windows不能在本地计算机启动iis admin service.错误代码是2145318902.查看事件管理器,提示的错误是:未能模拟ASP应用程序LM/W3SVC/ROOT/report的匿名用户.将不执行GLOBAL.ASA ONEND例程.
发现windows/system32/inetsrv/metabase.xml大小变成了0,
解析办法metabase.xml所在的目录下还有个history目录,里面存放的是metabase.xml文件在各个时间的备份。至此,解决办法也有了,就是从history目录下拷贝一份到inetsrv目录即可。
虽然方法很简单,但肯定会有很多朋友没有想到,所以今天写在这里,希望对大家有所帮助
其它关于iis不能启动原因总结
IIS Admin Service 服务因 2149647636 (0x80210514) 服务性错误而停止
服务器 {A9E69610-B80D-11D0-B9B9-00A0C922E750} 没有在限定的时间内用 DCOM 注册。
IIS Admin Service 服务因 2149647636 (0x80210514) 服务性错误而停止。
与 HTTP SSL 服务相依的 IIS Admin Service 服务因下列错误而无法启动:
服务已返回特定的服务错误代码。
与 World Wide Web Publishing Service 服务相依的 IIS Admin Service 服务因下列错误而无法启动:
服务已返回特定的服务错误代码。
IIS Admin Service 服务因 2149647636 (0x80210514) 服务性错误而停止。
解决办法
开始,运行输入 regsvr32 Msxml3.dll 回车
一般就可以解决了,如果上面运行之还是没有办法我们可删除下面是MetaBase.xml文件里,完整的一个网站配置的信息,供参考,在删除时就是从<IIsWebServer 到</IIsWebVirtualDir>全部删除。
| 代码如下 | 复制代码 |
|
<IIsWebServer Location ="/LM/W3SVC/196384284" 您可能想查找下面的文章: | |

