• linkedu视频
  • 平面设计
  • 电脑入门
  • 操作系统
  • 办公应用
  • 电脑硬件
  • 动画设计
  • 3D设计
  • 网页设计
  • CAD设计
  • 影音处理
  • 数据库
  • 程序设计
  • 认证考试
  • 信息管理
  • 信息安全
菜单
linkedu.com
导航菜单
  • 网页制作
  • 数据库
  • 程序设计
  • 操作系统
  • CMS教程
  • 游戏攻略
  • 脚本语言
  • 平面设计
  • 软件教程
  • 网络安全
  • 电脑知识
  • 服务器
  • 视频教程
  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx
您的位置:首页 > 服务器 >IIS教程 > centos7.2安装mysql5.7.17

centos7.2安装mysql5.7.17

作者:网友 字体:[增加 减小] 来源:互联网

本文主要包含centos7.2安装mysql,如何安装mysql5.7.17,mysql5.7.17安装教程,怎么安装mysql5.7.17,mysql5.7.17安装图解等服务器相关知识,网友希望可以进行参考

centos7.2安装mysql5.7.17


CentOS 7之后的版本yum的默认源中使用MariaDB替代原先MySQL,因此安装方式较为以往有一些改变:

下载mysql的源

wgethttp://dev.mysql.com/get/mysql57-community-release-el7-7.noarch.rpm

安装yum库

yumlocalinstall-ymysql57-community-release-el7-7.noarch.rpm

安装MySQL

yuminstall-ymysql-community-server

启动MySQL服务

systemctlstartmysqld.service

MySQL5.7加强了root用户的安全性,因此在第一次安装后会初始化一个随机密码,以下为查看初始随机密码的方式

grep'temporarypassword'/var/log/mysqld.log

结果如下:

使用初始随机密码登录后MySQL会强制要求修改密码,否则无法正常使用,(密码必须包含小写、大写字母及特殊字符,当然也有其他方法不受此限制,再次不多做描述),修改方法如下:

SETPASSWORD=PASSWORD('yournewpassword');ALTERUSER'root'@'localhost'PASSWORDEXPIRENEVER;flushprivileges;

然后退出后即可用新密码登录。

远程连接授权:

GRANTALLPRIVILEGESON*.*TO'root'@'%'IDENTIFIEDBY'yourpassword'WITHGRANTOPTION;

开通端口(默认3306):

firewall-cmd--add-port=3306/tcp

分享到:QQ空间新浪微博腾讯微博微信百度贴吧QQ好友复制网址打印

您可能想查找下面的文章:

  • centos7.2安装mysql5.7.17
  • centos7.2安装mysql5.7.17

相关文章

  • Centos一键部署openstack RDO packstack
  • 致DBA:为什么你经常犯错,是因为你做的功课不够
  • Discuz!使用imagemagic添加水印的相关问题
  • 强制DataNode向NameNode上报blocks
  • 【干货】解密监控宝Docker监控实现原理
  • IIS教程:因权限问题被拒绝访问的解决方案
  • 走进长安汽车 轻盈IT促转型
  • Discuz转换到X后用户无法登录的解决方法
  • FTP服务器架设考虑三方面的安全因素
  • Serv-U中文版建立FTP服务器教程

文章分类

  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx

最近更新的内容

    • 走进青岛中集 看IT轻盈之道
    • [转]建立大容量基于Web的Email系统
    • UC通信成功,Discuz头像不显示的解决方法
    • Linux下vsftp的安装和配置方法
    • 产品级敏捷案例: 企业云存储,案例企业云存储
    • phpmailer发送邮件 SMTP Error: Could not authenticate 错误
    • 天玑科技全力打造IT资源管控平台
    • Service Unavailable关于IIS连接数的几种解释
    • linux tun/tap设备的实现(kennel 3.10)
    • 大型网站集群构建之:DNS配置篇

关于我们 - 联系我们 - 免责声明 - 网站地图

©2020-2025 All Rights Reserved. linkedu.com 版权所有