• linkedu视频
  • 平面设计
  • 电脑入门
  • 操作系统
  • 办公应用
  • 电脑硬件
  • 动画设计
  • 3D设计
  • 网页设计
  • CAD设计
  • 影音处理
  • 数据库
  • 程序设计
  • 认证考试
  • 信息管理
  • 信息安全
菜单
linkedu.com
导航菜单
  • 网页制作
  • 数据库
  • 程序设计
  • 操作系统
  • CMS教程
  • 游戏攻略
  • 脚本语言
  • 平面设计
  • 软件教程
  • 网络安全
  • 电脑知识
  • 服务器
  • 视频教程
  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx
您的位置:首页 > 服务器 >windows > 上传文件提示413 Request Entity Too Large错误

上传文件提示413 Request Entity Too Large错误

作者:网友 字体:[增加 减小] 来源:互联网

本文主要包含stringrequestentity,requestentity,413 request entity,entity too large,413 entity too large等服务器相关知识,网友希望可以进行参考

今天发现网站上传文件时提示413 Request Entity Too Large错误了,以前我有介绍过nginx时上传大文件时提示413 Request Entity Too Large,下面我来总结一下常用的nginx,apache,iis出现此问题的解决办法。

Nginx服务器


原因是请求实体太长了。一般出现种情况是Post请求时Body内容Post的数据太大了
如上传大文件过大; 如POST数据比较多
处理方法修改nginx.conf的值就可以解决了。
client_max_body_size 2M        改为
client_max_body_size 10M

Apache服务器


修改下Apache配置文件中的LimitRequestBody配置,如果是虚拟主机,请联系空间商帮助修改。
具体步骤:
在apache环境中上传较大软件的时候,有时候会出现413错误,出现这个错误的原因,是因为apache的配置不当造成的,找到apache的配置文件目录也就是conf目录,和这个目录平行的一个目录叫conf.d打开这个conf.d,里面有一个php.conf
目录内容如下:
# PHP is an HTML-embedded scripting language which attempts to make it
# easy for developers to write dynamically generated webpages.
LoadModule php4_module modules/libphp4.so
# Cause the PHP interpreter handle files with a .php extension.
SetOutputFilter PHP
SetInputFilter PHP
LimitRequestBody 6550000
# Add index.php to the list of files that will be served as directory
# indexes.
#
DirectoryIndex index.php
错误就发生在这个LimitRequestBody配置上,将这个的值改大到超过你的软件大小就可以了
如果没有这个配置文件请将
SetOutputFilter PHP
SetInputFilter PHP
LimitRequestBody 6550000
写到apache的配置文件里面即可。

IIS服务器(Windows Server 2003系统IIS6)


先停止IIS Admin Service服务,然后
找到windows/system32/inesrv/下的metabase.xml,打开,找到ASPMaxRequestEntityAllowed 修改为需要的值,然后重启IIS Admin Service服务
1、在web服务扩展 允许active server pages和在服务器端的包含文档
2、修改各站点的属性 主目录-配置-选项-启用父路径
3、使之可以上传大文档(修改成您想要的大小就可以了,以字节为单位)
c:/WINDOWS/system32/inetsrv/MetaBase.xml
!企业版的windows2003在第592行
默认的预设置值 AspMaxRequestEntityAllowed="204800" 即200K

将其加两个0,即改为,现在最大就可以上传20M了。
AspMaxRequestEntityAllowed="20480000"

分享到:QQ空间新浪微博腾讯微博微信百度贴吧QQ好友复制网址打印

您可能想查找下面的文章:

  • 上传文件提示413 Request Entity Too Large错误

相关文章

  • Windows Server 2008巧妙配置DHCP服务器
  • Windows服务器IIS中设置站点或目录的执行权限
  • iis中常用见的错误代码
  • nginx+php编译安装
  • nginx main和events模块学习
  • 在CentOS 5上配置NFS服务器
  • 自己搭建家庭“云”(1)——概念、布局、平台选择
  • Windows Server 2003 标准版 IIS6.0 安装配置
  • 网站出现Service Unavailable报错的处理方法
  • Mysql主从复制讲解 从官方手册说起

文章分类

  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx

最近更新的内容

    • Windows服务器中安装 GruntJS方法介绍
    • 【微软的VDI】Windows Server 2012 RDS存储相关
    • 四、配置开机自动启动Nginx + PHP【LNMP安装 】
    • IIS应用程序池自动停止/关闭/假死网提示 Service Unavailable解决办法
    • Windows IIS如何设置CDN的CACHE过期时间
    • NTFS 权限导致的程序疑难问题排查
    • windows环境配置apache+php+mysql开发环境
    • liunx基本命令(进程的学习)
    • Windows Server 2008服务器系统数据安全
    • windows下python安装sqlalchemy教程

关于我们 - 联系我们 - 免责声明 - 网站地图

©2020-2025 All Rights Reserved. linkedu.com 版权所有