• linkedu视频
  • 平面设计
  • 电脑入门
  • 操作系统
  • 办公应用
  • 电脑硬件
  • 动画设计
  • 3D设计
  • 网页设计
  • CAD设计
  • 影音处理
  • 数据库
  • 程序设计
  • 认证考试
  • 信息管理
  • 信息安全
菜单
linkedu.com
导航菜单
  • 网页制作
  • 数据库
  • 程序设计
  • 操作系统
  • CMS教程
  • 游戏攻略
  • 脚本语言
  • 平面设计
  • 软件教程
  • 网络安全
  • 电脑知识
  • 服务器
  • 视频教程
  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx
您的位置:首页 > 服务器 >windows > 利用tcmalloc优化mysql主从

利用tcmalloc优化mysql主从

作者:网友 字体:[增加 减小] 来源:互联网

本文主要包含tcmalloc,jemalloc tcmalloc,tcmalloc 安装,mysql主从复制,mysql主从配置等服务器相关知识,网友希望可以进行参考

实现环境:mysql 5.5.27,cenot 6.2 64bit,centos 最小化安装。软件cmake-2.8.8.tar.gz,

libunwind-1.0.tar.gz ,gperftools-2.0.tar.gz 。

一,主服务器IP:192.168.1.15,从服务器IP:192.168.1.16。先配置主服务器,安装好系统后需要安装开发环境:yum -y groupinstall 'Development tools' ,centos 6.0的系统只需安装Development tools。

二,安装libunwind和gperftools。

  1. 安装libunwind库。 
  2.  
  3.     # tar xf libunwind-1.0.tar.gz  
  4.     # tar xf libunwind-1.0  
  5.     #CFLAGS=-fPIC ./configure添加编译参数  
  6.     # make CFLAGS=-fPIC  
  7.     # make CFLAGS=-fPIC install  
  8.  
  9. 这样执行会出现如下错误: 
  10.  
  11.     libtool: install: error: relink `libunwind-setjmp.la' with the above command before installing it  
  12.     make[3]: *** [install-libLTLIBRARIES] Error 1  
  13.     make[3]: Leaving directory `/down/libunwind-1.0/src'  
  14.     make[2]: *** [install-am] Error 2  
  15.     make[2]: Leaving directory `/down/libunwind-1.0/src'  
  16.     make[1]: *** [install] Error 2  
  17.     make[1]: Leaving directory `/down/libunwind-1.0/src'  
  18.     make: *** [install-recursive] Error 1  
  19.  
  20. 产生这种问题的原因:autotools兼容性的问题,运行命令autoreconf -i -f  ,在重新编译安装下。 
  21.  
  22.     #autoreconf -i -f  
  23.     #make clean  
  24.     #CFLAGS=-fPIC ./configure  
  25.     #make  CFLAGS=-fPIC   
  26.     #make  CFLAGS=-fPIC install  
  27.  
  28. 安装gpperftools: 
  29.  
  30.     #tar xf  gperftools-2.0.tar.gz  
  31.     # cd gperftools-2.0  
  32.     #./configure   
  33.     #make && make install   
  34.  
  35. 这样安装会会报如下错误: 
  36.  
  37.     cc1plus: warning: unrecognized command line option "-Wno-unused-result"  
  38.     ake: *** [stacktrace.lo] Error 1  
  39.  
  40. 为什么出现在这种错误,因此是64bit系统,至于更深度的解释,安装说明中有。下面重新编译。 
  41.  
  42.     #make clean   
  43.     #./configure  --enable-frame-pointers   
  44.     #make &&  make install   
  45.     #echo "/usr/local/lib" > /etc/ld.so.conf.d/usr_local_lib.conf  
  46.     #ldconfig  

三,安装cmake与mysql

  1. 安装cmake 
  2. #tar xf cmake-2.8.8.tar.gz   
  3. #cd cmake-2.8.8  
  4. # ./bootstrap   
  5. # gmake && gmake install  
  6.  
  7. 安装mysql 
  8. #useradd -r mysql  -s /sbin/nologin
  9. #mkdir -p /data/mysql/{data,binlog,relaylog} 
  10. #chown mysql:mysql -R /data/mysql 
  11. # tar xf mysql-5.5.27.tar.gz    
  12. #cd mysql-5.5.27 
  13. #cmake -DCMAKE_INSTALL_PREFIX=/usr/local/mysql -DDEFAULT_CHARSET=utf8 -DDEFAULT_COLLATION=utf8_general_ci -DEXTRA_CHARSETS=all -DWITH_MYISAM_STORAGE_ENGINE=1 -DWITH_INNOBASE_STORAGE_ENGINE=1  -DENABLED_LOCAL_INFILE=1 -DMYSQL_DATADIR=/data/mysql/data  -DWITH_DEBUG=0  -DSYSCONFDIR=/etc -DMYSQL_TCP_PORT=3306  
  14. #会编译不过去,提示需要安装ncurses-devel,yum -y install ncurses-devel 
  15. #rm -f CMakeCache.txe 重新执行./configure
  16. # make && make install  
  17. #cd /usr/local/mysql 
  18. #chown -R mysql:mysql * 
  19. # cp support-files/mysql.server /etc/rc.d/init.d/mysqld 
  20. #chmod +x /etc/init.d/mysqld
  21. #chkconfig mysqld on
  22. # vim /etc/profile  添加PATH=$PATH:/usr/local/mysql/bin 
  23. # . /etc/profile(或
分享到:QQ空间新浪微博腾讯微博微信百度贴吧QQ好友复制网址打印

您可能想查找下面的文章:

  • Tcmalloc优化Nginx内存管理
  • 利用tcmalloc优化mysql主从

相关文章

  • VMware Workstation 虚拟机上重装系统
  • Windows沙拉:文件关联的实现原理
  • DELL R420 & MD3220 IO性能测试报告
  • 中小企业开源存储方案演变详解
  • windows2003服务器iis新建Web网站图解
  • 国产服务器的喜与忧
  • 电脑忘记密码之找回密码的方法大汇总
  • 用来安装 Microsoft Windows 的产品密钥可能无效
  • 华硕服务器主板无盘系统方案
  • Win2003无法重命名administrator帐号的解决方法

文章分类

  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx

最近更新的内容

    • 垃圾、无用文件无法删除问题的解决办法
    • Windows下安装MariaDB数据库小结
    • Windows 无法连接到System Event Notification Service服务
    • Windows Server 2008 R2 设置SMTP服务(图)
    • iis服务器提示 http错误 500 Internal Server Error解决办法
    • 网站出现Service Unavailable报错的处理方法
    • windows服务器asp木马删除不了解决办法
    • 如何防止服务器溢出 降低可能的几个方法
    • 如何禁止Hyper-V虚拟机进入锁定界面/登录界面
    • How To:通过资源管理器查看文件夹大小

关于我们 - 联系我们 - 免责声明 - 网站地图

©2020-2025 All Rights Reserved. linkedu.com 版权所有