• linkedu视频
  • 平面设计
  • 电脑入门
  • 操作系统
  • 办公应用
  • 电脑硬件
  • 动画设计
  • 3D设计
  • 网页设计
  • CAD设计
  • 影音处理
  • 数据库
  • 程序设计
  • 认证考试
  • 信息管理
  • 信息安全
菜单
linkedu.com
导航菜单
  • 网页制作
  • 数据库
  • 程序设计
  • 操作系统
  • CMS教程
  • 游戏攻略
  • 脚本语言
  • 平面设计
  • 软件教程
  • 网络安全
  • 电脑知识
  • 服务器
  • 视频教程
  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx
您的位置:首页 > 服务器 >windows > Apache中启动失败错误日志总结

Apache中启动失败错误日志总结

作者:网友 字体:[增加 减小] 来源:互联网

本文主要包含apache错误日志,apache错误日志在哪,查看apache错误日志,apache 启动日志,apache日志等服务器相关知识,网友希望可以进行参考

本文章总结了Apache中启动失败错误日志各种解决方法,有需要学习的朋友可参考一下。

Apache启动失败错误日志:
The Apache service named reported the following error:
>>> httpd.exe: Could not reliably determine the server’s fully qualified domain name, using 192.168.0.210 for ServerName .

分析:不能可靠地确定服务器的完全限定的域名,使用的192.168.0.210)

The Apache service named reported the following error:
>>> (OS 10055)由于系统缓冲区空间不足或队列已满,不能执行套接字上的操作。 : make_sock: unable to listen for connections on address 0.0.0.0:80

分析:不能侦听80端口

The Apache service named reported the following error:
>>> Unable to open logs

分析:80端口被占用

The Apache service named reported the following error:
>>> [Sun May 13 09:29:45 2012] [warn] NameVirtualHost 192.168.0.210:80 has no VirtualHosts

分析:绑定的IP和端口无法对应虚拟主机

 总体错误概述:
从上面的报错分析可以看出:

1.80端口被占用

2.apache无法绑定IP(192.168.0.210)

3.日志文件可能打不开

 解决过程:
1.winsock的问题导致:
1.网上邻居->本地连接->属性->internet协议(TCP/IP)->属性->高级->wins标签->去掉启用LMhosts查询前的勾.

2.控制面版->windows防火墙->高级标签->本地连接设置->服务的标签里勾选安全Web服务器(HTTPS)即可.

3.重置LSP到初始状态(常见的是winsockfix这个软件,金山清理专家的LSP修复工具也能解决该问题)。重启后,问题得解决。(直接用360自带的LSP恢复到初始状态不用重启可生效)

2.多网卡多IP导致:
服务器上有两块网卡,分别配置了不同的IP,apache未指定侦听IP

解决方法:

方法一:禁用没有使用的那块网卡

方法二:配置apache侦听指定IP的端口:

Listen 192.168.0.210:80

3.80端口被占用:
查找那个应用占用80端口,关闭占用应用或修改占用软件使用的端口即可。

 

分享到:QQ空间新浪微博腾讯微博微信百度贴吧QQ好友复制网址打印

您可能想查找下面的文章:

  • Apache中启动失败错误日志总结

相关文章

  • IIS开启Gzip失败的决方法和如何开启gzip
  • Hadoop运维记录系列(十)
  • 无法打开用户默认数据库的解决方法
  • 云平台与云主机选择的经验和建议
  • 电脑开始运行命令备忘Windows运行命令
  • HTTP 401.5未经授权:ISAPI-CGI 应用程序授权失败解决办法
  • IIS中php sendmail函数无法发送邮件
  • 六、在不停止Nginx服务的情况下平滑变更Nginx配置【LNMP安装 】
  • 绝对超乎你的想像:电脑五大件故障率统计II
  • Linux squid代理一基本概念

文章分类

  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx

最近更新的内容

    • 部署awstats分析系统
    • linux运维故障定位汇总
    • 基于Drbd+Corosync构建高可用Mysql服务器
    • Window2003 iis+mysql+php+zend环境配置图解
    • inetinfo.exe是什么进程 关于inetinfo.exe的介绍
    • rsync 排除文件和文件夹参数详解
    • 微软PDC:Asp.net和C#技术更加web化
    • Hadoop (CDH4发行版)集群部署 (部署脚本,namenode高可用,hadoop管理)
    • 怎么让配置Apache支持.htaccess文件
    • 域普通用户临时提升权限

关于我们 - 联系我们 - 免责声明 - 网站地图

©2020-2025 All Rights Reserved. linkedu.com 版权所有