• linkedu视频
  • 平面设计
  • 电脑入门
  • 操作系统
  • 办公应用
  • 电脑硬件
  • 动画设计
  • 3D设计
  • 网页设计
  • CAD设计
  • 影音处理
  • 数据库
  • 程序设计
  • 认证考试
  • 信息管理
  • 信息安全
菜单
linkedu.com
导航菜单
  • 网页制作
  • 数据库
  • 程序设计
  • 操作系统
  • CMS教程
  • 游戏攻略
  • 脚本语言
  • 平面设计
  • 软件教程
  • 网络安全
  • 电脑知识
  • 服务器
  • 视频教程
  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx
您的位置:首页 > 服务器 >windows > Windows中IIS7 大文件上传限制解决办法

Windows中IIS7 大文件上传限制解决办法

作者:网友 字体:[增加 减小] 来源:互联网

本文主要包含windows2003 iis7,iis7 windows 2008 r2,windows iis7,iis7 windows身份验证,iis7上传文件大小限制等服务器相关知识,网友希望可以进行参考

使用windows iis环境的朋友可能会发现上传比较大的文件居然会上传不了,后来百度了一下发现是iis7自己限制了上传文件大小,我们只要修改web.config中的maxRequestLength即可。

在IIS7下,即便你在web.config设置了maxRequestLength=”1048576”最大允许上传的大小,也是没用的,其实是受C:/Windows/System32/inetsrv/config/applicationHost.config的限制, 默认最大只能上传30M的文件,修改下这个文件就好了,在该文件的system.webServer/security/requestFiltering/节内添加

<requestLimits maxAllowedContentLength ="<length>" />

就行了,将<length>修改为你要允许的大小,注意,这里的单位是bytes,而web.config里的maxRequestLength的单位是KB

具体方法如下

目标是要修改文件C:/Windows/System32/inetsrv/config/schema/IIS_schema.xml  。红色下划线部分使我们要修改的目标位置。

 代码如下 复制代码

<element name="requestLimits">    

  <attribute name="maxAllowedContentLength"  type="uint" defaultValue="30000000" />      

<attribute name="maxUrl" type="uint"  defaultValue="4096" />     

 <attribute name="maxQueryString" type="uint"  defaultValue="2048" />     

 <element name="headerLimits">        

<collection addElement="add" clearElement="clear"  removeElement="remove">         

 <attribute name="header" type="string"  required="true" isUniqueKey="true" validationType="nonEmptyString" />                  

<attribute name="sizeLimit" type="uint"  required="true" />       

 </collection>     

 </element>

问题在于,这个文件是只读的,即使用管理员权限也不能修改。要先修改文件的权限,然后去掉只读属性才可以。

1.右键文件->属性->安全,选中目标用户,点击高级,修改文件所有者;

2.确定后点击编辑,就可以修改当前用户的权限了,添加“写入”权限。至此,权限设置OK了。

3.将文件的只读属性去掉。

4.以管理员身份打开VS,然后在VS中编辑目标XML文件,修改所需位置即可。

修改后重启IIS.

分享到:QQ空间新浪微博腾讯微博微信百度贴吧QQ好友复制网址打印

您可能想查找下面的文章:

  • windows下安装iis7配置php环境图文教程
  • windows让iis7支持php配置方法
  • Windows2003中IIS6/iis7伪静态组件安装配置
  • Windows中IIS7 大文件上传限制解决办法

相关文章

  • 企业里实现代码自动部署、回滚的解决方案——Caphub
  • Win7的telnet服务怎么打开,Windows7如何用Telnet
  • VMware虚拟机中激活Windows Server 2008的方法
  • Ghost时出现错误代码5555h的解决方法(一)
  • IIS中php sendmail函数无法发送邮件
  • WampServer的www目录更改为指定目录
  • RS.dll文件损坏 游戏因RS.dll不能玩的问题
  • iis中域名绑定的方法图解
  • Windows2012远程桌面的“限制每个用户只能进行一个会话”的解除方法
  • centos 6.4下的samba服务器的构建

文章分类

  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx

最近更新的内容

    • NBU MediaServer 备份失败状态码2
    • Hyper-V3虚拟机文件类型简介
    • 大数据环境下的磁盘脚本思考和实现
    • nagios3.2.0搭建过程
    • Nginx下构建nagios监控平台Nagios+nrpe+nagios-plugins+pnp安装文档
    • 64 位硬件和软件的优势(Office SharePoint Server 2007)
    • Windows 2008计算机不能添加到域的原因分析
    • 正则表达式和grep的基本用法9
    • 详解Windows切至Linux的7大障碍
    • 锐捷找不到网卡或网卡初始化失败的解决方案

关于我们 - 联系我们 - 免责声明 - 网站地图

©2020-2025 All Rights Reserved. linkedu.com 版权所有