• linkedu视频
  • 平面设计
  • 电脑入门
  • 操作系统
  • 办公应用
  • 电脑硬件
  • 动画设计
  • 3D设计
  • 网页设计
  • CAD设计
  • 影音处理
  • 数据库
  • 程序设计
  • 认证考试
  • 信息管理
  • 信息安全
菜单
linkedu.com
导航菜单
  • 网页制作
  • 数据库
  • 程序设计
  • 操作系统
  • CMS教程
  • 游戏攻略
  • 脚本语言
  • 平面设计
  • 软件教程
  • 网络安全
  • 电脑知识
  • 服务器
  • 视频教程
  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx
您的位置:首页 > 服务器 >云计算 > ERROR (ConnectionError): HTTPConnectionPool (Caused by <class 'socket.error'>: [Errno 111] Connecti,errno111

ERROR (ConnectionError): HTTPConnectionPool (Caused by <class 'socket.error'>: [Errno 111] Connecti,errno111

作者:网友 字体:[增加 减小] 来源:互联网

本文主要包含ERROR (ConnectionError): HTTPConnectionPool (Caused by <class 'socket.error'>: [Errno 111] Connecti,errno111等服务器相关知识,网友希望可以进行参考

ERROR (ConnectionError): HTTPConnectionPool (Caused by <class 'socket.error'>: [Errno 111] Connecti,errno111


突然有一天使用 nova list  出现错误了

root@openstackcloud1:~# nova list

ERROR: HTTPConnectionPool(host='openstackcloud1', port=35357): Max retries exceeded with url: /v2.0/tokens (Caused by <class 'socket.error'>: [Errno 111] Connection refused)


原因是  nova-api service   没有启动起来

结果启动 还失败了

# service openstack-nova-api restart
Redirecting to /bin/systemctl restart  openstack-nova-api.service
Job for openstack-nova-api.service failed. See 'systemctl status openstack-nova-api.service' and 'journalctl -xn' for details.

通过查询错误日志 /var/log/nova/nova-api.log

看到如下错误:

2015-07-21 04:11:30.800 6879 ERROR nova.wsgi [-] Could not bind to 0.0.0.0:8775

原因是

openstack-nova-api and openstack-nova-metadata-api both run on the same port so you are getting "Address already in use" error.Try stopping "openstack-nova-metadata-api" service and run "openstack-nova-api".

只需两步

# service openstack-nova-metadata-api stop

# service openstack-nova-api restart

成功了

[root@localhost Desktop]# service openstack-nova-metadata-api stop
Redirecting to /bin/systemctl stop  openstack-nova-metadata-api.service
[root@localhost Desktop]# service openstack-nova-api restart
Redirecting to /bin/systemctl restart  openstack-nova-api.service


版权声明:本文为博主原创文章,未经博主允许不得转载。

分享到:QQ空间新浪微博腾讯微博微信百度贴吧QQ好友复制网址打印

您可能想查找下面的文章:

  • ERROR (ConnectionError): HTTPConnectionPool (Caused by &lt;class &#39;socket.error&#39;&gt;: [Errno 111] Connecti,errno111

相关文章

  • MapReduce排序及实例,MapReduce排序实例
  • Greenplum+Hadoop学习笔记-14-定义数据库对象之创建与管理数据库,hadoop-14-
  • hadoop集群搭建之NFS服务,hadoop集群nfs
  • Hadoop之—— CentOS Warning: $HADOOP_HOME is deprecated解决方案,hadoopdeprecated
  • 如何在coding.net上部署项目 (Flask),coding.netflask
  • 【Spark】Spark基本概念,spark基本概念
  • hive通过jdbc创建表,分区,桶,hivejdbc
  • Spark Standalone 以及 HDFS系统环境搭建,standalonehdfs
  • 机器学习算法-K-means聚类,算法-k-means聚类
  • 高阶MapReduce_3_reducer侧联结原理,mapreduce原理

文章分类

  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx

最近更新的内容

    • 分布式系列,分布式系统
    • Greenplum+Hadoop学习笔记-14-定义数据库对象之创建与管理表空间,hadoop-14-
    • 个性化推荐的十大挑战,个性化十大挑战
    • Scala类型详解,scala详解
    • openstack报错openstack-config:command not find,find
    • hive创建表语句详解,hive语句详解
    • IBM Symphony开发,ibmsymphony开发
    • Spark Core and Cluster Managers(翻译自Learning.Spark.Lightning-Fast.Big.Data.Analysis),
    • 自定义输出文件名,输出文件名
    • 初识云计算,初识云

关于我们 - 联系我们 - 免责声明 - 网站地图

©2020-2025 All Rights Reserved. linkedu.com 版权所有