• linkedu视频
  • 平面设计
  • 电脑入门
  • 操作系统
  • 办公应用
  • 电脑硬件
  • 动画设计
  • 3D设计
  • 网页设计
  • CAD设计
  • 影音处理
  • 数据库
  • 程序设计
  • 认证考试
  • 信息管理
  • 信息安全
菜单
linkedu.com
导航菜单
  • 网页制作
  • 数据库
  • 程序设计
  • 操作系统
  • CMS教程
  • 游戏攻略
  • 脚本语言
  • 平面设计
  • 软件教程
  • 网络安全
  • 电脑知识
  • 服务器
  • 视频教程
  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx
您的位置:首页 > 服务器 >云计算 > 《5》CentOS7.0+OpenStack+kvm云平台部署—配置Horizon,《5》kvm

《5》CentOS7.0+OpenStack+kvm云平台部署—配置Horizon,《5》kvm

作者:网友 字体:[增加 减小] 来源:互联网

本文主要包含centos7.0,centos7.0安装教程,centos7.0下载,centos7.0 64位下载,centos7.0镜像下载等服务器相关知识,网友希望可以进行参考

《5》CentOS7.0+OpenStack+kvm云平台部署—配置Horizon,《5》kvm


(1).安装Horizon

[root@openstack~]# yum -y install openstack-dashboard

 

(2).修改local_settings文件,将DEBUG= False修改为DEBUG =True

[root@openstack ~]# vi/etc/openstack-dashboard/local_settings

DEBUG = True

……

 

(3).修改httpd.conf文件,将#ServerNamewww.example.com:80修改为ServerName192.168.1.2:80

[root@openstack ~]# vi/etc/httpd/conf/httpd.conf

#ServerNamewww.example.com:80

ServerName192.168.1.2:80

 

(4).修改local_settings.py文件,将"Member"修改为"admin"

[root@openstack keystone]#vi /usr/share/openstack-dashboard/openstack_dashboard/local/local_settings.py 
#OPENSTACK_KEYSTONE_DEFAULT_ROLE = "Member"
OPENSTACK_KEYSTONE_DEFAULT_ROLE = "admin" 

 

(5).启动http服务,设置开机自启动

[root@openstack ~]# servicehttpd start

[root@openstack ~]# chkconfighttpd on

 

(6).重启nova-api服务

[root@openstack ~]# serviceopenstack-nova-api restart

 

(7).添加防火墙策略

[root@openstack ~]# iptables-I INPUT -p tcp --dport 80 -j ACCEPT

[root@openstack ~]# iptables-I INPUT -p tcp -m multiport --dports 5900:6000 -j ACCEPT

[root@openstack ~]# iptables-I INPUT -p tcp --dport 6080 -j ACCEPT

[root@openstack ~]# serviceiptables save

 

Horizon安装完成,使用http://10.1.1.2/dashboard访问openstackweb界面。

用户名:admin

密码:password

 

添加新项目

(1).为操作员用户创建一个tenant:

[root@openstack~]# keystone tenant-create --name=manager --description='Manager Tenant'

 

(2).创建操作员用户:

[root@openstack~]# keystone user-create --name=manager --pass=password--email=manager@zcs.com

 

(3).创建一个管理角色manager:

[root@openstack~]# keystone role-create --name=manager

 

(4).将manager角色添加到用户:

[root@openstack~]# keystone user-role-add --user=manager --tenant=manager --role=manager

 

(5).将nova角色添加到用户:

[root@openstack~]# keystone user-role-add --user=nova --tenant=service--role=manager 

分享到:QQ空间新浪微博腾讯微博微信百度贴吧QQ好友复制网址打印

您可能想查找下面的文章:

  • 《5》CentOS7.0+OpenStack+kvm云平台部署—配置Horizon,《5》kvm
  • 《2》CentOS7.0+OpenStack+kvm云平台部署—配置Keystone,centos7.0kvm
  • 《3》CentOS7.0+OpenStack+kvm云平台部署—配置Glance,《3》kvm
  • 《4》CentOS7.0+OpenStack+kvm云平台部署—配置Nova,《4》kvm
  • 《1》CentOS7.0+OpenStack+kvm云平台部署—基础配置,centos7.0kvm

相关文章

  • myeclipse2013 建的web项目没有web.xml,myeclipse中web.xml
  • Docker exec与Docker attach,dockerexecattach
  • openstack性能测试用例和测试结果,openstack性能测试
  • Hadoop之——HDFS命令,hadoophdfs
  • sbt pom reader,sbtpom
  • hive UDF自动增长列函数,hiveudf列函数
  • spark core源码分析16 Shuffle详解-读流程,sparkshuffle
  • 关于 unable to load shared object 'C:\Program Files\R\R-3.0.3\library\stats\libs\i386\stats.dll',r-3.0.3stats.dll
  • Andrew Ng机器学习课程10,andrewng机器课程
  • nova-compute[5410]: OSError: [Errno 13] Permission denied: '镜像路径',5410oserror

文章分类

  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx

最近更新的内容

    • Ceph集群磁盘没有剩余空间的解决方法,ceph集群
    • Bulk Load-HBase数据导入最佳实践,load-hbase最佳实践
    • Elasticsearch之Nested(嵌套)系列,elasticsearch
    • 云服务器之间实时文件同步和文件备份的最简单高效的免费方案,实时文件备份
    • HIVE的数据存储,HIVE数据存储
    • Spark中配置Parquet参数,sparkparquet参数
    • hive创建分区,hive创建
    • 【Spark1.3官方翻译】 Spark Submit提交应用程序,spark1.3spark
    • LXC学习,学习中国app上线
    • 2015 OpenCloud峰会总结,2015opencloud峰会

关于我们 - 联系我们 - 免责声明 - 网站地图

©2020-2025 All Rights Reserved. linkedu.com 版权所有