• linkedu视频
  • 平面设计
  • 电脑入门
  • 操作系统
  • 办公应用
  • 电脑硬件
  • 动画设计
  • 3D设计
  • 网页设计
  • CAD设计
  • 影音处理
  • 数据库
  • 程序设计
  • 认证考试
  • 信息管理
  • 信息安全
菜单
linkedu.com
导航菜单
  • 网页制作
  • 数据库
  • 程序设计
  • 操作系统
  • CMS教程
  • 游戏攻略
  • 脚本语言
  • 平面设计
  • 软件教程
  • 网络安全
  • 电脑知识
  • 服务器
  • 视频教程
  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx
您的位置:首页 > 服务器 >云计算 > hbase遇到问题及解决方法,hbase遇到问题

hbase遇到问题及解决方法,hbase遇到问题

作者:网友 字体:[增加 减小] 来源:互联网

本文主要包含hbase 热点问题,hdfs和hbase存储,hbase是什么,hbase,hbase应用场景等服务器相关知识,网友希望可以进行参考

hbase遇到问题及解决方法,hbase遇到问题


hbase遇到问题及解决方法

1.zookeeper启动报错

错误日志

启动zookeeper报错信息如下:

java.net.NoRouteToHostException: No route to host
        at java.net.PlainSocketImpl.socketConnect(Native Method)
        at java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:339)
        at java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:200)
        at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:182)
        at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)
        at java.net.Socket.connect(Socket.java:579)
        at org.apache.zookeeper.server.quorum.QuorumCnxManager.connectOne(QuorumCnxManager.java:368)
        at org.apache.zookeeper.server.quorum.QuorumCnxManager.connectAll(QuorumCnxManager.java:402)
        at org.apache.zookeeper.server.quorum.FastLeaderElection.lookForLeader(FastLeaderElection.java:840)
        at org.apache.zookeeper.server.quorum.QuorumPeer.run(QuorumPeer.java:762)
2015-05-19 10:26:26,983 [myid:1] - INFO  [QuorumPeer[myid=1]/0:0:0:0:0:0:0:0:2181:FastLeaderElection@849] - Notification time out: 800

解决方法

此问题产生的主要原因是因为zookeeper集群未关闭防火墙。
执行下面命令后仍然报上面的错误:
systemctl start iptables.service
经过仔细查找后发现,CentOS 7.0默认使用的是firewall作为防火墙,需要执行如下命令关闭防火墙:
systemctl stop firewalld.service #停止firewall
systemctl disable firewalld.service #禁止firewall开机启动
关闭各个节点防火墙后,重启zookeeper进程,就可以解决上述问题了。

分享到:QQ空间新浪微博腾讯微博微信百度贴吧QQ好友复制网址打印

您可能想查找下面的文章:

  • hbase遇到问题及解决方法,hbase遇到问题

相关文章

  • MapReduce排序及实例,MapReduce排序实例
  • MapReduce对输入多文件的处理,mapreduce输入处理
  • Hadoop源代码分析(三七),hadoop源代码
  • hive sql,hive
  • TopicModel主题模型,topicmodel模型
  • openstack-glance-api.service start request repeated too quickly, refusing to start,openstackglance
  • Andrew Ng机器学习课程9-补充,andrew9-
  • hadoop2.6.0伪分布式安装,hadoop2.6.0伪
  • Oxygen xml editor 16.0 x86 crack,oxygen16.0
  • 《转》OpenStack Live Migration,《转》openstack

文章分类

  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx

最近更新的内容

    • error: internal error: unable to execute QEMU command 'migrate': this feature or command is not cur,qemumigrate
    • MongoDB Query 的几个方法,mongodbquery
    • NOSQL(六)集群并发计算模型Map-Reduce,nosqlmap-reduce
    • A Note on Distributed Computing,anoteondialectic
    • Spark编程指南V1.4.0(翻译),编程指南v1.4.0
    • 深度学习工具caffe详细安装指南,深度caffe安装指南
    • 金典依旧,钱龙金典版
    • Andrew Ng Machine Learning,andrewlearning
    • spark streaming 调试技巧,sparkstreaming
    • 2015年中国的云计算标准有哪些?,2015年中国标准

关于我们 - 联系我们 - 免责声明 - 网站地图

©2020-2025 All Rights Reserved. linkedu.com 版权所有