• linkedu视频
  • 平面设计
  • 电脑入门
  • 操作系统
  • 办公应用
  • 电脑硬件
  • 动画设计
  • 3D设计
  • 网页设计
  • CAD设计
  • 影音处理
  • 数据库
  • 程序设计
  • 认证考试
  • 信息管理
  • 信息安全
菜单
linkedu.com
导航菜单
  • 网页制作
  • 数据库
  • 程序设计
  • 操作系统
  • CMS教程
  • 游戏攻略
  • 脚本语言
  • 平面设计
  • 软件教程
  • 网络安全
  • 电脑知识
  • 服务器
  • 视频教程
  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx
您的位置:首页 > 服务器 >云计算 > OutOfMemoryError PermGen space 的解决办法(头痛了几天),permgenspace

OutOfMemoryError PermGen space 的解决办法(头痛了几天),permgenspace

作者:网友 字体:[增加 减小] 来源:互联网

本文主要包含OutOfMemoryError PermGen space 的解决办法(头痛了几天),permgenspace等服务器相关知识,网友希望可以进行参考

OutOfMemoryError PermGen space 的解决办法(头痛了几天),permgenspace


解决

OutOfMemoryError: PermGen space

,过程是痛苦的,结果是舒畅的

 

 

最近自己的程序在

Redeploy

重新部署的时候,老提示

OutOfMemoryError: PermGen 

space

错误,在网络上搜索了相关的资料,但是按照做后还是存在这个问题。由

于我是第一次碰到这个问题,

花费了我

2

天时间,

过程比较痛苦,

结果还是比较

圆满的。我将我的经历写下来,供我自己以后参考,也提供给大家分享。

 

 

  

在网络上关于

OutOfMemoryError: 

PermGen 

space

的解决办法很多了,但是有

的办法都是互相转发,真假难辨。有的可能还产生误导。

 

 

   

我的环境是

Myeclips 

8.5

、

tomcat6.x

,

试过了很多办法后,

比如:

文档

《

Linux 

和

 Windows

修改

Java

虚拟机内存大小》

(

http://duanfei.iteye.com/blog/1189541

)

,

中的办法,

我都试过了,

还是不

行;

当然还参考了很多其他资料,

然后进一步研究

JVM

的优化等,

我就是想知道

我配置的内存参数应该够大了,

为什么还是溢出,

难道没有生效,

那我就需要找

到配置后系统认可的内存参数是多少,

参考网络上的知识,

启动了

JDK

自带的工

具,

在

\jdk1.6.0_10\bin

下面的

jconsole.exe

内存监控的工具,

点击进入如下:

选择

PID

为

4472

的这个进程,

 

点击

,进入如下界面,

 

 

选择内存页,并且选择图表中最后一个选项的“内存池“

Perm Gen

”

,下面的详细信息显示

的是:

 

这个地方的最大值是

65536Kb

,也就是

64M,

我于是就找到原因了,

64M

肯定会导致溢出,

但是我配置了几百兆的内存空间就是不生效呢。

注意,

这个是我在

myclipse

中启动的

tomcat

看到的结果。

 

 

 

接下来,我进入

bin/catalina.bat

分享到:QQ空间新浪微博腾讯微博微信百度贴吧QQ好友复制网址打印

您可能想查找下面的文章:

  • OutOfMemoryError PermGen space 的解决办法(头痛了几天),permgenspace

相关文章

  • Andrew Ng Machine Learning,andrewlearning
  • sbt pom reader,sbtpom
  • nova-compute[5410]: OSError: [Errno 13] Permission denied: '镜像路径',5410oserror
  • 使用 ElasticSearch + LogStash + Kibana 来可视化网络流量,kibanaelasticsearch
  • hive优化-----控制hive任务的reduce数,hivereduce
  • Redis源码学习:字符串,redis源码字符串
  • (Kilo)Devstack Kilo版本localrc推荐,devstacklocalrc
  • 玩转OpenStack网络Neutron(2)--使用Open vSwitch实现VLAN类型租户网络,openstackvswitch
  • 基于反射实现自动化restful开发,自动化restful开发
  • hadoop 运行jar文件,

文章分类

  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx

最近更新的内容

    • 关于 unable to load shared object 'C:\Program Files\R\R-3.0.3\library\stats\libs\i386\stats.dll',r-3.0.3stats.dll
    • hdfs一致性模型,hdfs一致性
    • AMQP server on c ontroller:5672 is unreachable: [Errno 113] EHOSTUNREACH. Trying again in 2 seconds.,ehostunreach
    • springmvc 访问不了后台的contrlollerUserController,springmvccontroller
    • Linux索引节点(Inode:no space for device)用满导致的一次故障,linuxinode
    • 浅谈大数据,浅谈数据
    • JOIN操作,数据库join操作
    • Hbase namespace问题,hbasenamespace问题
    • 讨论Spark的配置监控和性能优化,spark监控性能优化
    • -bash:jps:command not found,-bashjps

关于我们 - 联系我们 - 免责声明 - 网站地图

©2020-2025 All Rights Reserved. linkedu.com 版权所有