• linkedu视频
  • 平面设计
  • 电脑入门
  • 操作系统
  • 办公应用
  • 电脑硬件
  • 动画设计
  • 3D设计
  • 网页设计
  • CAD设计
  • 影音处理
  • 数据库
  • 程序设计
  • 认证考试
  • 信息管理
  • 信息安全
菜单
linkedu.com
导航菜单
  • 网页制作
  • 数据库
  • 程序设计
  • 操作系统
  • CMS教程
  • 游戏攻略
  • 脚本语言
  • 平面设计
  • 软件教程
  • 网络安全
  • 电脑知识
  • 服务器
  • 视频教程
  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx
您的位置:首页 > 服务器 >云计算 > Greenplum+Hadoop学习笔记-14-定义数据库对象之创建与管理模式,hadoop-14-

Greenplum+Hadoop学习笔记-14-定义数据库对象之创建与管理模式,hadoop-14-

作者:网友 字体:[增加 减小] 来源:互联网

本文主要包含Greenplum+Hadoop学习笔记-14-定义数据库对象之创建与管理模式,hadoop-14-等服务器相关知识,网友希望可以进行参考

Greenplum+Hadoop学习笔记-14-定义数据库对象之创建与管理模式,hadoop-14-


6.3.创建与管理模式

  • 概述:DB内组织对象的一种逻辑结构,一个DB内可以有多个模式,在未指定模式时默认放置在public中,可以通过”\dn”方式查看数据库中现有模式;

testdw=# \dn

       List of schemas

        Name        |  Owner 

--------------------+---------

 gp_toolkit         | gpadmin

 information_schema | gpadmin

 pg_aoseg           | gpadmin

 pg_bitmapindex     | gpadmin

 pg_catalog         | gpadmin

 pg_toast           | gpadmin

 public             | gpadmin

(7 rows)

  •   创建模式:使用CREATESCHEMA命令,通过查看帮助如下所示:

testdw=# \h CREATE SCHEMA

Command:     CREATE SCHEMA

Description: define a new schema

Syntax:

CREATE SCHEMA schemaname [ AUTHORIZATION username ] [ schema_element [ ... ] ]    将所有者设置为其他角色通过AUTHORIZTION

CREATE SCHEMA AUTHORIZATION username [ schema_element [ ... ] ]

  • 访问模式的对象:schema.table

testdw=# CREATE SCHEMA sc01;

CREATE SCHEMA

testdw=# \dn

       List of schemas

        Name        |  Owner 

--------------------+---------

 gp_toolkit         | gpadmin

 information_schema | gpadmin

 pg_aoseg           | gpadmin

 pg_bitmapindex     | gpadmin

 pg_catalog         | gpadmin

 pg_toast           | gpadmin

 public             | gpadmin

 sc01               | gpadmin

(8 rows)

testdw=# create schema sc02 authorization mavshuang;

ERROR:  permission denied for database testdw  (seg1 slave2:40000 pid=5424)  提示testdw数据库中权限拒绝

testdw=# grant all on database testdw to mavshuang;             将testdw数据库的所有权限赋给mavshuang

GRANT

testdw=# create schema sc02 authorization mavshuang;

CREATE SCHEMA

testdw=# \dn

        List of schemas

        Name        |   Owner  

--------------------+-----------

 gp_toolkit         | gpadmin

 information_schema | gpadmin

 pg_aoseg           | gpadmin

 pg_bitmapindex     | gpadmin

 pg_catalog         | gpadmin

 pg_toast           | gpadmin

 public             | gpadmin

 sc01               | gpadmin

 sc02               | mavshuang                    此时用户是mavshuang

(9 rows)

  • 模式搜索路径:若不想通过指定模式名称的方式来搜索需要的对象,可以通过设置search_path的方式来实现,第一个模式为缺省。

testdw=# show search_path;

  search_path  

----------------

 "$user",public

(1 row)

  •  通过ALTERDATABASE修改DB的模式搜索路径

testdw-# \h alter database

Command:     ALTER DATABASE

Description: change a database

Syntax:

ALTER DATABASE name [ [ WITH ] option [ ... ] ]

where option can be:

    CONNECTION LIMIT connlimit

ALTER DATABASE name SET parameter { TO | = } { value | DEFAULT }     通过此命令来修改DB的模式搜索路径

ALTER DATABASE name RESET parameter

ALTER DATABASE name RENAME TO newname

ALTER DATABASE name OWNER TO new_owner

 

testdw=# alter database testdw set search_path to sc01,public,pg_catalog;   设置testdw数据库的搜索路径为sc01,public,pg_catalog;

ALTER DATABASE

testdw=# \q                                  修改完成后通过\q退出testdw数据库后重新登录

[gpadmin@master ~]$ psql -d testdw

psql (8.2.15)

Type "help" for help.

 

testdw=# show search_path;

       search_path       

--------------------------

 sc01, public, pg_catalog

(1 row)

 

  • 通过ALTER ROLE修改ROLE(User)的模式搜索路径:

testdw-# \h alter role

Command:     ALTER ROLE

Description: change a database role

Syntax:

ALTER ROLE name RENAME TO newname

ALTER ROLE name SET config_parameter {TO | =} {value | DEFAULT}

ALTER ROLE name RESET config_parameter

ALTER ROLE name RESOURCE QUEUE {queue_name | NONE}

ALTER ROLE name [ [WITH] option [ ... ] ]

where option can be:

      SUPERUSER | NOSUPERUSER

  &nbs

分享到:QQ空间新浪微博腾讯微博微信百度贴吧QQ好友复制网址打印

您可能想查找下面的文章:

  • Greenplum+Hadoop学习笔记-14-定义数据库对象之创建与管理模式,hadoop-14-

相关文章

  • Error: unable to connect to node 'rabbit@devlop-ceilo': nodedown,unabletoconnect
  • HIVE动态分区实战,hive动态实战
  • Apache Pig的前世今生,apachepig前世今生
  • H3C config vlan access and trunk links,h3ctrunk
  • <转>linux上nagios安装完整版,linuxnagios
  • HIVE的数据存储,HIVE数据存储
  • openstack中Nova组件Networks的所有python API 汇总,openstacknova
  • 使用export/import导出和导入docker容器,exportdocker
  • MemStore刷写线程—MemStoreFlusher源代码分析,hbasememstore
  • Spark Standalone 以及 HDFS系统环境搭建,standalonehdfs

文章分类

  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx

最近更新的内容

    • ERROR (ConnectionError): HTTPConnectionPool (Caused by <class 'socket.error'>: [Errno 111] Connecti,errno111
    • Hadoop自测题,hadoop
    • Centos 安装R 集成 Hadoop、RHive 配置安装手册,centoshadoop
    • [Spark源码剖析] DAGScheduler划分stage,sparkdagscheduler
    • Spark编程指南V1.4.0(翻译),编程指南v1.4.0
    • MongoDB 安装与启动,MongoDB安装启动
    • 机器学习-统计学习方法概论,学习方法概论
    • ElasticSearch的分布式安装
    • request.getScheme()的使用方法,request.getscheme
    • MapReduce编程之WordCount,mapreducewordcount

关于我们 - 联系我们 - 免责声明 - 网站地图

©2020-2025 All Rights Reserved. linkedu.com 版权所有