• linkedu视频
  • 平面设计
  • 电脑入门
  • 操作系统
  • 办公应用
  • 电脑硬件
  • 动画设计
  • 3D设计
  • 网页设计
  • CAD设计
  • 影音处理
  • 数据库
  • 程序设计
  • 认证考试
  • 信息管理
  • 信息安全
菜单
linkedu.com
导航菜单
  • 网页制作
  • 数据库
  • 程序设计
  • 操作系统
  • CMS教程
  • 游戏攻略
  • 脚本语言
  • 平面设计
  • 软件教程
  • 网络安全
  • 电脑知识
  • 服务器
  • 视频教程
  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx
您的位置:首页 > 服务器 >云计算 > Docker安装MySQL8.0的实现方法

Docker安装MySQL8.0的实现方法

作者:张德Talk 字体:[增加 减小] 来源:互联网

本文主要包含Docker安装MySQL8.0,Docker安装MySQL等服务器相关知识,张德Talk 希望可以进行参考
环境:MacOS_Cetalina_10.15.1、Mysql8.0.18、Docker_2.0.0.3

1、docker仓库搜索mysql

docker search mysql

2、docker仓库拉取mysql8.0

docker pull mysql:8.0
备注:
docker pull mysql //默认拉取最新版本

3、查看本地仓库镜像是否下载成功

docker images mysql:8.0

4、安装运行mysql8.0容器

docker run -p 3307:3306 --name mysql8.0 -e MYSQL_ROOT_PASSWORD=root -d mysql:8.0
备注:
-p 将本地主机的端口映射到docker容器端口(因为本机的3306端口已被其它版本占用,所以使用3307)
--name 容器名称命名
-e 配置信息,配置root密码
-d 镜像名称

5、查看mysql8.0容器运行情况

docker ps

6、docker登录mysql

docker exec -it mysql8.0 bash
mysql -uroot -p

7、使用客户端连接工具(navicat)远程登录mysql

发现登录不了,报错:navicat不支持caching_sha_password加密方式
原因:mysql8.0使用新的密码加密方式:caching_sha_password
解决方式:修改成旧的加密方式(mysql_native_password),并重置密码
* select host,user,plugin from user;
* alter user 'root'@'%' identified with mysql_native_password by 'root';

8、使用客户端连接工具(navicat)重新远程登录mysql

9、后记(常用的docker命令)

docker search 镜像名称 //搜索镜像
docker pull 镜像名称:版本号 //拉取对应版本的镜像
docker pull 镜像名称 //默认拉取最新的镜像
docker images //查看本地已下载的镜像
docker ps //查看正在运行的容器
docker ps -a //查看所有的容器(包括run、stop、exited状态的)
docker container ls //查看正在运行的容器
docker rm 容器ID //只能删除没有在运行的容器
docker rm -f 容器ID //可以删除正在运行的容器
docker run -p 本地主机端口号:容器服务端口号 --name 容器名字 [-e 配置信息修改] -d 镜像名字
docker start 容器ID //启动容器
docker stop 容器ID //终止容器
docker rmi 镜像名称orID //删除镜像

 

分享到:QQ空间新浪微博腾讯微博微信百度贴吧QQ好友复制网址打印

您可能想查找下面的文章:

  • Docker安装MySQL8.0的实现方法

相关文章

  • OpenStack Kilo版本新功能分析,openstackkilo
  • 1006-HBase操作实战(JAVA API模式),1006-hbaseapi
  • Hive Developing,hivedeveloping
  • Spark RDD API扩展开发(1),sparkrdd
  • CentOS 下面解决libvirt版本过低、升级冲突问题,centoslibvirt
  • HIVE动态分区实战,hive动态实战
  • hive创建分区,hive创建
  • Zoho产品经理谈中小企业面临的挑战及应对之策,zoho产品经理
  • Deploy FAILURE:An app Was not successfully detected by any available buildpack,deploybuildpack
  • kernel interrupt,interrupt

文章分类

  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx

最近更新的内容

    • hadoop2.7完全分布式安装,hadoop2.7
    • Linux快速配置svn库,Linux配置svn库
    • Spark中广播变量知识点
    • 新增数据页面360浏览器样式异常,新增360浏览器样式
    • openstack中glance组件images的所有python API 汇总,openstackglance
    • apache hadoop-2.6.0-CDH5.4.1 安装笔记,hadoop2.6.0安装
    • Spark调研笔记第3篇,spark调研第3篇
    • nova-compute[5410]: OSError: [Errno 13] Permission denied: '镜像路径',5410oserror
    • hive UDF自动增长列函数,hiveudf列函数
    • CentOS 下面解决libvirt版本过低、升级冲突问题,centoslibvirt

关于我们 - 联系我们 - 免责声明 - 网站地图

©2020-2025 All Rights Reserved. linkedu.com 版权所有