• linkedu视频
  • 平面设计
  • 电脑入门
  • 操作系统
  • 办公应用
  • 电脑硬件
  • 动画设计
  • 3D设计
  • 网页设计
  • CAD设计
  • 影音处理
  • 数据库
  • 程序设计
  • 认证考试
  • 信息管理
  • 信息安全
菜单
linkedu.com
导航菜单
  • 网页制作
  • 数据库
  • 程序设计
  • 操作系统
  • CMS教程
  • 游戏攻略
  • 脚本语言
  • 平面设计
  • 软件教程
  • 网络安全
  • 电脑知识
  • 服务器
  • 视频教程
  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx
您的位置:首页 > 服务器 >Ftp > FTP连接服务器遇到的FEAT命令连接失败的问题

FTP连接服务器遇到的FEAT命令连接失败的问题

作者:网友 字体:[增加 减小] 来源:互联网

本文主要包含ftp feat,feat,feat是什么意思,timber feat ke ha,endless tears feat等服务器相关知识,网友希望可以进行参考

FlashFXP连接不上:
[右] 正在连接到 xxxxx203 -> IP=202.*.*.238 PORT=21
[右] 已连接到 xxxx203
[右] 220 Serv-U FTP Server v6.3 for WinSock ready...
[右] USER xxxx8
[右] 331 User name okay, need password.
[右] PASS (隐藏)
[右] 230 User logged in, proceed.
[右] SYST
[右] 215 UNIX Type: L8
[右] FEAT
[右] 211-Extension supported
[右] 连接失败 (连接丢失)
[左] 连接失败 (连接超时)

解决方法:

1. 使用Fashfxp的解决方法:
  在菜单栏点 “站点”>>“站点管理器”或者直接按快捷键"F4",打开站点管理器窗口,从左边选择你要改变的站点,然后点击右边的“选项”选项卡,在此窗口中,找到“站点不支持FEAT命令”,在前面打上钩,“应用”,“关闭”。重新连接该站点即可。

2. 使用CuteFTP的解决方法。
  在菜单栏点 点“工具”>> “全局选项”或者直接按快捷键"ALT+F7",在“全局选项”窗口中,点左边的“连接”,在此界面的右边把“登陆到确定功能支持后发送FEAT命令(F)”前面的钩去掉。确定。重新连接就好了。

3.Windows 开启了系统防火墙

在例外里面添加Serv-U目录的ServUDaemon.exe并且在防火墙的-高级-本地连接设置将“FTP服务器”的勾选取消。

 

问题原因:

某些客户端使用的命令是pasv(被动模式), 另外一些客户端使用命令feat,就进不去。使用cuteftp7.0,或flashfxp的客户端停在feat。也设置为pasv(被动模式)。
feat命令是用来请求FTP服务器列出它的所有的扩展命令与扩展功能的。属于主动模式命令!端口被服务器禁掉了。修改成pasv(被动模式)就可以正常工作

以下参考资料:

FTP是仅基于TCP的服务,不支持UDP。与

众不同的是FTP使用2个端口,一个数据端口和一个命令端口(也可叫做控制端口)。通常来说这两个端口是21(命令端口)和20(数据端口)。但FTP 工作方式的不同,数据端口并不总是20。这就是主动与被动FTP的最大不同之处。

(一)主动FTP
主动方式的FTP是这样的:客户端从一个任意的非特权端口N(N>1024)连接到FTP服务器的命令端口,也就是21端口。然后客户端开始监听端口N+1,并发送FTP命令“port N+1”到FTP服务器。接着服务器会从它自己的数据端口(20)连接到客户端指定的数据端口(N+1)。
针对FTP服务器前面的防火墙来说,必须允许以下通讯才能支持主动方式FTP:

1. 任何大于1024的端口到FTP服务器的21端口。(客户端初始化的连接)
2. FTP服务器的21端口到大于1024的端口。 (服务器响应客户端的控制端口)
3. FTP服务器的20端口到大于1024的端口。(服务器端初始化数据连接到客户端的数据端口)
4. 大于1024端口到FTP服务器的20端口(客户端发送ACK响应到服务器的数据端口)

(二)被动FTP

为了解决服务器发起到客户的连接的问题,人们开发了一种不同的FTP连接方式。这就是所谓的被动方式,或者叫做PASV,当客户端通知服务器它处于被动模式时才启用。

在被动方式FTP中,命令连接和数据连接都由客户端发起,这样就可以解决从服务器到客户端的数据端口的入方向连接被防火墙过滤掉的问题。

当开启一个 FTP连接时,客户端打开两个任意的非特权本地端口(N > 1024和N+1)。第一个端口连接服务器的21端口,但与主动方式的FTP不同,客户端不会提交PORT命令并允许服务器来回连它的数据端口,而是提交 PASV命令。这样做的结果是服务器会开启一个任意的非特权端口(P > 1024),并发送PORT P命令给客户端。然后客户端发起从本地端口N+1到服务器的端口P的连接用来传送数据。
对于服务器端的防火墙来说,必须允许下面的通讯才能支持被动方式的FTP:

1. 从任何大于1024的端口到服务器的21端口 (客户端初始化的连接)
2. 服务器的21端口到任何大于1024的端口 (服务器响应到客户端的控制端口的连接)
3. 从任何大于1024端口到服务器的大于1024端口 (客户端初始化数据连接到服务器指定的任意端口)

4. 服务器的大于1024端口到远程的大于1024的端口(服务器发送ACK响应和数据到客户端的数据端口)


以上关于主动和被动FTP的解释,可以简单概括为以下两点:

主动FTP:

命令连接:客户端 >1024端口 -> 服务器 21端口

数据连接:客户端 >1024端口 <- 服务器 20端口

被动FTP:

命令连接:客户端 >1024端口 -> 服务器 21端口

数据连接:客户端 >1024端口 -> 服务器 >1024端口

下面是主动与被动FTP优缺点的简要总结:

主动FTP对FTP服务器的管理有利,但对客户端的管理不利。因为FTP服务器企图与客户端的高位随机端口建立连接,而这个端口很有可能被客户端的防火墙 阻塞掉。被动FTP对FTP客户端的管理有利,但对服务器端的管理不利。因为客户端要与服务器端建立两个连接,其中一个连到一个高位随机端口,而这个端口 很有可能被服务器端的防火墙阻塞掉。

幸运的是,有折衷的办法。既然FTP服务器的管理员需要他们的服务器有最多的客户连接,那么必须得支持被动FTP。我们可以通过为FTP服务器指定一个有 限的端口范围来减小服务器高位端口的暴露。这样,不在这个范围的任何端口会被服务器的防火墙阻塞。虽然这没有消除所有针对服务器的危险,但它大大减少了危 险。

分享到:QQ空间新浪微博腾讯微博微信百度贴吧QQ好友复制网址打印

您可能想查找下面的文章:

  • FTP连接服务器遇到的FEAT命令连接失败的问题

相关文章

  • Serv-U FTP服务器10大经典问题
  • 教你用SRP服务构建Linux下FTP服务器
  • Serv-U中文版建立FTP服务器教程
  • 解决FTP上传文件时出现的"Access is denied"错误
  • Microsoft FTP7.5 For IIS7.x 安装与使用教程
  • 花生壳实现互联网访问局域网FTP与WWW服务器
  • 使用wget和cron job进行远程ftp镜像备份
  • serv-u更改端口需在防火墙开放端口及说明
  • 应用:在Linux系统下配置WU-FTP服务器
  • FTP命令行使用方法 用命令方式登陆FTP详解

文章分类

  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx

最近更新的内容

    • FTP连接服务器遇到的FEAT命令连接失败的问题
    • Serv-U中文版建立FTP服务器教程
    • FTP服务器架设考虑三方面的安全因素
    • vsftp本地用户登录配置的详细介绍
    • Windows 2008设置解决ftp无法打开列表的情况
    • FTP服务器主动模式与被动模式的设置说明
    • 让Windows FTP服务器更安全
    • NET FTP Response error:(503) 的解决方法
    • 应用:在Linux系统下配置WU-FTP服务器
    • Microsoft FTP7.5 For IIS7.x 安装与使用教程

关于我们 - 联系我们 - 免责声明 - 网站地图

©2020-2025 All Rights Reserved. linkedu.com 版权所有