• linkedu视频
  • 平面设计
  • 电脑入门
  • 操作系统
  • 办公应用
  • 电脑硬件
  • 动画设计
  • 3D设计
  • 网页设计
  • CAD设计
  • 影音处理
  • 数据库
  • 程序设计
  • 认证考试
  • 信息管理
  • 信息安全
菜单
linkedu.com
导航菜单
  • 网页制作
  • 数据库
  • 程序设计
  • 操作系统
  • CMS教程
  • 游戏攻略
  • 脚本语言
  • 平面设计
  • 软件教程
  • 网络安全
  • 电脑知识
  • 服务器
  • 视频教程
  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx
您的位置:首页 > 服务器 >Ftp > 让Windows FTP服务器更安全

让Windows FTP服务器更安全

作者:网友 字体:[增加 减小] 来源:互联网

本文主要包含windows ftp服务器,windows搭建ftp服务器,windows7 ftp服务器,windows10 ftp服务器,windows服务器安装ftp等服务器相关知识,网友希望可以进行参考

Windows 2000系统提供 了FTP服务功能,由于简单易用,与Windows系统本身结合紧密,深受广大用户的喜爱。但使用IIS5.0架设的FTP服务器真的安全吗?它的默认设置其实存在很多安全隐患,很容易成为黑客们的攻击目标。如何让FTP服务器更加安全,只要稍加改造,就能做到。

  一 取消匿名访问功能

  默认情况下,Windows 2000系统的FTP服务器是允许匿名访问的,虽然匿名访问为用户上传、下载文件提供方便,但却存在极大的安全隐患。用户不需要申请合法的账号,就能访问FTP服务器,甚至还可以上传、下载文件,特别对于一些存储重要资料的FTP服务器,很容易出现泄密的情况,因此建议用户取消匿名访问功能。

  在Windows 2000系统中,点击“开始→程序→管理工具→Internet服务管理器”,弹出管理控制台窗口。然后展开窗口左侧的本地计算机选项,就能看到IIS5.0自带的FTP服务器,下面笔者以默认FTP站点为例,介绍如何取消匿名访问功能。

  右键点击“默认FTP站点”项,在右键菜单中选择“属性”,接着弹出默认FTP站点属性对话框,切换到“安全账号”标签页,取消“允许匿名连接”前的勾选(如图1),最后点击“确定”按钮,这样用户就不能使用匿名账号访问FTP服务器了,必须拥有合法账号。

  二 启用日志记录

  Windows日志记录着系统运行的一切信息,但很多管理员对日志记录功能不够重视,为了节省服务器资源,禁用了FTP服务器日志记录功能,这是万万要不得的。FTP服务器日志记录着所有用户的访问信息,如访问时间、客户机IP地址、使用的登录账号等,这些信息对于FTP服务器的稳定运行具有很重要的意义,一旦服务器出现问题,就可以查看FTP日志,找到故障所在,及时排除。因此一定要启用FTP日志记录。

  在默认FTP站点属性对话框中,切换到“FTP站点”标签页,一定要确保“启用日志记录”选项被选中,这样就可以在“事件查看器”中查看FTP日志记录了。


  三 正确设置用户访问权限

  每个FTP用户账号都具有一定的访问权限,但对用户权限的不合理设置,也能导致FTP服务器出现安全隐患。如服务器中的CCE文件夹,只允许CCEUSER账号对它有读、写、修改、列表的权限,禁止其他用户访问,但系统默认设置,还是允许其他用户对CCE文件夹有读和列表的权限,因此必须重新设置该文件夹的用户访问权限。

  右键点击CCE文件夹,在弹出菜单中选择“属性”,然后切换到“安全”标签页,首先删除Everyone用户账号,接着点击“添加”按钮,将CCEUSER账号添加到名称列表框中,然后在“权限”列表框中选中修改、读取及运行、列出文件夹目录、读取和写入选项,最后点击“确定”按钮。这样一来,CCE文件夹只有CCEUSER用户才能访问。

  四 启用磁盘配额

  FTP服务器磁盘空间资源是宝贵的,无限制的让用户使用,势必造成巨大的浪费,因此要对每位FTP用户使用的磁盘空间进行限制。下面笔者以CCEUSER用户为例,将其限制为只能使用100M磁盘空间。

  在资源管理器窗口中,右键点击CCE文件夹所在的硬盘盘符,在弹出的菜单中选择“属性”,接着切换到“配额”标签页(如图2),选中“启用配额管理”复选框,激活“配额”标签页中的所有配额设置选项,为了不让某些FTP用户占用过多的服务器磁盘空间,一定要选中“拒绝将磁盘空间给超过配额限制的用户” 复选框。  

  然后在“为该卷上的新用户选择默认配额限制”框中选择“将磁盘空间限制为”单选项,接着在后面的栏中输入100,磁盘容量单位选择为“MB”,然后进行警告等级设置,在“将警告等级设置为”栏中输入“96”, 容量单位也选择为“MB”,这样就完成了默认配额设置。此外,还要选中“用户超出配额限制时记录事件”和“用户超过警告等级时记录事件”复选框,以便将配额告警事件记录到Windows日志中。

  • 共2页:
  • 上一页
  • 1
  • 2
  • 下一页

分享到:QQ空间新浪微博腾讯微博微信百度贴吧QQ好友复制网址打印

您可能想查找下面的文章:

  • 让Windows FTP服务器更安全

相关文章

  • FTP连接服务器遇到的FEAT命令连接失败的问题
  • 应用:在Linux系统下配置WU-FTP服务器
  • 使用wget和cron job进行远程ftp镜像备份
  • FTP命令行使用方法 用命令方式登陆FTP详解
  • 让Windows FTP服务器更安全
  • Microsoft FTP7.5 For IIS7.x 安装与使用教程
  • Serv-U FTP服务器10大经典问题
  • 解决FTP上传文件时出现的"Access is denied"错误
  • FTP服务器主动模式与被动模式的设置说明
  • FTP服务器架设考虑三方面的安全因素

文章分类

  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx

最近更新的内容

    • Serv-U中文版建立FTP服务器教程
    • Microsoft FTP7.5 For IIS7.x 安装与使用教程
    • 解决FlashFXP错误10049无法分配请求的地址
    • 教你用SRP服务构建Linux下FTP服务器
    • FTP命令行使用方法 用命令方式登陆FTP详解
    • 在命令行下实验FTP的PASV传输模式
    • Ubuntu自带的FTP服务器vsftpd技巧
    • NET FTP Response error:(503) 的解决方法
    • Windows2003开启安装系统默认FTP服务教程
    • 应用:在Linux系统下配置WU-FTP服务器

关于我们 - 联系我们 - 免责声明 - 网站地图

©2020-2025 All Rights Reserved. linkedu.com 版权所有