• linkedu视频
  • 平面设计
  • 电脑入门
  • 操作系统
  • 办公应用
  • 电脑硬件
  • 动画设计
  • 3D设计
  • 网页设计
  • CAD设计
  • 影音处理
  • 数据库
  • 程序设计
  • 认证考试
  • 信息管理
  • 信息安全
菜单
linkedu.com
导航菜单
  • 网页制作
  • 数据库
  • 程序设计
  • 操作系统
  • CMS教程
  • 游戏攻略
  • 脚本语言
  • 平面设计
  • 软件教程
  • 网络安全
  • 电脑知识
  • 服务器
  • 视频教程
  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx
您的位置:首页 > 服务器 >服务器运维 > 补丁服务器常见的五种故障

补丁服务器常见的五种故障

作者:网友 字体:[增加 减小] 来源:互联网

本文主要包含wsus补丁服务器,补丁服务器,windows 补丁服务器,微软补丁服务器,超级跑跑与补丁服务器等服务器相关知识,网友希望可以进行参考

 
图1  CPU占用率100%

 

图2  svchost.exe占用了大量CPU资源

图3  完成安装KB927891补丁

 

图4  设置自动更新属性

WSUS是由Microsoft提供的,为Microsoft操作系统、Microsoft Office、Microsoft服务器类产品ISA Server等)和其他产品Visual Studio系列等)提供补丁管理的服务器。许多企业都部署了WSUS服务器,但WSUS服务器的使用并不是一帆风顺的。本文介绍在使用WSUS服务器中碰到的几个重要问题并介绍解决方法。

当CPU占用率100%

在第一次配置WSUS服务器时,在为工作站配置并使用WSUS服务器升级系统时,有些工作站的速度会变得非常慢。这些工作站的任务管理器可能会显示CPU占用率为100%, svchost.exe进程也可能占用100%或将近100%的CPU资源如图1、图2)。

出现这种问题时,可以暂时中止svchost.exe进程,下载补丁并在工作站上安装,然后重新启动计算机就可以解决该问题。需要注意,在安装补丁的时候,出现图3所示的界面才表示补丁被正确安装了。在有的工作站上,需要反复多次地安装这个补丁才能解决问题。

针对这个问题,还有以下两点说明:1.WSUS服务器已经提供了这个补丁,但由于各种原因,有的工作站不能及时安装,所以就会出现CPU占用率100%的现象。2.当WSUS在后台自动安装补丁时,CPU占用率暂时可能会达到100%,但不会一直在100%,而是在40%~100%之间反复。出现这种情况是正常的。

工作站不能联系WSUS

在使用gpedit.msc配置工作站进行WSUS服务器更新,或把编辑好的“注册表文件”导入工作站并从企业内部进行WSUS服务器升级,在第一次做这些工作时,为了让工作站立刻从WSUS服务器下载补丁,需要在命令提示符下输入以下内容:

Wuauclt /detectnow

Wuauclt1 /detectnow

然后再使用netstat -an,如没有发现到WSUS服务器的连接,或没有使用上述命令,但过几天之后工作站没有从WSUS服务器下载任何补丁,并且在WSUS服务器上也没有发现该工作站,那么需要在该工作站上安装WSUS客户端代理程序,并重新启动计算机来解决这个问题。

下载地址为:http://download.windowsupdate.com/Windows

Update/redist/standalone/7.0.6000

.381/WindowsUpdateAgent30-x86.exe。

自动更新出了问题

当工作站端配置为自动下载并计划安装时,工作站将会在指定的时间安装如图4)。可能有人认为,工作站不会在指定的时间安装,但经过多次测试,结果如下:

当工作站从WSUS服务器下载完补丁后,会在右下角出现黄色的感叹号并提示“已经为您的计算机准备好更新,单击此处安装这些更新”。根据用户是否选择,将会有三种情况:

1.如果用户单击黄色的感叹号,会弹出自动更新对话框,此时单击“快速安装”按钮,即开始安装补丁。

2.如果用户没有选择,则在到达设置的时间后如图4), WSUS客户端程序会自动在后台安装补丁。这时,如果打开任务管理器,在“进程”对话框中会发现一个svchost.exe进程占用了大量的CPU资源,并且占用了大量内存,这个进程会完成补丁的自动安装工作。另外,还可以在“进程”中看到安装的补丁。

当安装完成后,如果安装的补丁需要重新启动计算机,如果把WSUS客户端“对于有己登录用户的计算机,计划的自动更新安装不执行重新启动”这一项设置为“禁用”或“未配置”,则会弹出5分钟倒计时窗口,如果在指定时间内,没有人取消该操作,计算机将会重新启动。如果配置为“己启用”,则会弹出“更新完成,是否需要重新启动计算机”的提示。如果安装的补丁不需要重新启动计算机,则不会有任何提示。

3.如果在指定的时间没有安装,则Windows XP会在关机的时候,安装该更新。

WSUS不能下载补丁

如果WSUS服务器不能下载补丁,在“事件查看器”中,我们可以看到如下错误:“内容文件下载失败。原因:此服务器不支持必要的 HTTP 协议。后台智能传送服务(BITS)要求服务器支持范围协议头。”解决方法如下:

首先,进入命令提示符。

如果使用WSUS 2.0自带的 MSDE 或 WMSDE 数据库并且默认安装,则执行如下代码:%programfiles%\Update Services\

tools\osql\osql.exe -S %Computer

name%\WSUS -E -b -n -Q "USE SUSDB update tbConfigurationC set BitsDownloadPriorityFore

ground=1"

如果使用WSUS 2.0和一个已经存在的 Microsoft SQL Server数据库,则执行如下代码:%programfiles%\Update Services\

tools\osql\osql.exe" -S %Computer

name% -E -b -n -Q "USE SUSDB update tbConfigurationC set BitsDownloadPriorityForeground=1"

如果使用 WSUS 3.0和 Windows Internal Database默认安装),则执行如下代码:%programfiles%\Update Services\

Setup\ExecuteSQL.exe -S %Computername%\MICROSOFT##SS

EE -d "SUSDB" -Q "update tb

ConfigurationC set BitsDownload

PriorityForeground=1"

如果使用WSUS 3.0和一个存在的 SQL Server数据库安装,则执行如下代码:%programfiles%\Update Services\Setup\Execute

SQL.exe"-S %Computername% -d "SUSDB" -Q "update tb

ConfigurationC set BitsDownload

PriorityForeground=1"

然后再重新启动Update Services服务。

出现0x80070002错误

一些工作站在更新到XP SP3时可能出现 “一个问题阻止Windows正确检查此机器的许可证。错误代码0x80070002”的提示。如果注销计算机,再次进入后仍然提示此错误,则表示该更新不能使用。

这是由于该计算机安装的是破解版本的Windows XP操作系统。一般情况下,使用WSUS服务器为网络中的工作站提供升级补丁时,不会检测操作系统是否是正版,但在以下的情况下例外:安装Windows Media Player 11时、安装IE 7.0时后来取消了这个限制)和升级到XP SP3时。

出现这个问题后,虽然一些资料说,恢复C:\windows\system32下的oembios.bin文件即可。但实际上,要解决这个问题在大多数情况下需要重新安装操作系统。在重新安装的时候,建议使用Windows XP的VL版本,而不要使用破解版或精简版。

了解这些典型问题可以为你管理WSUS服务器带来方便。当然,网络是发展的,WSUS也并不是一成不变的,而且每个单位的实际情况不同,每个管理员的习惯也不一样。因此WSUS服务器出现的问题也可能不同。但我们只要沉着、冷静,在出现问题后仔细分析、判断,还是可以很快地解决的。

分享到:QQ空间新浪微博腾讯微博微信百度贴吧QQ好友复制网址打印

您可能想查找下面的文章:

  • WSUS服务器是什么
  • WSUS服务器的详细配置和部署
  • WSUS服务器的工作原理
  • WSUS服务器和更新管理流程
  • WSUS服务器概要介绍
  • WSUS服务器部署场景
  • WSUS服务器的管理模式
  • 补丁服务器常见的五种故障
  • 选择WSUS服务器使用的数据库
  • 微软WSUS 3.0安装配置详解(1)

相关文章

  • WSUS服务器的硬件需求
  • HP ProLiant DL120 G7打造性价比第一
  • 从虚拟化到云端数据中心(1)
  • 在SAN环境下部署虚拟服务器
  • 缓存服务器在Linux下的应用
  • 盘点中小企业使用云服务的六大理由
  • 不受制于厂商 大型机迁移概念及优势(1)
  • 如何借助LinOTP为Apache2保驾护航?(1)
  • 向下兼容 带你了解IBM新eX5架构(1)
  • NAS与文件服务器有什么联系?(1)

文章分类

  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx

最近更新的内容

    • 将DHCP服务器部署进行到底(1)
    • 如何解决开源Web设备中的安全故障
    • N+X等于几?
    • 绝对重口味 机房管理员“死亡笔记”(漫画)(1)
    • 实战:如何部署RemoteApp服务器(多图)(1)
    • 2011年3月中国服务器市场分析报告(1)
    • 如何解决w3wp占用CPU和内存问题(1)
    • 服务器升级硬件篇——存储(1)
    • 灾难恢复计划 数据中心不可忽视(1)
    • 解析各厂商实施服务器虚拟化所需成本

关于我们 - 联系我们 - 免责声明 - 网站地图

©2020-2025 All Rights Reserved. linkedu.com 版权所有