• linkedu视频
  • 平面设计
  • 电脑入门
  • 操作系统
  • 办公应用
  • 电脑硬件
  • 动画设计
  • 3D设计
  • 网页设计
  • CAD设计
  • 影音处理
  • 数据库
  • 程序设计
  • 认证考试
  • 信息管理
  • 信息安全
菜单
linkedu.com
导航菜单
  • 网页制作
  • 数据库
  • 程序设计
  • 操作系统
  • CMS教程
  • 游戏攻略
  • 脚本语言
  • 平面设计
  • 软件教程
  • 网络安全
  • 电脑知识
  • 服务器
  • 视频教程
  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx
您的位置:首页 > 服务器 >虚拟化 > CloudStack 创建主存储失败解决方案

CloudStack 创建主存储失败解决方案

作者: 字体:[增加 减小] 来源:互联网

本文主要包含CloudStack,创建主存储失败,CloudStack,创建主存储失败如何解决,CloudStack,主存储失败等服务器相关知识,希望可以进行参考

CloudStack创建主存储失败(SR已经被使用),删除SR后成功

           由于最近工程需要用到这个东西,于是乎,在网上找了些资料解决了CloudStack创建主存储失败(SR已经被使用),删除SR后成功,的问题,这里就记录下:

创建主存储时,可能会发生创建存储pool失败(SR已经被使用,重装CloudStack management后可能发生此问题),错误提示如下:

 Can not create storage pool through host 1 due to Catch Exception 
com.cloud.utils.exception.CloudRuntimeException, create StoragePool failed due to
 com.cloud.utils.exception.CloudRuntimeException:
 There is a SR using the same configuration server:10.217.5.192, serverpath:/home/export/primary for 
pool c9c0319f-33f0-3494-9ada-4d7a2f1dafd4on host:09b3515e-447e-406f-869a-239386d5fe90 
on host:09b3515e-447e-406f-869a-239386d5fe90 pool: 10.217.5.192/home/export/primary

失败原因通常是因为已经在host里创建过CS,到重装之前UUID为09b3515e-447e-406f-869a-239386d5fe90的host里删除c9c0319f-33f0-3494-9ada-4d7a2f1dafd4的SR,然后再创建主存储就没有问题了。

在XenServer里删除SR方法如下

1. 首先得到SR的UUID

xe sr-list name-label=c9c0319f-33f0-3494-9ada-4d7a2f1dafd4

2. 使用UUID获得物理块设备列表,可能有多个。

xe pbd-list sr-uuid= SR-uuid-from-step-1

3. 卸载物理块设备,如有多个,需要执行多次

xe pbd-unplug uuid=PBD-uuid-from-step-2

4. 销毁物理块设备,如有多个,需要执行多次

xe pbd-destroy uuid=PBD-uuid-from-step-2

5. 删除SR

xe sr-forget uuid=SR-uuid-from-step-1

另外,此问题可以在重新安装前,查询出storage_pool里的SR(select uuid from storage_pool;),然后到相应host(通常是SSVM所在的host里)里删除相关SR。

感谢阅读,希望能帮助到大家,谢谢大家对本站的支持!

您可能感兴趣的文章:

  • CloudStack 安装及使用过程中常见问题汇总
  • CloudStack 环境如何重新部署详解
  • CentOS6.6安装CloudStack4.8
  • cloudstack下libvirtd服务无响应问题
  • CloudStack SSVM启动条件源码阅读与问题解决方法
分享到:QQ空间新浪微博腾讯微博微信百度贴吧QQ好友复制网址打印

您可能想查找下面的文章:

  • CloudStack SSVM启动条件源码阅读与问题解决方法
  • CloudStack 安装及使用过程中常见问题汇总
  • CloudStack 环境如何重新部署详解
  • CloudStack 创建主存储失败解决方案

相关文章

  • 修改Docker默认镜像和容器的存储位置的方法
  • VMVare虚拟机网络配置步骤
  • Docker下mysql设置字符集的方法
  • XenServer 5.6环境下安装Windows Server 2012详细过程(图文)
  • Docke实例之搭建gitlab的方法
  • Docker容器中Mysql数据的导入/导出详解
  • 服务器虚拟资源分配原则如何制定?
  • Docker-Compose的使用示例详解
  • 轻松安装docker并运行docker swarm模式
  • 详解使用Hyper-V安装Ubuntu Server 16.10

文章分类

  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx

最近更新的内容

    • Windows7 64位 旗舰版下VirtualBox 4.3.12安装教程
    • 详解在 KVM 上安装 Win7 虚拟机
    • VMware网络连接模式(桥接、NAT以及仅主机模式的详细介绍和区别)
    • Docker教程之Ubuntu 安装 Docker详细介绍
    • Docker镜像制作详解介绍
    • Docker基础知识之Linux namespace图文详解
    • 技术解析:服务器虚拟化技术及优势(1)
    • Docker 基础之Dockerfile命令详解
    • Centos7下搭建KVM虚拟机的方法
    • 详解利用Dockerfile构建mysql镜像并实现数据的初始化及权限设置

关于我们 - 联系我们 - 免责声明 - 网站地图

©2020-2025 All Rights Reserved. linkedu.com 版权所有