• linkedu视频
  • 平面设计
  • 电脑入门
  • 操作系统
  • 办公应用
  • 电脑硬件
  • 动画设计
  • 3D设计
  • 网页设计
  • CAD设计
  • 影音处理
  • 数据库
  • 程序设计
  • 认证考试
  • 信息管理
  • 信息安全
菜单
linkedu.com
导航菜单
  • 网页制作
  • 数据库
  • 程序设计
  • 操作系统
  • CMS教程
  • 游戏攻略
  • 脚本语言
  • 平面设计
  • 软件教程
  • 网络安全
  • 电脑知识
  • 服务器
  • 视频教程
  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx
您的位置:首页 > 服务器 >虚拟化 > CloudStack 安装及使用过程中常见问题汇总

CloudStack 安装及使用过程中常见问题汇总

作者: 字体:[增加 减小] 来源:互联网

本文主要包含CloudStack,常见问题,CloudStack,常见问题总结,CloudStack,常见问题解决方案等服务器相关知识,希望可以进行参考

CloudStack 安装及使用过程中常见问题汇总

            在做工程项目中对CloudStack 安装及使用过程中常见的几个问题及如何解决做一个总结。

   1、Windows XP虚拟机内部重启不能正确获取IP,windows xp iso建立VM,重启VM无法正确获取IP地址,原因是没有加入域,可以通过修改注册表来解决此问题。设置组策略 计算机配置--管理模板--网络--DNS客户端里的DNS后缀搜索列表,设置为已启动,后缀值为cs1group.internal

       Windows 7的虚拟机,还需要设置组策略计算机配置--管理模板--网络--DNS客户端里的连接特定的DNS后缀,设置为已启动,后缀值为cs1group.internal

       2、不能下载模板,有几个问题需要确认:

       如果是系统模板,可能是网络不通。在CloudStack Management上wget一下相应的url,看是否能够下载,不能下载的话,先解决网络问题。

       如果是ISO或者以前的自制模板,则可能是server不对。需要确认:

       1),看看浏览器是否能够下载模板的URL。如果不能下载,请解决下载服务器的问题(启动httpd,设置iso配置),然后重启 SSVM(secondary storage VM)。
       2),修改secstorage.allowed.internal.sites(10.127.0.1/24,根据实际环境配置), 然后重启 SSVM;

       3、如果primary和secondary放在系统硬盘,容易导致系统盘空间不足而影响系统运行。可以通过如下方法修改放到其他硬盘。

       1)、service cloud-management stop

       2)、修改primary文件夹存放硬盘:先mv primary下所有文件到另外的目录,然后mount newdisk primary,然后再将文件mv到primary。这样就不会占用系统盘的硬盘。(secondary目录同)

       3)、service cloud-management start

       4、给卷附加磁盘时出现错误

       Failed to attach volume: Disk3 to VM: cd0e453b-af53-4904-b7d7-54091ee83791; You attempted an operation that requires PV drivers to be installed on the VM. Please install them by inserting xen-pv-drv.iso

       关闭VM之后重新附加磁盘,则没有问题.

       5、增加不了host,到csmt主机上ssh host,如果不行,解决相关问题后能够ssh后就可以增加host了
SSH连接错误,
如下:

@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
@  WARNING: REMOTE HOST IDENTIFICATION HAS CHANGED!   @
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
IT IS POSSIBLE THAT SOMEONE IS DOING SOMETHING NASTY!
Someone could be eavesdropping on you right now (man-in-the-middle attack)!
It is also possible that the RSA host key has just been changed.
The fingerprint for the RSA key sent by the remote host is
d0:5b:18:96:7c:ee:af:af:a2:6b:a2:02:0a:8c:cd:40.
Please contact your system administrator.
Add correct host key in /home/opzoon/.ssh/known_hosts to get rid of this message.
Offending key in /home/opzoon/.ssh/known_hosts:2
RSA host key for 10.127.0.130 has changed and you have requested strict checking.
Host key verification failed.

       原因:密钥发生错误

       解决:vi ~/.ssh/known_hosts,删除host对应的密钥

感谢阅读,希望能帮助到大家,谢谢大家对本站的支持!

您可能感兴趣的文章:

  • CloudStack 环境如何重新部署详解
  • CloudStack 创建主存储失败解决方案
  • CentOS6.6安装CloudStack4.8
  • cloudstack下libvirtd服务无响应问题
  • CloudStack SSVM启动条件源码阅读与问题解决方法
分享到:QQ空间新浪微博腾讯微博微信百度贴吧QQ好友复制网址打印

您可能想查找下面的文章:

  • CloudStack SSVM启动条件源码阅读与问题解决方法
  • CloudStack 安装及使用过程中常见问题汇总
  • CloudStack 环境如何重新部署详解
  • CloudStack 创建主存储失败解决方案

相关文章

  • Docker使用Link在容器之间建立连接
  • 详解在Docker容器中运行Spring Boot应用
  • 详解如何干净的卸载docker的方法
  • VMware Workstation/Fusion 中安装 Fedora 23/24 及其他 Linux 系统时使用 Open VM Tools 代替 VMware Tools 增强工具的方法
  • VMware Tools(ubuntu系统)安装图文教程
  • 详解docker容器间通信的一种方法
  • 服务器虚拟化的三大优势
  • 详解Virtual Box配置CentOS7网络(图文教程)
  • 详解在docker中制作自己的JDK+tomcat镜像
  • VirtualBox实现虚拟机中共享本地目录的方法

文章分类

  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx

最近更新的内容

    • VMware EXSI为虚拟机centos安装VMware Tools
    • VirtualBox虚拟机使用技巧
    • Docker 简单部署 ElasticSearch的实现方法
    • Docker push镜像失败解决方法
    • VMware Workstation安装配置方法图文教程
    • 虚拟化能够满足将来的存储系统的需求
    • docker快速入门教程
    • Docker容器中运行flume及启动不输出运行日志问题
    • 梦工厂数据中心:云和虚拟化不到20%
    • CentOS7.2服务器上搭建Docker私有镜像仓库操作示例

关于我们 - 联系我们 - 免责声明 - 网站地图

©2020-2025 All Rights Reserved. linkedu.com 版权所有