• linkedu视频
  • 平面设计
  • 电脑入门
  • 操作系统
  • 办公应用
  • 电脑硬件
  • 动画设计
  • 3D设计
  • 网页设计
  • CAD设计
  • 影音处理
  • 数据库
  • 程序设计
  • 认证考试
  • 信息管理
  • 信息安全
菜单
linkedu.com
导航菜单
  • 网页制作
  • 数据库
  • 程序设计
  • 操作系统
  • CMS教程
  • 游戏攻略
  • 脚本语言
  • 平面设计
  • 软件教程
  • 网络安全
  • 电脑知识
  • 服务器
  • 视频教程
  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx
您的位置:首页 > 服务器 >windows > Hadoop运维记录系列(十)

Hadoop运维记录系列(十)

作者:网友 字体:[增加 减小] 来源:互联网

本文主要包含hadoop运维,hadoop运维工程师,hadoop运维面试题,hadoop数据清洗,hadoop等服务器相关知识,网友希望可以进行参考

昨天同事遇到一个hadoop故障,找了半天没看出问题,问到我这里,花了一会解决了一下,估计这是我给暴风的集群解决的最后的故障了,以后就不定给谁解决问题去了。


只截下来了Namenode的报错Log,Datanode的刷屏刷过去了,不过都差不多。

2013-09-03 18:11:44,021 WARN org.apache.hadoop.hdfs.StateChange: BLOCK* NameSystem.blockReceived: blk_8094241928859719036_2147969 is received from dead or unregistered node 192.168.1.99:50010
2013-09-03 18:11:44,022 ERROR org.apache.hadoop.security.UserGroupInformation: PriviledgedActionException as:hdfs cause:java.io.IOException: Got blockReceived message from unregistered or dead node blk_8094241928859719036_2147969
2013-09-03 18:11:44,022 INFO org.apache.hadoop.ipc.Server: IPC Server handler 2 on 9000, call blockReceived(DatanodeRegistration(192.168.1.99:50010, storageID=DS-1925877777-192.168.1.99-50010-1372745739682, infoPort=50075, ipcPort=50020), [Lorg.apache.hadoop.hdfs.protocol.Block;@4ec371c, [Ljava.lang.String;@301611ca) from 192.168.1.99:18853: error: java.io.IOException: Got blockReceived message from unregistered or dead node blk_8094241928859719036_2147969
java.io.IOException: Got blockReceived message from unregistered or dead node blk_8094241928859719036_2147969
        at org.apache.hadoop.hdfs.server.namenode.FSNamesystem.blockReceived(FSNamesystem.java:4188)
        at org.apache.hadoop.hdfs.server.namenode.NameNode.blockReceived(NameNode.java:1069)
        at sun.reflect.GeneratedMethodAccessor13.invoke(Unknown Source)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
        at java.lang.reflect.Method.invoke(Unknown Source)
        at org.apache.hadoop.ipc.RPC$Server.call(RPC.java:578)
        at org.apache.hadoop.ipc.Server$Handler$1.run(Server.java:1393)
        at org.apache.hadoop.ipc.Server$Handler$1.run(Server.java:1389)
        at java.security.AccessController.doPrivileged(Native Method)
        at javax.security.auth.Subject.doAs(Unknown Source)
        at org.apache.hadoop.security.UserGroupInformation.doAs(UserGroupInformation.java:1149)
        at org.apache.hadoop.ipc.Server$Handler.run(Server.java:1387)



看上去是个IPC的错误,从下往上看,都是报权限错误,然后无法注册Datanode,还有从未注册或死亡的Datanode上报了一个块已被接收的错误。同事就晕了,已经死亡的node怎么还上报啊。


然后重启datanode时间不长,就又挂掉了。


登录到datanode,先看了一下dfs的数据文件夹的权限,正确无误。然后看了一下df -h,发现/var文件夹满了,OPS很缺,只给分了20G的/var。结果Hadoop的log写不进去了,自然就挂了。删掉/var/log/hadoop/hdfs里面的历史日志,datanode启动正常。以后的解决办法只有两个,要么设置定时脚本每天删历史日志,要么就把/var/log/hadoop/hdfs文件夹软链到一个比较大的硬盘上。


马上要离开暴风影音了,心中有诸多槽点,以后慢慢吐了。

本文出自 “实践检验真理” 博客,谢绝转载!

分享到:QQ空间新浪微博腾讯微博微信百度贴吧QQ好友复制网址打印

您可能想查找下面的文章:

  • Hadoop运维记录系列(十)

相关文章

  • svn全自动化更新
  • Windows Server 2008 修改密码策略的方法
  • Exchange Server 2010 邮箱数据库的恢复(移植)
  • LUN和Volume
  • Windows中配置Python运行环境,只有700KB
  • livekd 调试 Windows 内核出错的解决方法
  • Windows 2003中IIS不支持FLV视频文件
  • linux系统下挂在大于16TB磁盘
  • iis服务器设置网站默认首页方法
  • history高级应用7

文章分类

  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx

最近更新的内容

    • Web服务器和应用程序服务器的区别
    • Windows7下系统环境变量的配置图解
    • win2003/2008下建立隐藏系统用户与查看及删除方法
    • LAMP的web站点搭建(一)
    • iis和apache 80端口冲突无法正常启动解决方法
    • 真正彻底卸载ie8的某些加载项
    • Linux快捷键技巧和系统变量5
    • windows2003服务器配置Asp.Net环境图解
    • VMWare文件未能锁定(Failed to lock the file)的解决方法
    • 也谈学生机房PC桌面虚拟化

关于我们 - 联系我们 - 免责声明 - 网站地图

©2020-2025 All Rights Reserved. linkedu.com 版权所有