• linkedu视频
  • 平面设计
  • 电脑入门
  • 操作系统
  • 办公应用
  • 电脑硬件
  • 动画设计
  • 3D设计
  • 网页设计
  • CAD设计
  • 影音处理
  • 数据库
  • 程序设计
  • 认证考试
  • 信息管理
  • 信息安全
菜单
linkedu.com
导航菜单
  • 网页制作
  • 数据库
  • 程序设计
  • 操作系统
  • CMS教程
  • 游戏攻略
  • 脚本语言
  • 平面设计
  • 软件教程
  • 网络安全
  • 电脑知识
  • 服务器
  • 视频教程
  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx
您的位置:首页 > 服务器 >windows > iis和apache 80端口冲突无法正常启动解决方法

iis和apache 80端口冲突无法正常启动解决方法

作者:网友 字体:[增加 减小] 来源:互联网

本文主要包含iis和apache端口冲突,iis和apache共存,iis和apache哪个好,apache iis,关闭iis/nginx/apache等服务器相关知识,网友希望可以进行参考

本文章介绍一下关于apache不能启动的解决办法,apache端口占用一一般是我们常用的IIS默认起用的是80端口, 迅雷和SKYPE也会占用80端口所以从这些家伙下手了。

IIS默认起用的是80端口, 迅雷和SKYPE也会占用80端口。
如果不知道80端口被那个软件占用,如果您安装了360安全卫士,你可以用360安全卫士查找80端口被谁占用。

查看80端口是否被占用
1)开始->运行 cmd 进入命令提示行


2)输入:netstat -o -an > C:portInfo.txt


3)然后进入C盘,查看protInfo.txt文件,找到占用80端口的程序pid,记下pid。


4)打开任务管理器,点击“查看”/选择列,勾选“PID(进程标识 符)”,然后单击“进程”标签,找到80端口对应的pid,就可以看到是那个程序占用的了,更改这个程序的port,或结束该进程即可。

今天我的情况很明显是开启了IIS,我用的是2003 server。 由于apache默认的端口和IIS的一样,所以就需要更改了

查看80端口的方法在本站搜

下面就进入更改apache端口修改
进入apache安装目录,找到conf配置文件夹,点击进入后找到httpd.conf. 你选择用记事本的方式打开后ctrl+f查找

listen直到找到 listen 80 ,然后把80改成你想要更改的端口,注意千万不要改你电脑上已用过的端口就OK了,更改后保存。

之后你浏览apache服务器中的网页就要在你的IP下加入http://127.0.0.1:81(比如你把80改成了81).
如果你不想更改apache服务器的端口,那就修改其它程序的端口就行啦。这里不再说其他程序的端口号的修改方法了,修改端口的文章,在我的笔记里也可以找到,祝你好运。


好了我这里在本地用的是81端口了,但是在服务器上不太可能用81端口了,所以我们还是用80解决方法就是把其它占用的端口的改一下。

随便说一下iis和apache共用80的方法apache下的网站使用80端口,IIS使用8081端口,通过apache代理转发为80端口。

IIS6,多IP下共存,IIS为192.168.0.1,apache为192.168.0.2 原文地址
到2003的CD下的 support/tools/Support.cab。解压出httpcfg.exe文件,COPY到windows/system32/目录下,用法自己看帮助

命令行

绑定到某IP: httpcfg set iplisten -i 192.168.0.1
即命令使用IIS的只监听指定的IP及端口
查看绑定: httpcfg query iplisten
删除绑定: httpcfg delete iplisten -i 192.168.0.1

命令行
net stop Apache2
net stop iisadmin /y
net START Apache2
net START w3svc

保证iis下的ip设置为全局默认,Apache中httpconf设置listen 192.168.0.2:80,就应该可以两个服务同时运行,相互不冲突了。
IIS的访问地址为http://192.168.0.1,Apache访问地址为http://192.168.0.2

分享到:QQ空间新浪微博腾讯微博微信百度贴吧QQ好友复制网址打印

您可能想查找下面的文章:

  • iis和apache 80端口冲突无法正常启动解决方法
  • apache 和iis共用80端口多种解决办法

相关文章

  • Windows 2003服务器禁用错误报告
  • liunx服务使用(DNS服务器)
  • 集群 之 LVS + Keepalived
  • win2003/2008 IIS服务器.flv文件不能访问解决办法
  • discuz 常见报错
  • ssh全自动实现双机信任脚本
  • windows 2003服务器Gene6 FTP Server安装教程
  • apache/iis设置网站的默认首页方法
  • HTTP 500 内部服务器错误的解决
  • winscp在windows下批处理通过SSH端口上传文件

文章分类

  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx

最近更新的内容

    • QVOD资源服务器广告设置、网页插件显示位置及防盗链设置教程
    • windows计划任务实现mysql数据库自动备份批处理命令
    • 64位Windows系统配置IIS 7.0+PHP+Mysql图解
    • 让服务器apache/iis/nginx支持.apk/ipa文件下载
    • ansible简单使用
    • windows2003禁止关机时出现的关机理由
    • Apache 301转向实现方法介绍
    • 利用Flash media server 4.5配置流媒体服务器
    • oracle数据库使用nfs存储,启动报错提示无法锁定文件
    • Hyper-V Server2008 R2的热插拔技术

关于我们 - 联系我们 - 免责声明 - 网站地图

©2020-2025 All Rights Reserved. linkedu.com 版权所有