我们知道在iis7中设置上传文件大小我们只需要修改两个参数:maxRequestLength和maxAllowedContentLength即可了,下面来参考。
当上传一个超过30M的文件时,服务器会重定向至404.13页面,报错如下:
HTTP Error 404.13 - Not Found
The request filtering module is configured to deny a request that exceeds the request content length.
这是由于服务器限制了所能上传文件的最大值。其值在
configuration/system.webServer/security/requestFiltering/requestLimits@maxAllowedContentLength setting
in the applicationhost.config or web.config file. 中定义。
查看C:WindowsSystem32inetsrvconfig目录下的applicationhost.config,可以在
system.webServer/security/requestFiltering/中找到requestLimits设置项,若没有,则可以自行添加如下:(这
里maxAllowedContentLength的单位为bytes。)
| 代码如下 | 复制代码 |
|
<system.webServer> |
|
也可以使用命令行模式修改applicationhost.config为:
| 代码如下 | 复制代码 |
|
%windir%system32inetsrvappcmd set config -section:requestFiltering - requestLimits.maxAllowedContentLength:40000000 |
|
经过这个设置后,服务器对上传文件的大小限制将变为40000000bytes了。当然,这个设置是服务器级别的,如果你想
在某个站点或者某个应用上限制大小,也可以通过以相同方式进行设置,只不过这次设置的是站点内的Web.config。
但是你要进行此项修改,要确保applicationhost.config中对该项修改的权限已经放开。可通过如下设置进行更改:
| 代码如下 | 复制代码 |
|
modify the overrideModeDefault from "Deny" to "Allow" like so: <sectionGroup name="system.webServer"> |
|
确认修改过applicationhost.config中上述设置以后,再进行如下设置。
找到应用的Web.config,按上述进行修改:
| 代码如下 | 复制代码 |
|
<system.webServer> |
|
或者你也可以通过命令行的形式:
| 代码如下 | 复制代码 |
|
%windir%system32inetsrvappcmd set config "Default Web Site/<your app>" -section:requestFiltering - requestLimits.maxAllowedContentLength:40000000 |
|
这样,你就能针对某个站点的某个应用进行设置。
但是开发人员是在Web.Config中进行了如下设置:
| 代码如下 | 复制代码 |
|
<system.web> <httpRuntime maxRequestLength="40960" appRequestQueueLimit="100" useFullyQualifiedRedirectUrl="true" executionTimeout="120" /> </system.web> |
|
这里的maxRequestLength据MSDN介绍:Gets or sets the maximum request size. The maximum request size in
kilobytes. The default size is 4096 KB (4 MB).
The MaxRequestLength property specifies the limit for the buffering threshold of the input stream. For
example, this limit can be used to prevent denial of service attacks(拒绝服务攻击) that are caused by
users who post large files to the server.
The value assigned to this property should be greater or equal to value assigned to the
RequestLengthDiskThreshold property.
但是开发人员的这个设置好像是不起作用的。他们在这里,限制最大请求长度为40MB,超时为120s。
下次再看一下具体这个设置是用来做什么的。
-------------------------
现在明白了。这个是用来设置单个请求的最大长度。比如EmailTicket中若设置maxRequestLength为30M,
maxAllowedContentLength为40M,
然后在Reply Email时,选择了一个35M的附件,在点击Save as Draft的时候,这个请求的长度大概会有35M,这个已
经超过了maxRequestLength。此时请求就会报错了,结果是黄页:
Server Error in '/emailticket' Application.
--------------------------------------------------------------------------------
Maximum request length exceeded.
Description: An unhandled exception occurred during the execution of the current web request. Please
review the stack trace for more information about the error and where it originated in the code.
Exception Details: System.Web.HttpException: Maximum request length exceeded.
另一种解决办法
在Win2008里,打开IIS7,找到需要修改限制的网站,双击右侧“管理”下面的“配置编辑器”,在上面的“节”处,
找到“system.webServer-->webdav-->asp”,这时,“节”处显示“system.webServer/asp”。
在下面,找到“Limits”,点击左边的加号,改变“bufferingLimit”和“maxRequestAntityAllowed”的值为
“2000000000”(2G,最大值就是2G),改好后回车,点击右边栏顶部“操作”下面的“

