• linkedu视频
  • 平面设计
  • 电脑入门
  • 操作系统
  • 办公应用
  • 电脑硬件
  • 动画设计
  • 3D设计
  • 网页设计
  • CAD设计
  • 影音处理
  • 数据库
  • 程序设计
  • 认证考试
  • 信息管理
  • 信息安全
菜单
linkedu.com
导航菜单
  • 网页制作
  • 数据库
  • 程序设计
  • 操作系统
  • CMS教程
  • 游戏攻略
  • 脚本语言
  • 平面设计
  • 软件教程
  • 网络安全
  • 电脑知识
  • 服务器
  • 视频教程
  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx
您的位置:首页 > 服务器 >windows > IIS提示Service Unavailable错误解决办法

IIS提示Service Unavailable错误解决办法

作者:网友 字体:[增加 减小] 来源:互联网

本文主要包含service unavailable,unavailable,unavailable什么意思,unavailable 翻译,cas is unavailable等服务器相关知识,网友希望可以进行参考

使用iis服务器环境的同学可以会常常发现自己的网站出现Service Unavailable提示,出现Service Unavailable这种提示的原因有很多,下面我来总结常见引起此问题的解决办法。

问题一

. 现象描述

1)访问网站出现“Service Unavailable”错误

2)查看IIS中的应用程序池出现被自动禁用情况

3)计算机管理 - 系统工具 - 事件查看器 - 应用程序:出现错误(来源:.NET Runtime 2.0,类型:错误,事件ID

:1000,描述:Faulting application w3wp.exe, version 6.0.3790.3959, stamp 45d6968e, faulting module

kernel32.dll, version 5.2.3790.4480, stamp 49c51ee2, debug? 0, fault address 0x0000bef7.)

4)计算机管理 - 系统工具 - 事件查看器 - 系统:出现错误(来源:W3SVC,类型:错误,事件ID:1002,描述:应

用程序池 'ASP.NET V2.0' 被自动禁用,原因是为此应用程序池提供服务的进程中出现一系列错误)

2. 解决方案

给用户NETWORK SERVICE加上访问IIS服务的权限

开始 - 控制面板 - 管理工具 - 组件服务 - 计算机 - 我的电脑 - DCOM - IIS ADMIN SERVICE - 属性 - 安全 - 启

动和激活权限 - 自定义 - 添加帐号“NETWORK SERVICE”,给该帐号赋予“本地启动”和“本地激活”的权限 - 在

cmd下输入“IISRESET”命令(不含引号)重新启动IIS


问题二


如果你使用的是iis+php环境我们碰到Service Unavailable提示可参考下面解决办法

PHP配置上就提示在页面上提示 Service Unavailable,自然,ASP也不能正常运行了,后来在IIS中检查PHP的配置,

发现php5isapi.dll没有被ISAPI筛选器正常加载,是红色的向下的箭头,正常情况应该是绿色向上的箭头,表示加载

成功!于是将其删除后重新启动IIS,结果页面显示正常!于是重新检查PHP的配置,也没有发现什么异常现象,最后

想到了有可能是权限问题,于是检查PHP安装文件夹的权限,发现没有EVERYONE权限,不知什么时候把EVERYONE权限给

删除了,于是从新给EVERYONE加上了只读权限(只读权限就足够了),重启IIS后,一切正常!


问题三

1.首先是打开IIS管理器.检查应用程序池,果然"DefaultAppPool"出错了.而且不是平常的停止的图标.

2.试着重启"DefaultAppPool"应用程序池,但是没过多久程序池又出错了.

3.到了查看事件日志的时候了.发现了以下这类的日志

事件类型: 警告
事件来源: W3SVC
事件种类: 无
事件 ID: 1009
日期:   2008-6-24
事件:   16:12:33
用户:   N/A
计算机: MAIL
描述:
为应用程序池 'DefaultAppPool' 提供服务的进程意外终止。进程 ID 是 '3160'。进程退出代码是 '0xffffffff'。

有关更多信息,请参阅在 http://go.microsoft.com/fwlink/events.asp 的帮助和支持中心。

4.会不会是默认的程序池出问题了?于是,尝试新建一个新的程序池.将默认网站的程序池改成新的.但是问题依旧

.出现相似的日志.

事件类型: 错误
事件来源: W3SVC
事件种类: 无
事件 ID: 1002
日期:   2008-6-25
事件:   14:17:04
用户:   N/A
计算机: MAIL
描述:
应用程序池 'AppPool #1' 被自动禁用,原因是为此应用程序池提供服务的进程中出现一系列错误。

有关更多信息,请参阅在 http://go.microsoft.com/fwlink/events.asp 的帮助和支持中心。


5.再查找事件日志另一个日志引起了我的注意.如下:

事件类型: 错误
事件来源: DCOM
事件种类: 无
事件 ID: 10016
日期:   2008-6-24
事件:   16:12:33
用户:   NT AUTHORITYNETWORK SERVICE
计算机: MAIL
描述:
应用程序-特定 权限设置未将 COM 服务器应用程序(CLSID 为
{A9E69610-B80D-11D0-B9B9-00A0C922E750}
)的 本地 激活 权限授予用户 NT AUTHORITYNETWORK SERVICE SID (S-1-5-20)。可以使用组件服务管理工具修改此

安全权限。

有关更多信息,请参阅在 http://go.microsoft.com/fwlink/events.asp 的帮助和支持中心。

6.有点戏了.看看CLSID 为 {A9E69610-B80D-11D0-B9B9-00A0C922E750} 是什么服务先.最后在下面的注册表项中找

到它:

 代码如下 复制代码

HKEY_CLASSES_ROOTAppID{A9E69610-B80D-11D0-B9B9-00A0C922E750}


C.并给予本地启动和激活权限,保存退出.

到此问题解决.

分享到:QQ空间新浪微博腾讯微博微信百度贴吧QQ好友复制网址打印

您可能想查找下面的文章:

  • 网站出现Service Unavailable报错的处理方法
  • IIS应用程序池自动停止/关闭/假死网提示 Service Unavailable解决办法
  • IIS提示Service Unavailable错误解决办法
  • IIS站点出现Service Unavailable 的解决办法
  • 网站出现service unavailable的解决方法

相关文章

  • zabbix实现linux流量变化率监控
  • VMware安装或卸载提示the msi failed的解决方法
  • windows storage server 2008创建iscsi磁盘
  • Windows下安装MariaDB数据库小结
  • WindowsPE与WindowsRE有什么区别
  • IBM AIX 从零开始2
  • 在CentOS 5上配置NFS服务器
  • 云平台与云主机选择的经验和建议
  • iis 您未被授权查看该页
  • 阐述Windows系统的超级帐户SYSTEM

文章分类

  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx

最近更新的内容

    • perl编写ping脚本
    • 电脑开机为什么要按F1才能进入系统,如何解决?
    • Windows Server 2008服务器系统数据安全
    • Windows Server 2008 R2 分布式扫描管理
    • windows计划任务实现mysql数据库自动备份批处理命令
    • php上传文件到服务器
    • windows storage server 2008创建iscsi磁盘
    • 有声音但任务栏没有音量图标的解决方法
    • win2008用注册表实现右键取得管理员权限
    • 桌面虚拟化IOPS计算方法

关于我们 - 联系我们 - 免责声明 - 网站地图

©2020-2025 All Rights Reserved. linkedu.com 版权所有