• linkedu视频
  • 平面设计
  • 电脑入门
  • 操作系统
  • 办公应用
  • 电脑硬件
  • 动画设计
  • 3D设计
  • 网页设计
  • CAD设计
  • 影音处理
  • 数据库
  • 程序设计
  • 认证考试
  • 信息管理
  • 信息安全
菜单
linkedu.com
导航菜单
  • 网页制作
  • 数据库
  • 程序设计
  • 操作系统
  • CMS教程
  • 游戏攻略
  • 脚本语言
  • 平面设计
  • 软件教程
  • 网络安全
  • 电脑知识
  • 服务器
  • 视频教程
  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx
您的位置:首页 > 服务器 >windows > GoDaddy Windows启用Gzip压缩配置方法

GoDaddy Windows启用Gzip压缩配置方法

作者:网友 字体:[增加 减小] 来源:互联网

本文主要包含启用gzip压缩,启用gzip,未启用gzip压缩,apache启用gzip压缩,启用服务器gzip等服务器相关知识,网友希望可以进行参考

GD主机是我们现在使用国外主机比较常用的一个IDC商了,下面我来给大家介绍GoDaddy Windows启用Gzip压缩配置方法,有需要了解的朋友可参考。

一、先检查你网站的根目录是否已经有web.config文件

1、 如果你的根目录没有web.config文件,那么就自己新建一个,内容如下:

 代码如下 复制代码

<configuration>
<system.webServer>
<urlCompression doStaticCompression=”true” doDynamicCompression=”true” />
</system.webServer>
</configuration>

 如果你的根目录已经有web.config文件,请在“”

的上一行加上

 代码如下 复制代码

<system.webServer>
<urlCompression doStaticCompression="true" doDynamicCompression="true" />
</system.webServer>

代码

 代码如下 复制代码

<?xml version="1.0" encoding="UTF-8"?>
<configuration>
<system.webServer>
 <defaultDocument>
     <!-- Set the default document -->
      <files>
        <remove value="index.php" />
        <add value="index.php" />
      </files>
    </defaultDocument>
        <httpErrors errorMode="Detailed"/>
    <rewrite>
        <rules>
            <rule name="wordpress" patternSyntax="Wildcard">
                <match url="*" />
                    <conditions>
                        <add input="{REQUEST_FILENAME}" matchType="IsFile" negate="true" />
                        <add input="{REQUEST_FILENAME}" matchType="IsDirectory" negate="true" />
                    </conditions>
                <action type="Rewrite" url="index.php" />
            </rule>
        </rules>
    </rewrite>
</system.webServer>
<system.webServer>
<urlCompression doStaticCompression="true" doDynamicCompression="true" />
</system.webServer>
</configuration>

分享到:QQ空间新浪微博腾讯微博微信百度贴吧QQ好友复制网址打印

您可能想查找下面的文章:

  • IIS中启用Gzip压缩传输网页方法
  • apache启用mod_deflate的GZIP压缩网页传输方法
  • GoDaddy Windows启用Gzip压缩配置方法
  • iis启用GZIP压缩Css javascript文件无效的原因及解决
  • IIS启用GZip失败之原因:临时目录权限没设好

相关文章

  • 基于Drbd+Corosync构建高可用Mysql服务器
  • apache如何绑定多个域名
  • DNS域名服务器
  • Windows 2003 中密钥无效解决方法
  • windows系统搭建SVN 管理环境
  • Windows Server 2008 R2安装Windows Phone SDK
  • vps配置Apache rewirte伪静态(支持.htaccess)
  • xampp修改mysql默认密码详解
  • Windows系统中IIS防盗链设置详细介绍
  • Zabbix 之snmp配置

文章分类

  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx

最近更新的内容

    • liunx服务使用(apche服务器 也就是web发布)
    • VM配置文件所在分区内存太小导致错误的解决方法
    • 从两方面分析 有效地减少电脑死机或蓝屏
    • iis备份(MetaBase.xml)重装系统后怎么恢复
    • 手动刷新断开连接的邮箱
    • 服务器日志Tencent Virtual Printer Driver 未知的问题
    • 电脑开机为什么要按F1才能进入系统,如何解决?
    • 如何设置视频质量
    • Windows 系统查看端口占用以及解决端口占用
    • linux下,查找命令的使用

关于我们 - 联系我们 - 免责声明 - 网站地图

©2020-2025 All Rights Reserved. linkedu.com 版权所有