• linkedu视频
  • 平面设计
  • 电脑入门
  • 操作系统
  • 办公应用
  • 电脑硬件
  • 动画设计
  • 3D设计
  • 网页设计
  • CAD设计
  • 影音处理
  • 数据库
  • 程序设计
  • 认证考试
  • 信息管理
  • 信息安全
菜单
linkedu.com
导航菜单
  • 网页制作
  • 数据库
  • 程序设计
  • 操作系统
  • CMS教程
  • 游戏攻略
  • 脚本语言
  • 平面设计
  • 软件教程
  • 网络安全
  • 电脑知识
  • 服务器
  • 视频教程
  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx
您的位置:首页 > 服务器 >windows > Apache启动时无法加载php5apache2_2.dll解决办法

Apache启动时无法加载php5apache2_2.dll解决办法

作者:网友 字体:[增加 减小] 来源:互联网

本文主要包含php5apache2 2.dll,php5apache2 4.dll,php5apache2.dll,php5apache2 4,php5apache2 2等服务器相关知识,网友希望可以进行参考

今天在windows 2003系统中配置了apache环境但是在运行是apache日志提示无法加载php5apache2_2.dll呀,这个问题觉得很奇怪了,后来发现是编译环境的问题哦,下面我来给大家介绍解决此问题步骤。


安装环境

在Windows 2003(32位)中安装wampserver之后无法启动。查看错误是无法加载php模块:

12 The Apache service named  reported the following error:
>>> httpd.exe: Syntax error on line 127 of E:/wamp/bin/apache/apache2.2.22/conf/httpd.conf: Cannot load E:/wamp/bin/php/php5.3.13/php5apache2_2.dll into server: xd3xc9xd3xdaxd3xa6xd3xc3xb3xccxd0xf2xc5xe4xd6xc3xb2xbbxd5xfdxc8xb7xa3xacx     .

看到这个错误,忽然就感觉不知所措,这个文件是存在的为啥无法加载呢?也装了vc2010的运行库了。

解决方案

1、加载php5apache2_2.dll路径错误或者你的php安装目录中没有php5apache2_2.dll该文件。

排错方案:打开apache的httpd.conf文件,找到:LoadModule php5_module "D:/Program Files (x86)/Web/PHP/php5apache2_2.dll",检查路径和拼写错误。

2、缺少vc++2008可在发行组件包,下载并安装。

32位:Microsoft 2008 C++ Runtime (x86)

64位:Microsoft 2008 C++ Runtime (x64)

如果你不知道该装哪个,那就两个都装吧。目前php.net的php二进制源码都是x86版本,从压缩包和安装文件的命名就可以看出,所以一般下载x86版本的c++2008运行时环境就行了。

3、你可能安装的是64位版本的apache,注意windows平台的php目前只能搭配win32版本的apache,所以不要安装win64版本的apache

4、安装apache需要VC10 SP1 vcredist_x86.exe,如果你遇到无法安装apache的情况,下载安装它。

我的问题

以前遇到过无法安装wampserver,那时候是直接安装的VC10的运行库,现在安装成功了无法启动,一开始是一直觉得是iis的问题,后来查看事件查看器的错误发现时无法加载,检查各个原因都没发现问题,这时候忽然想到了是不是因为没有安装vc2008的原因,下载安装后搞定。

总结,如果你是windows2003还是安装php5.2.18版本吧使用vc6版本的php,vc9版本的需要安装一个编辑器大家可到微软管方下载。

分享到:QQ空间新浪微博腾讯微博微信百度贴吧QQ好友复制网址打印

您可能想查找下面的文章:

  • Apache启动时无法加载php5apache2_2.dll解决办法

相关文章

  • EqualLogic控制器算法研究一:基本管理
  • 后棱镜门时代企业核心数据如何存储
  • keepalived架设简单高可用的nginx的web服务器 ----那些你不知道的秘密
  • Debian软Raid安装笔记
  • 页面提示HTTP错误401.3-未经授权错误解决办法
  • 让apache/iis环境支持shtml与shtml文件
  • LNMP一键安装
  • 桌面虚拟化IOPS计算方法
  • Windows中创建.htaccess文件方法介绍
  • windows服务器iis伪静态配置图解

文章分类

  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx

最近更新的内容

    • 利用shutdown命令实现远程关机的方法
    • ↑mysql主从复制实现SSL加密和半同步复制↑
    • linux运维故障定位汇总
    • Windows2003安装SQL2005的SP1补丁无法安装
    • Windows8系统自带Hyper-V虚拟机
    • IIS8中添加WCF支持几种方法总结
    • 选取存储设备构建数据容灾备份系统方法
    • windows同时安装apahce和iis教程
    • Linux文件目录结构2
    • liunx中的网络安全介绍了一些网络知识

关于我们 - 联系我们 - 免责声明 - 网站地图

©2020-2025 All Rights Reserved. linkedu.com 版权所有