• linkedu视频
  • 平面设计
  • 电脑入门
  • 操作系统
  • 办公应用
  • 电脑硬件
  • 动画设计
  • 3D设计
  • 网页设计
  • CAD设计
  • 影音处理
  • 数据库
  • 程序设计
  • 认证考试
  • 信息管理
  • 信息安全
菜单
linkedu.com
导航菜单
  • 网页制作
  • 数据库
  • 程序设计
  • 操作系统
  • CMS教程
  • 游戏攻略
  • 脚本语言
  • 平面设计
  • 软件教程
  • 网络安全
  • 电脑知识
  • 服务器
  • 视频教程
  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx
您的位置:首页 > 服务器 >Nginx > Ubuntu下Nginx/PHP/MYSQL开发环境的配置方法

Ubuntu下Nginx/PHP/MYSQL开发环境的配置方法

作者:网友 字体:[增加 减小] 来源:互联网

本文主要包含ubuntu 安装nginx php,ubuntu nginx php,ubuntu安装nginx,ubuntu启动nginx,ubuntu 卸载nginx等服务器相关知识,网友希望可以进行参考

最近将原来的程序都迁移到了Nginx下来了,用了Ubuntu也有一段时间大了,慢慢了习惯了下Linux的操作,在加上Linux下性能确实不错,就开始配置了。

配置了

Ubuntu 9.10  Nginx  0.7.62  PHP5.2.10  MYSQL 5.1.37

0.打开终端 切换到root

sudo -H -s


1.安装PHP5

apt-get install php-pear php5-cli php5-common php5-xcache php5-cgi php5-mysql php5-gd php5-dev php5-memcache

默认安装就行
2.安装mysql5

apt-get install mysql-server mysql-client libipc-sharedcache-perl mysql-doc-5.0 tinyca

安装过程中提示输入mysql密码并确认,设置完要记住密码
3.安装nginx 

apt-get install nginx

版本为0.7.62
4.安装php-fastcgi下载php-fastcgi,完成后执行解压并安装(这个在下载包中会提供)

tar -zxvf php-fastcgi.tar.gzcd /tmp/php-fastcgi/

cp init-fastcgi /etc/init.d/init-fastcgi

chmod 755 /etc/init.d/init-fastcgi

cp php-fastcgi /usr/bin/php-fastcgi

cp spawn-fcgi /usr/bin/spawn-fcgi

  • 共3页:
  • 上一页
  • 1
  • 2
  • 3
  • 下一页

分享到:QQ空间新浪微博腾讯微博微信百度贴吧QQ好友复制网址打印

您可能想查找下面的文章:

  • 指导:Ubuntu环境搭建nginx+php系统
  • Ubuntu下Nginx/PHP/MYSQL开发环境的配置方法

相关文章

  • Nginx 504 Gateway Time-out错误的解决方案
  • Nginx下设置虚拟主机的技巧一则
  • Debian 7 安装LNMP服务器命令详解
  • Nginx 502 Bad Gateway错误的原因分析与解决方法
  • Curl监控Nginx网站状态,如回应502信息即重启php-fpm
  • 使用Nginx给Google App Engine做负载均衡
  • nginx和apche如何自定义404的页面
  • 更换apache到nginx的操作过程全记录
  • nginx location 指令匹配顺序
  • nginx支持.htaccess文件实现rewrite伪静态

文章分类

  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx

最近更新的内容

    • nginx支持.htaccess文件实现rewrite伪静态
    • Nginx提示:413 Request Entity Too Large 的解决方法
    • nginx下404错误页面的配置方法
    • nginx1.1.0无缝升级升级到1.1.1教程
    • Nginx下WordPress后台wp-admin不自动加斜杠的问题
    • 更换apache到nginx的操作过程全记录
    • Ubuntu下Nginx/PHP/MYSQL开发环境的配置方法
    • nginx和apche如何自定义404的页面
    • Nginx 502 Bad Gateway错误的原因分析与解决方法
    • nginx 设置网站目录访问验证方法

关于我们 - 联系我们 - 免责声明 - 网站地图

©2020-2025 All Rights Reserved. linkedu.com 版权所有