• linkedu视频
  • 平面设计
  • 电脑入门
  • 操作系统
  • 办公应用
  • 电脑硬件
  • 动画设计
  • 3D设计
  • 网页设计
  • CAD设计
  • 影音处理
  • 数据库
  • 程序设计
  • 认证考试
  • 信息管理
  • 信息安全
菜单
linkedu.com
导航菜单
  • 网页制作
  • 数据库
  • 程序设计
  • 操作系统
  • CMS教程
  • 游戏攻略
  • 脚本语言
  • 平面设计
  • 软件教程
  • 网络安全
  • 电脑知识
  • 服务器
  • 视频教程
  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx
您的位置:首页 > 服务器 >windows > XAMPP创建域名虚拟目录(php+apache+mysql)

XAMPP创建域名虚拟目录(php+apache+mysql)

作者:网友 字体:[增加 减小] 来源:互联网

本文主要包含xampp apache无法启动,xampp apache启动失败,xampp apache,xampp启动不了apache,xampp apache配置等服务器相关知识,网友希望可以进行参考

我们知道xampp使用的是php+apache+mysql了,所以XAMPP创建域名虚拟目录与apache单独安装是一样的,我们只要对VirtualHost多加几个就行了。

XAMPP是一个可以快速创建网站所需环境(php+apache+mysql)软件,如果项目多的话,用127.0.0.1或者localhost访问比较麻烦而且不容易记忆,可以使用域名虚拟目录来达到快速访问,也可以很好的区分各个项目。

以 WordPress 和 discuz 来做列子,wordpress用wordpress.com来访问,discuz使用discuz.com来访问。

1.下载好源码放置于htdocs文件里面
- /htdocs
- /wordpress
- /discuz
2.打开本地hosts文件(C:/windows/system32/drivers/etc/),在最后添加下面代码:
127.0.0.1 wordpress.com
127.0.0.1 discuz.com
3.编辑XAMPP vhost文件(/xampp/apache/conf/extra/httpd-vhosts.conf)
删除NameVirtualHost *:80前的*号,并在最后添加
## 添加 127.0.0.1 规则,要不然 127.0.0.1 不能使用

 代码如下 复制代码
<VirtualHost *:80>
ServerAdmin webmaster@127.0.0.1.com
DocumentRoot “E:/xampp/htdocs/”
ServerName 127.0.0.1
ErrorLog “logs/127.0.0.1-error.log”
CustomLog “logs/127.0.0.1-access.log” common
</VirtualHost>

## 添加 localhost 规则,要不然 localhost 不能使用

 代码如下 复制代码
<VirtualHost *:80>
ServerAdmin webmaster@localhost.com
DocumentRoot “E:/xampp/htdocs/”
ServerName localhost
ErrorLog “logs/localhost-error.log”
CustomLog “logs/localhost-access.log” common
</VirtualHost>

## 添加 wordpress.com 规则,要不然 wordpress.com 不能使用
## DocumentRoot 为源码目录

 代码如下 复制代码
<VirtualHost *:80>
ServerAdmin webmaster@wordpress.com
DocumentRoot “E:/xampp/htdocs/wordpress”
ServerName hzhuti.com
ErrorLog “logs/wordpress-error.log”
CustomLog “logs/wordpress-access.log” common
</VirtualHost>

## 添加 discuz.com 规则,要不然 discuz.com 不能使用
## DocumentRoot 为源码目录

 代码如下 复制代码
<VirtualHost *:80>
ServerAdmin webmaster@discuz.com
DocumentRoot “E:/xampp/htdocs/discuz”
ServerName www.bKjia.c0m
ErrorLog “logs/discuz-error.log”
CustomLog “logs/discuz-access.log” common
</VirtualHost>

4.重启apache后,众www.hzhuti.com 

分享到:QQ空间新浪微博腾讯微博微信百度贴吧QQ好友复制网址打印

您可能想查找下面的文章:

  • XAMPP创建域名虚拟目录(php+apache+mysql)
  • apache服务无法启动多种方法总结?

相关文章

  • Windows 2003远程桌面登录RPC错误的解决方法
  • Windows服务器下查IIS被挂iframe木马
  • nagios3.2.0搭建过程
  • 垃圾、无用文件无法删除问题的解决办法
  • Windows操作系统下 如何安装Memcache软件
  • Understanding Lync load balance
  • [趣图]恋爱就像TCP连接一样,是不可靠的
  • nginx+php编译安装
  • web集群怎么共享同步session(memcache)
  • Windows下的Memcache安装与测试教程

文章分类

  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx

最近更新的内容

    • UltraISO 制作USB系统启动盘图文教程
    • 自动进入Windows Server 2003系统
    • 负载均衡集群解决方案 (一)LVS-DR
    • 解决Win8在VMware Fusion中使用Wacom笔不正常的问题
    • Windows XP安装Apache环境图文详解
    • 页面提示HTTP错误401.3-未经授权错误解决办法
    • Hyper-V第1代虚拟机和第2代虚拟机特性对照表
    • 七、编写每天定时切割Nginx日志的脚本【LNMP安装 】
    • xcopy本地文件备份与复制到远程服务器
    • windows 2003服务器远程桌面超出最大连接数解决办法

关于我们 - 联系我们 - 免责声明 - 网站地图

©2020-2025 All Rights Reserved. linkedu.com 版权所有