• linkedu视频
  • 平面设计
  • 电脑入门
  • 操作系统
  • 办公应用
  • 电脑硬件
  • 动画设计
  • 3D设计
  • 网页设计
  • CAD设计
  • 影音处理
  • 数据库
  • 程序设计
  • 认证考试
  • 信息管理
  • 信息安全
菜单
linkedu.com
导航菜单
  • 网页制作
  • 数据库
  • 程序设计
  • 操作系统
  • CMS教程
  • 游戏攻略
  • 脚本语言
  • 平面设计
  • 软件教程
  • 网络安全
  • 电脑知识
  • 服务器
  • 视频教程
  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx
您的位置:首页 > 服务器 >windows > Windows IIS 7.5伪静态中文URL地址404错误问题

Windows IIS 7.5伪静态中文URL地址404错误问题

作者:网友 字体:[增加 减小] 来源:互联网

本文主要包含windows iis,windows iis安装,windows10 iis配置,windows7 iis,iis windows server等服务器相关知识,网友希望可以进行参考

下面本文章以wordpress 众iis7到iis7.5是使用tag中文url全部都同现了404错误了,下面我们一起来看此问题解决方法。


空间迁移后,WordPress文章中所有的中文tag页面访问全都报404错误,Google搜索了一下,得知IIS7.5伪静态URL_Rewrite不支持中文,最终在IIS7 WordPress 中文 URL 解决方案博文中找到解决方法,特别感谢原文作者,在此将解决方案再分享一下,希望可以帮到后来的朋友~

在WordPress安装目录下,新建一个“chineseurl.php”文件,内容如下:

 代码如下 复制代码

<?php

// IIS Mod-Rewrite
if (isset($_SERVER['HTTP_X_ORIGINAL_URL'])) {
$_SERVER['REQUEST_URI'] = $_SERVER['HTTP_X_ORIGINAL_URL'];
}
// IIS Isapi_Rewrite
else if (isset($_SERVER['HTTP_X_REWRITE_URL'])) {
$_SERVER['REQUEST_URI'] = $_SERVER['HTTP_X_REWRITE_URL'];
}
else
{
// Use ORIG_PATH_INFO if there is no PATH_INFO
if ( !isset($_SERVER['PATH_INFO']) && isset($_SERVER['ORIG_PATH_INFO']) )
$_SERVER['PATH_INFO'] = $_SERVER['ORIG_PATH_INFO'];

// Some IIS + PHP configurations puts the script-name in the path-info (No need to append it twice)
if ( isset($_SERVER['PATH_INFO']) ) {
if ( $_SERVER['PATH_INFO'] == $_SERVER['SCRIPT_NAME'] )
$_SERVER['REQUEST_URI'] = $_SERVER['PATH_INFO'];
else
$_SERVER['REQUEST_URI'] = $_SERVER['SCRIPT_NAME'] . $_SERVER['PATH_INFO'];
}

// Append the query string if it exists and isn't null
if (isset($_SERVER['QUERY_STRING']) && !empty($_SERVER['QUERY_STRING'])) {
$_SERVER['REQUEST_URI'] .= '?' . $_SERVER['QUERY_STRING'];
}
}

require("index.php");

?>

然后在web.config中新增一条规则,并将此规则置于规则集合的顶部:

 代码如下 复制代码


<rule name="ChineseURL" stopProcessing="true">
 <match url="/(tag|category)/(.*)" />
 <action type="Rewrite" url="chineseurl.php" />
</rule>

效果如下

如果 WordPress 不是装在根目录,则需要更改“<match url=”^(tag|category)/(.*)$” />”为“<match url=”^安装目录/(tag|category)/(.*)$” />”。如果在固定链接设置里把默认的标签前缀和分类目录前缀(tag 和 category)改了,则更改这句里的对应内容即可。

分享到:QQ空间新浪微博腾讯微博微信百度贴吧QQ好友复制网址打印

您可能想查找下面的文章:

  • Windows IIS 7.5伪静态中文URL地址404错误问题
  • Windows IIS 7.5配置二级域名图文详解
  • Windows IIS如何设置CDN的CACHE过期时间
  • windows同时安装apahce和iis教程
  • windows下安装iis7配置php环境图文教程
  • windows让iis7支持php配置方法
  • Windows系统中IIS防盗链设置详细介绍
  • Windows IIS怎么新建站点及绑定域名
  • Windows中IIS7 大文件上传限制解决办法
  • 64位Windows系统配置IIS 7.0+PHP+Mysql图解

相关文章

  • VM配置文件所在分区内存太小导致错误的解决方法
  • windows中关闭135危险端口方法
  • 在CentOS 5上配置NFS服务器
  • 如何降级Windows 2003 server域控制器
  • windows2003系统无盘终端网组建详细教程(1/3)
  • Windows2003 IIS6/7伪静态组件/安装/配置/下载
  • Opera 10 为低速网络优化的优秀浏览器
  • Windows 系统运行命令操作十个技巧
  • Apache中配置最大并发用户数 tcp连接设置方法
  • IE8主页被锁定不能修改的彻底解决方法

文章分类

  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx

最近更新的内容

    • apache 和iis共用80端口多种解决办法
    • 关于nginx中的fastcgi_param
    • PHP与LDAP登录相关 ( Win 2008 R2 Server Domain Controller )
    • iis服务器提示 http错误 500 Internal Server Error解决办法
    • oracle数据库使用nfs存储,启动报错提示无法锁定文件
    • LFTP 软件详解
    • 让虚拟化的风暴 来得再猛烈些吧
    • 怎么修改tomcat默认访问首页
    • liunx基本命令(用户的管理,难点重复介绍)
    • 锐捷找不到网卡或网卡初始化失败的解决方案

关于我们 - 联系我们 - 免责声明 - 网站地图

©2020-2025 All Rights Reserved. linkedu.com 版权所有