• linkedu视频
  • 平面设计
  • 电脑入门
  • 操作系统
  • 办公应用
  • 电脑硬件
  • 动画设计
  • 3D设计
  • 网页设计
  • CAD设计
  • 影音处理
  • 数据库
  • 程序设计
  • 认证考试
  • 信息管理
  • 信息安全
菜单
linkedu.com
  • 网页制作
  • 数据库
  • 程序设计
  • 操作系统
  • CMS教程
  • 游戏攻略
  • 脚本语言
  • 平面设计
  • 软件教程
  • 网络安全
  • 电脑知识
  • 服务器
  • 视频教程
  • vbs
  • DOS/BAT
  • hta/htc
  • python
  • perl
  • VBA
  • ColdFusion
  • ruby
  • PowerShell
  • Lua
  • Golang
  • linux shell
您的位置:首页 > 脚本语言 >linux shell > 建立基于虚拟用户的VSftpd服务

建立基于虚拟用户的VSftpd服务

作者: 字体:[增加 减小] 来源:互联网

通过本文主要向大家介绍了vsftpd虚拟用户,vsftpd虚拟用户配置,vsftpd创建虚拟用户,vsftpd添加用户,vsftpd 用户等相关知识,希望对您有所帮助,也希望大家支持linkedu.com www.linkedu.com

上一篇文章给大家介绍了Linux中搭建FTP服务器的方法,说了vsftpd的基本配置,也就是匿名和本地,这回来说一下配置虚拟用户使用vsftpd,下面是具体步骤:

一、建立虚拟用户口令文件

    可以使用vi命令创建一个用户口令文件,该文件是一个文本文件,其中奇数行为用户,偶数行为用户密码,文件名可以任意,如我建立一个名为login.txt的文件文件里的内容为:

a
abc123~
b
abc123~

其中a和b为用户,abc123~为用户的密码。

二、生成vsftpd口令认证文件

    建立虚拟用户口令文件后,接下来就是使用db_load命令来创建口令认证文件,默认情况下,db_load命令并没有被安装在系统中,该命令在db4_utils软件包中。

liwei@linux# rpm -qa |grep db4-utils

liwei@linux# rpm -vih /media/Server/db4-utils-版本号.rpm

安装上此软件后就可以使用db_load命令来生成口令认证文件了,如下:

liwei@linux# db_load -T -t hash -f login.txt /etc/vsftpd/vsftpuser.db

通过以上命令就在/etc/vsftpd/目录中创建vsftpuser.db口令认证文件了,创建好后为了安全起见我们为它修改一下权限:

liwei@linux# chmod 600 /etc/vsftpd/vsftpuser.db

三、建立虚拟用户所需的PAM配置文件

生成vsftpd口令认证文件后,然后在/etc/pam.d/下新建一个文件并编辑添加两条记录:

liwei@linux# vi /etc/pam.d/vsftpd.v

auth required /lib/security/pam_userdb.so db=/etc/vsftpd/vsftpuser

account required /lib/security/pam_userdb.so db=/etc/vsftpd/vsftpuser

编辑完保存退出。

四、建立虚拟用户访问所需要的目录

    创建好虚拟用户所需的PAM配置文件后,就到了建立虚拟用户的工作环境这一步了,这一步的作用是用来映射所有的虚拟用户,具体命令如下:

liwei@linux# useradd  -s /sbin/nologin virtual  //这一步可以自己使用-d来指定具体目录

liwei@linux# chmod 700 /home/virtual

五、修改vsftpd.conf配置文件

    建立好虚拟用户访问所需要的目录后,就可以修改vsftpd.conf主配置文件了。在配置文件中添加如下选项:

anonymous_enable=NO               
local_enable=YES               
write_enable=YES
anon_upload_enable=NO           
anon_mkidr_write_enable=NO
anon_other_write_enable=NO
chroot_local_user=YES
pam_service_name=vsftpd.v
guest_enable=YES
guest_username=virtual
user_config_dir=/etc/vsftpd/vsftpuser_conf    //为虚拟用户创建单独配置文件,可选

修改完配置文件后,创建虚拟用户单独配置文件目录,然后为用户添加配置文件:

liwei@linux# mkdir /etc/vsftpd/vsftpuser_conf
liwei@linux# mkdir /home/virtual/a
liwei@linux# chown virtual:virtual /home/virtual/a
liwei@linux# vi /etc/vsftpd/vsftpusr_conf/a

在此文件里为a虚拟用户添加单独配置选项:

local_root=/home/virtual/a
anon_world_readable_only=NO
write_enable=YES
anon_upload_enable=YES
anon_mkdir_write_enable=YES
anon_other_wirte_enable=YES

保存退出

使用命令service vsftpd restart重启一下服务。

用同样的方法创建虚拟用户b的配置文件及目录。

六、做完以上这些步骤后,整个实验就OK了,到了测试的时候了,到Windows或linux客户机上试试看能不能使用虚拟用户a和b是否能访问此FTP服务器。

常会出现的错误有:

1.530 Login incorrect    //登录被拒绝

这个错误是由于系统中没有vsftpd的pam文件所导致的,如出现此错误请检查PAM文件

2.500 OOPS: cannot change directory:目录

Login failed

这个错误是你的配置文件里指定的目录名不正确,请检查目录来解决问题。

3.还有一个550错误,一般原因就是因为目录的权限问题而造成的,检查目录的权限应该可以排除。

好了,就这些了,以后遇到再补充吧!

</div>

您可能想查找下面的文章:

  • 建立基于虚拟用户的VSftpd服务

相关文章

  • 实现core文件自动生成配置文件的方法
  • shell实现数字打印从100到200的数
  • Shell脚本判断Linux系统是32位还是64位的几种方法分享
  • Shell中的循环语句for、while、until实例讲解
  • Ubuntu配置NFS的具体流程(推荐)
  • sed初学者实用说明
  • LINUX 生产环境搭建推荐教程
  • Shell脚本8种字符串截取方法总结
  • VPS自动备份数据库到FTP的脚本代码
  • Linux Shell脚本系列教程(七):脚本调试

文章分类

  • vbs
  • DOS/BAT
  • hta/htc
  • python
  • perl
  • VBA
  • ColdFusion
  • ruby
  • PowerShell
  • Lua
  • Golang
  • linux shell

最近更新的内容

    • 基础的Linux Shell技巧小结
    • Shell中的${}、##和%%使用范例
    • Shell脚本实现查找字符串中某字符最后出现的位置
    • Shell中if的基本语法和常见判断用法
    • shell脚本实现随机生成10个8位密码
    • Linux Shell脚本系列教程(四):使用函数添加环境变量
    • Linux用户在第一次登录时强制更改初始密码
    • Shell正则表达式之grep、sed、awk实操笔记
    • Shell常见用法小记
    • Shell编程 Bash引号的那点事

关于我们 - 联系我们 - 免责声明 - 网站地图

©2020-2025 All Rights Reserved. linkedu.com 版权所有