• linkedu视频
  • 平面设计
  • 电脑入门
  • 操作系统
  • 办公应用
  • 电脑硬件
  • 动画设计
  • 3D设计
  • 网页设计
  • CAD设计
  • 影音处理
  • 数据库
  • 程序设计
  • 认证考试
  • 信息管理
  • 信息安全
菜单
linkedu.com
导航菜单
  • 网页制作
  • 数据库
  • 程序设计
  • 操作系统
  • CMS教程
  • 游戏攻略
  • 脚本语言
  • 平面设计
  • 软件教程
  • 网络安全
  • 电脑知识
  • 服务器
  • 视频教程
  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx
您的位置:首页 > 服务器 >云计算 > Llama-impala on yarn的中间协调服务,llama-impalayarn

Llama-impala on yarn的中间协调服务,llama-impalayarn

作者:网友 字体:[增加 减小] 来源:互联网

本文主要包含spark on yarn,mapreduce on yarn,hbase on yarn,tensorflow on yarn,storm on yarn等服务器相关知识,网友希望可以进行参考

Llama-impala on yarn的中间协调服务,llama-impalayarn


本文基于CDH发行版下的Hadoop Yarn和Impala


早期的Impala版本中,为了使用Impala,我们通常会在以Client/Server的结构在各个集群节点启动impala-server、impala-state-store和impala-catalog服务,并且在启动过程中无法动态调整内存和CPU的分配。CDH5之后,Impala开始支持Impala-on-yarn模式,通过一个叫做Llama(Long-Lived Application Master)的中间协调Yarn和Impala,向Hadoop Yarn资源管理器申请计算资源。


1、Llama介绍

Llama(Long-LivedApplicationMaster)是位于ClouderaImpala和HadoopYARN之间,用于协调资源管理的服务系统。在一个Hadoop集群中,Impala可以通过Llama预约、使用以及释放资源分配,以减少执行Impala查询时过多的资源管理用度。只有在Impala中启用资源管理,集群中的Llama服务才真正运作。
默认情况下,YARN根据MapReduce工作的需要按位分配资源,而Impala则需要所有资源在同一时间可用,以保证查询的中间结果能够在不同节点间交换,而不需要拖延查询时间来等待新的资源分配,Llama就是为了在每个Impala查询开始执行前就可保证其需要的资源都可用而出现。
若一个查询执行完毕,Llama会将资源进行缓存,确保在执行Impala子查询时可以使用。这种缓存机制避免了每个查询执行前都需要进行新的资源请求。同时,如果YARN需要该资源用于其他工作,Llama就会将这部分资源还给YARN。
需要注意的是:Llama仅支持YARN,不能与MRv1结合使用,同时,Llama也是通过YARN的配置文件与Hadoop进行协作的。


2、控制计算资源预估

我们提交SQL到Impala后,有时会错误的预估该次查询可能消耗的计算资源,Impala支持用户设置默认的内存和CPU资源申请大小,SQL运行过程中,一旦资源开始紧缺时,Impala会通过Llama向Yarn申请更多的资源来扩展(expanding)当前的预留资源,一旦查询作业完成,Llama通常会将资源还给Yarn。用户可以在启动使用impalad进程时加上-rm_always_use_defaults参数(必选)以及-rm_default_memory=size and -rm_default_cpu_cores(可选),Cloudera官方建议使用Impala-on-yarn时加上这些启动参数,可以让查询资源动态扩展。


3、验证计算资源预估和实际使用

为了使用户能够方便的验证查询语句所使用的集群资源大小,使用EXPLAIN语句可以查询相关内存预估的信息,以及使用到virtual core的大小。使用EXPLAIN并不会真正提交查询


4、资源限制的原理

  CPU限制是通过Linux CGroups机制,Yarn在各个节点启动符合CGroups形式的Container进程

  内存限制是通过限制Impala的查询内存,一旦查询请求被授权,Impala会在执行前设置内存上限

版权声明:本文为博主原创文章,未经博主允许不得转载。

分享到:QQ空间新浪微博腾讯微博微信百度贴吧QQ好友复制网址打印

您可能想查找下面的文章:

  • Llama-impala on yarn的中间协调服务,llama-impalayarn
  • spark on yarn的cpu使用,sparkonyarncpu

相关文章

  • Apriori算法的java实现,apriori算法java
  • Managing Data in Containers,managingcontainers
  • hadoop的namenode无法启动的解决办法,hadoopnamenode
  • Hive 和普通关系数据库的异同,hive关系数据库
  • Cloud Foundry service broker开发部署实例解析(上),foundrybroker
  • 《3》CentOS7.0+OpenStack+kvm云平台部署—配置Glance,《3》kvm
  • 分布式数据库MVCC读写设计,数据库mvcc读写
  • 最笨的方法解决 使用Snappy 压缩方式报错“java.lang.UnsatisfiedLinkError: no snappyjava in java.library.path”,java.library.path
  • hive启动报错 java.net.URISyntaxException: Relative path in absolute URI: ${system:java.io.tmpdir%7D/$%7B,relativeabsolute
  • HBase安装配置

文章分类

  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx

最近更新的内容

    • hadoop集群扩展,hadoop集群
    • hive创建表语句详解,hive语句详解
    • 配置KVM虚拟机的网络,Bridge和Nat方式,kvmnat
    • Hbase Client Test Case,hbasecase
    • MapReduce对输入多文件的处理,mapreduce输入处理
    • Zoho产品经理谈中小企业面临的挑战及应对之策,zoho产品经理
    • hive 如何处理科学计数法,hive处理科学计数
    • storm与hadoop的对比,stormhadoop
    • logstash 学习小记,logstash小记
    • openstack-glance-api.service start request repeated too quickly, refusing to start,openstackglance

关于我们 - 联系我们 - 免责声明 - 网站地图

©2020-2025 All Rights Reserved. linkedu.com 版权所有