• linkedu视频
  • 平面设计
  • 电脑入门
  • 操作系统
  • 办公应用
  • 电脑硬件
  • 动画设计
  • 3D设计
  • 网页设计
  • CAD设计
  • 影音处理
  • 数据库
  • 程序设计
  • 认证考试
  • 信息管理
  • 信息安全
菜单
linkedu.com
导航菜单
  • 网页制作
  • 数据库
  • 程序设计
  • 操作系统
  • CMS教程
  • 游戏攻略
  • 脚本语言
  • 平面设计
  • 软件教程
  • 网络安全
  • 电脑知识
  • 服务器
  • 视频教程
  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx
您的位置:首页 > 服务器 >windows > 基于DRBD构建高可用主从MySQL服务器

基于DRBD构建高可用主从MySQL服务器

作者:网友 字体:[增加 减小] 来源:互联网

本文主要包含heartbeat drbd mysql,drbd mysql,drbd,drbd heartbeat,drbd安装等服务器相关知识,网友希望可以进行参考

前言:构建双节点高可用Mysql服务器,用DRBD个人感觉是比较合适的,只需要两台Server即可,用IP SAN的话先不说SAN的设备,主机也得需要4台,NFS是行不通的。

目标:两台mysql服务器基于drbd构建高可用主从服务器,平时DR1服务器接受请求,DR2基于DRBD数据备份,当DR1出现问题时,DR2接替DR1的工作接受用户请求。

规划:

  1. DR1:172.16.1.16 hostname dr1.laoguang.me 
  2.  
  3. DR2:172.16.1.17 hostname dr2.laoguang.me 
  4.  
  5. VIP:172.16.1.1 

环境:RedHat5.8 内核:2.6.18-308.el5  Selinux已经关闭  Yum 配置完好

注:如果没说在哪台机器上配置则默认是dr1

一.配置准备工作,hostname设置,/etc/hosts解析的与对方hostname -n 一致,ssh互信,时间统一

1.1 hostname设置在dr1上演示设置

  1. hostname dr1.laoguang.me 
  2. vi /etc/hosts  ##添加如下解析 
  3. 172.16.1.16     dr1.laoguang.me dr1  
  4. 172.16.1.17     dr2.laoguang.me dr2  

1.2 ssh互信设置dr1上演示

  1. ssh-keygen -t rsa -P ""     ##回车,生成密钥在/root/.ssh下 
  2. ssh-copy-id -i /root/.ssh/id_rsa.pub dr2   ##公钥拷贝到dr2上,再次登录dr2不需要密码 
  3. 同样dr2也这么设置 

1.3 同步时间(如果有NTP就同步NTP的时间)

  1. date -s 20121127;ssh dr2 'date -s 20121127' 

二.dr1,dr2上安装DRBD

DRBD分为两部分,一部分是工作内核中的模块部分,一部分是工件在用户空间的管理工具,2.6.33以后的内核中已经集成了DRBD的模块,只安装管理工具即可,旧内核需要为内核打补丁才可以,有爱好者把补丁做成了rpm包名字为kmod-drbd,安装它即可,补丁包一定与内核版本一致。下面安装与软件。

2.1 dr1,dr2安装内核补丁与软件 kmod-drbd83-8.3.8-1.el5.centos.i686.rpm,drbd83-8.3.8-1.el5.centos.i386.rpm

  1. rpm -ivh kmod-drbd83-8.3.8-1.el5.centos.i686.rpm 
  2. rpm -ivh drbd83-8.3.8-1.el5.centos.i386.rpm 
  3. rpm -ql drbd83     ##查看生成文件 

2.2 配置DRBD注如果没说在哪台机器上配置则默认是dr1)

/etc/drbd.conf 为主配置文件,它把/etc/drbd.d下子配置文件包含进来,通过查看drbd.conf我们可以发现一样例文件/usr/share/doc/drbd83-8.3.8/drbd.conf,用它覆盖这个空的配置文件。

  1. cp /usr/share/doc/drbd83-8.3.8/drbd.conf /etc/ 

编辑/etc/drbd.d/global_common.conf 这个全局配置文件如下:

  1. global { 
  2.         usage-count no; 
  3.         # minor-count dialog-refresh disable-ip-verification 
  4.     } 
  5.  
  6.     common { 
  7.         protocol C; 
  8.  
  9.         handlers { 
  10.                 用默认即可 
  11.         } 
  12.  
  13.         startup { 
  14.                 #wfc-timeout 120; 
  15.                 #degr-wfc-timeout 120; 
  16.         } 
  17.  
  18.         disk { 
  19.                 on-io-error detach;           ##IO错误的处理方法 
  20.                 #fencing resource-only; 
  21.         } 
  22.  
  23.         net { 
  24.                 cram-hmac-alg "sha1";         ##指定校验算法,校验是为保证数据完整 
  25.                 shared-secret "laoguang.me";  ##指定校验密码 
  26.         } 
  27.  
  28.         syncer { 
  29.                 rate 1000M;                   ##指定同步时用多少带宽 
  30.         } 
  31.     } 

2.3 dr1,drs上创建大小一样的分区,不演示了

dr1上的为/dev/sda5 1G    ##注:记的partprobe,不要格式化

dr2上的为/dev/sda5 1G

2.4 为DRBD添加磁盘资源

  1. vim /etc/drbd.d/mysql.res 
  2.     resource mysql { 
  3.         on dr1.laoguang.me { 
  4.         device    /dev/drbd0;        ##DRBD用的设备 
  5.         disk      /dev/sda5;         ##映射的磁盘 
  6.         address   172.16.1.16:7789;  ##drbd启动后监听端口7789 
  7.         meta-disk internal;          ##元数据存放 
  8.         } 
  9.         on dr2.laoguang.me { 
  10.    
分享到:QQ空间新浪微博腾讯微博微信百度贴吧QQ好友复制网址打印

您可能想查找下面的文章:

  • 基于Drbd+Corosync构建高可用Mysql服务器
  • 搭建基于Corosync+DRBD的高可用MySQL集群
  • 基于DRBD构建高可用主从MySQL服务器

相关文章

  • 海鑫科金:立足多生物识别 共赢发展
  • Windows 2003与2008远程连接服务器设置图解
  • 一个IO的传奇一生 (6) --
  • 安装DHCP服务
  • 休眠文件hiberfil.sys有什么作用 如何清除?
  • 正则表达式和grep的基本用法9
  • Win2003+IIS6+PHP5.33(FastCGI)+MySQl5.1.50安装配置
  • 怎么修改windows2003服务器密码
  • GoDaddy Windows启用Gzip压缩配置方法
  • apache 和iis共用80端口多种解决办法

文章分类

  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx

最近更新的内容

    • VMware tools下载与VMware tools安装方法
    • windows2003 IIS6的配置备份与还原
    • memached启动报错
    • 企业shell脚本分析及切割apache日志实战
    • Windows下搭建PHP+MySQL+IIS环境
    • FTP连接错误:PASV模式失败&数据socket 错误
    • 微软提供正确卸载IE7的方法并恢复IE6
    • windows服务器IIS主机禁用不安全组件方法
    • oracle数据库表空间文件迁移
    • Apache报错 0x6eec38dc 指令引用的 0x00000000 内存不能为 read

关于我们 - 联系我们 - 免责声明 - 网站地图

©2020-2025 All Rights Reserved. linkedu.com 版权所有