• linkedu视频
  • 平面设计
  • 电脑入门
  • 操作系统
  • 办公应用
  • 电脑硬件
  • 动画设计
  • 3D设计
  • 网页设计
  • CAD设计
  • 影音处理
  • 数据库
  • 程序设计
  • 认证考试
  • 信息管理
  • 信息安全
菜单
linkedu.com
导航菜单
  • 网页制作
  • 数据库
  • 程序设计
  • 操作系统
  • CMS教程
  • 游戏攻略
  • 脚本语言
  • 平面设计
  • 软件教程
  • 网络安全
  • 电脑知识
  • 服务器
  • 视频教程
  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx
您的位置:首页 > 服务器 >windows > Win2003部署asp.net生成word的常见问题

Win2003部署asp.net生成word的常见问题

作者:网友 字体:[增加 减小] 来源:互联网

本文主要包含win2003 asp,win2003 asp.net,win2003 iis asp,安卓模拟器win2003,win2003等服务器相关知识,网友希望可以进行参考

  烈火建站学院(Bkjia.Com)服务器教程 服务器(WIndows2003)部署asp.net网站生成word文档经常遇到的问题!

  (1)将网站发布到远程服务器,出现了问题,web.config 找不到Microsoft.Office.Interop.Word,而远程服务器已经安装了word2003了。

   错误原因:在网站上有word模板生成word 的功能。

  解决办法:

  下载OFFICE IPA 安装,地址:http://www.mydown.com/soft/utilitie/others/107/439607.shtml

  (2)检索 COM 类工厂中 CLSID 为 {000209FF-0000-0000-C000-000000000046} 的组件时失败,原因是出现以下错误: 80070005。

  错误原因:不能向word写数据。

  解决办法:一、

  开始--》控制面板--》管理工具--》组件服务--》计算机--》我的电脑--》Dcom配件 找到Miscrosoft word2003 右键属性弹出"Microsoft   word应用程序属性"对话框,点击"标识"标签,选择"交互式用户",点击"安全"标签,在"启动和激活权限"上点击"自定义",然后点击对应的"编辑"按钮,在弹出的"安全性"对话框中填加一个"NETWORK   SERVICE"用户(注意要选择本计算机名),并给它赋予"本地启动"和"本地激活"权限.依然是"安全"标签,在"访问权限"上点击"自定义",然后点击"编辑",在弹出的"安全性"对话框中也填加一个"NETWORKSERVICE"用户,然后赋予"本地访问"权限.

  这样,我们便配置好了相应的word的DCOM权限.

  (其他系统:操作相同,添加ASP.NET账户和IUSER_计算机名)

  解决办法:二、

  在web.config中使用身份模拟,在 <system.web>节中加入 

以下为引用的内容:
<identity impersonate="true" userName="你的用户名" password="密码"/> </system.web>

分享到:QQ空间新浪微博腾讯微博微信百度贴吧QQ好友复制网址打印

您可能想查找下面的文章:

  • Win2003部署asp.net生成word的常见问题

相关文章

  • 浅析云存储服务安全问题
  • LFTP 软件详解
  • 检查你的电脑是否支持64位操作系统
  • Windows无法查询DllName注册表项它将不会被加载
  • Windows 2003 服务器的实用安全设置
  • 搭建基于Corosync+Pacemaker+NFS的高可用Web集群
  • IIS应用程序池自动停止/关闭/假死网提示 Service Unavailable解决办法
  • PHP与LDAP登录相关 ( Win 2008 R2 Server Domain Controller )
  • FC-SAN和IP-SAN
  • windows服务器iis6+php+mysql的安装配置详解

文章分类

  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx

最近更新的内容

    • Windows Server 2008 安装 IIS 7.0图文详解
    • windows中关闭137,138,139危险端口方法
    • oracle数据库表空间文件迁移
    • Hadoop和HBase集群的JMX监控
    • VM虚拟机提示operating system not found的解决方法
    • windows2008允许多用户同时登录
    • EqualLogic控制器算法研究一:基本管理
    • windows2003中带$符号的用户无法删除
    • xcopy本地文件备份与复制到远程服务器
    • nginx main和events模块学习

关于我们 - 联系我们 - 免责声明 - 网站地图

©2020-2025 All Rights Reserved. linkedu.com 版权所有