• linkedu视频
  • 平面设计
  • 电脑入门
  • 操作系统
  • 办公应用
  • 电脑硬件
  • 动画设计
  • 3D设计
  • 网页设计
  • CAD设计
  • 影音处理
  • 数据库
  • 程序设计
  • 认证考试
  • 信息管理
  • 信息安全
菜单
linkedu.com
导航菜单
  • 网页制作
  • 数据库
  • 程序设计
  • 操作系统
  • CMS教程
  • 游戏攻略
  • 脚本语言
  • 平面设计
  • 软件教程
  • 网络安全
  • 电脑知识
  • 服务器
  • 视频教程
  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx
您的位置:首页 > 服务器 >windows > IIS开启Gzip失败的决方法和如何开启gzip

IIS开启Gzip失败的决方法和如何开启gzip

作者:网友 字体:[增加 减小] 来源:互联网

本文主要包含iis开启gzip,iis gzip,iis gzip压缩,开启gzip压缩,开启gzip等服务器相关知识,网友希望可以进行参考

开启 gzip是对服务器带宽和性能的一个均衡了,gzip会压缩传输文件这样可以节省不少带宽的,但同样会增加服务器处理负载了,这个大家可自己去均衡。

 

先说明下服务器环境:Windows2003+IIS+PHP+ISAPI Rewrite,检查iis的配置内容没有任何问题,但查询HTTP状态都是未开启Gzip状态,今天在访问服务器上一个Discuz论坛的时候底部一行信息: Gzip On。灵光一闪,难道是PHP自带的的Gzip与IIS的冲突?赶紧动手测试,打开PHP配置文件,将php_zip.dll的extension关闭,重启IIS。

上面的操作完成后,检测状态,现在已经是开启了Gzip的状态了。原来那个Gzip开启的批处理文件没有任何问题,问题在于PHP也开启了Gzip,IIS再开的时候冲突了

开启gzip方法

直接一点的方式通过命令行执行如下命令启用对动态/静态内容的压缩输出:

appcmd set config /section:urlCompression /doDynamicCompression:Trueappcmd set config /section:urlCompression /doStaticCompression:True添加一个新的 Web Service Extension (如果原来没有的话) ,输入 gzip.dll 的全路径 。

IIS 6.0 上压缩额外的文件扩展名
修改 MetaBase.xml 文件中 HcFileExtensions 添加额外的文件扩展名。

IIS 7.0 上压缩额外的文件扩展名
修改 ApplicationHost.config 文件,添加合适的 mimeType 并指定激活. 打开文件参考原有的行照葫芦画瓢就成。可能要设置多次才会成功

分享到:QQ空间新浪微博腾讯微博微信百度贴吧QQ好友复制网址打印

您可能想查找下面的文章:

  • IIS中启用Gzip压缩传输网页方法
  • IIS开启Gzip失败的决方法和如何开启gzip
  • iis启用GZIP压缩Css javascript文件无效的原因及解决
  • IIS环境启用GZip压缩方法图文详解
  • IIS启用GZip失败之原因:临时目录权限没设好

相关文章

  • 开启电脑睡眠功能,大大提高工作效率
  • 远程桌面连接服务器和修改远程端口图解
  • IIS环境启用GZip压缩方法图文详解
  • windows中关闭135危险端口方法
  • windows200/2003/2008中安装sqlserver 2000图文教程
  • Windows 2003 中密钥无效解决方法
  • Windows 2003中IIS不支持FLV视频文件
  • Win7/Windows2003下IIS6.0、IIS7.5的伪静态组件ISAPI_Rewrite安装和伪静态配置方法
  • postfix+mysql+dovecot+extmail/extman+sasl+ssl构架
  • apache服务无法启动多种方法总结?

文章分类

  • windows
  • 服务器硬件
  • 服务器运维
  • 云计算
  • 虚拟化
  • IIS教程
  • Linux
  • Apache
  • Ftp
  • DNS
  • Nginx

最近更新的内容

    • 二、安装PHP 5.2.14(FastCGI模式)【LNMP安装 】
    • Windows与Linux中生成以当前时间命名的文件
    • IIS7文件上传的最大大小设置
    • windows 2003 无法开启Terminal Service
    • 禁止Windows Server 2008 R2密码过期提示
    • VM虚拟机vmware下安装Ghost XP的图文教程
    • liunx基础命令(vim编辑文件)
    • Apache报错 0x6eec38dc 指令引用的 0x00000000 内存不能为 read
    • 如何查看Windows服务所对应的端口?
    • 基于DRBD构建高可用主从MySQL服务器

关于我们 - 联系我们 - 免责声明 - 网站地图

©2020-2025 All Rights Reserved. linkedu.com 版权所有